Forum

Results 1 to 8 of 8
  1. #1
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404

    Solved [fixed] Client crashes when entering a channel too early

    Hi,

    We have a public TS3 server with 800+ channels (klanok.hu). It takes some time to load all of the channels, icons, users. If I try to switch channel immediately after connecting to the server, the client closes without any warning or crash report:

    Last 4 lines of log:

    Code:
    2010-06-19 01:52:21.286132|WARNING |StringHelp    |   | Invalid UTF-8 string passed to function, returning as-is
    2010-06-19 01:52:21.286132|INFO    |ClientUI      |   | Last update check was: Szo jún. 19 01:35:28 2010
    2010-06-19 01:52:23.474609|INFO    |PreProSpeex   |  1| Speex version: speex-1.2beta3
    2010-06-19 01:52:24.886718|CRITICAL|TreeModel     |  1| Already in use clID in addItem, clID was: 131
    Is it possible to display a loader, or loader animation and deny access to channels / functions during the loading process? This was a request some months ago already: http://forum.teamspeak.com/showthread.php?t=51399

    Another problem: if I close the client after visiting a large server it takes 10-20 seconds (!) before I can start TS3 again. My PC calculating something in the background very heavily. (Core2Duo 3Ghz, not slow machine) This happens on tabs too. (If I'm connected multiple servers, if I close a server tab, TS3 client freezes for about 5-10 seconds before that server tab really closes and I can take control over the client)
    Last edited by Slater; June 19th, 2010 at 10:28 AM.

  2. #2
    Join Date
    June 2008
    Posts
    18,409
    I can't reproduce this bug.sure the lcient is heavy loading, when all channels are subscribed. But it does not crash, when i switch the channel during that.

    It would be nice if we can isolate the crash and UTF-8 Bug.

  3. #3
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    UTF-8 bug happens only when I start the client.

  4. #4
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    New info: Client crashes if I there is a Server Query user in the channel I try to connect to. (for example a BOT). If I move the BOT into another room, I can switch to that channel without problem.

    Another strange behavior:
    User permissions loads AFTER the full channel list is loaded. Is it OK?! If I'm fast enough the server ask me to enter a password for a password protected room however I have SA rights. (of course one seconds later my SA permission loads so I can enter without password) If you can't change this behavior I think a loader is necessary for the client.
    Last edited by Slater; June 28th, 2010 at 05:48 PM.

  5. #5
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404
    Hi,

    Stefan1200 suggested that the client maybe doesn't crash if "Show ServerQuery Clients" is disabled. He was right! If I disable this option the client doesn't CTD.

  6. #6
    Join Date
    December 2009
    Location
    Hungary
    Posts
    404

    [BUG]Client crashes when entering a channel too early

    Hi,

    If I enter a channel immediately after connecting to a server (berfore my permissions loads) and there is a Query Client (for example a BOT) inside of that channel, the client crashes to desktop without error. If I disable "Show ServerQuery Clients" there is no problem.

    Please see this thread: http://forum.teamspeak.com/showthread.php?t=55696

  7. #7
    Join Date
    June 2008
    Posts
    18,409
    We are able to reproduce this, It's now on Dev's todo.

  8. #8
    Join Date
    June 2008
    Location
    Krün, Germany
    Posts
    510
    Fixed. Thanks for the report and to our testers for being persistent enough to get this resolved. :-)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Client Notification upon entering a Channel with LUA
    By Morganus in forum Client Plugins / Lua Scripts
    Replies: 3
    Last Post: April 8th, 2015, 10:43 AM
  2. Replies: 3
    Last Post: June 21st, 2014, 08:20 PM
  3. [Fixed? Channel Client Permissions Icon ID
    By -{HGH}-GEN.Skylab in forum Bug Reports [EN/DE]
    Replies: 5
    Last Post: December 1st, 2010, 06:46 PM
  4. [Fixed] Channel to client permission
    By florian_fr40 in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: October 18th, 2010, 11:55 AM
  5. [Fixed] Client crashes when opening Options window (Linux)
    By Coredump in forum Bug Reports [EN/DE]
    Replies: 4
    Last Post: August 5th, 2010, 06:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •