Forum

Results 1 to 8 of 8
  1. #1
    Join Date
    December 2007
    Location
    Germany
    Posts
    6

    Restarting after Server Crash

    Hi,
    i updated my server to opensuse 11.3 after my old 11.0 gets crashed. I took my copy of the ts3 folder and copyied to the old path with the same user and same permissions as before. After i want to start the Server with the ts user it aborted with :

    :/srv/ts3> ./ts3server_startscript.sh start
    ts3server.pid found, but no server running. Possibly your previously started server crashed
    Please view the logfile for details.
    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file
    :/srv/ts3> 2010-07-28 13:31:38.965658|CRITICAL|VirtualSvrMgr | | unable to start filemanager, while creating directory : files failed

    Do you have any suggestions whats missing or whats happening ?
    The filesystem looks like normal - exactly 100% Copy.

    Files folder :

    drwx------ 3 ts users 4096 6. Jul 08:45 files

    :/srv/ts3/files/virtualserver_1> l

    drwx------ 2 ts users 4096 6. Jul 08:45 channel_1/
    drwx------ 2 ts users 4096 6. Jul 08:45 channel_27/
    drwx------ 2 ts users 4096 6. Jul 08:45 channel_29/
    drwx------ 2 ts users 4096 6. Jul 08:45 channel_30/
    drwx------ 2 ts users 4096 6. Jul 08:45 channel_31/
    drwx------ 2 ts users 4096 6. Jul 08:45 channel_32/
    drwx------ 2 ts users 4096 6. Jul 08:45 channel_34/
    drwx------ 2 ts users 4096 6. Jul 08:45 channel_35/
    drwx------ 2 ts users 4096 6. Jul 08:45 channel_36/
    drwx------ 2 ts users 4096 6. Jul 08:45 channel_4/
    drwx------ 2 ts users 4096 6. Jul 08:45 channel_5/
    drwx------ 3 ts users 4096 6. Jul 08:45 internal/

    same problem with root user ... so there should be no permission problem.

    Thanks for Feedback
    Last edited by Testy; July 28th, 2010 at 04:17 PM.

  2. #2
    Join Date
    December 2007
    Location
    Germany
    Posts
    6
    No one has any suggestions ?

  3. #3
    Join Date
    May 2010
    Posts
    6,310
    Hello

    Little idea, can you show us the result for "ls -al" command in the virtualserver folder.

    Just for see the permission for "./" and "../" folder

  4. #4
    Join Date
    December 2009
    Location
    The Game!
    Posts
    236
    You could try the following :
    Backup your files folder and then delete the folder while your TSserver is turned off.
    Then start your server, usually it should re-create the directories automatically and you can copy your files back in.

  5. #5
    Join Date
    December 2007
    Location
    Germany
    Posts
    6
    Hi,

    :/srv/ts3 # ls -al
    insgesamt 7308
    drwxr-xr-x 8 ts users 4096 28. Jul 16:30 .
    drwxr-xr-x 5 ts users 4096 28. Jul 16:14 ..
    -rw------- 1 ts users 47 28. Jul 16:30 .bash_history
    -rw-r--r-- 1 ts users 21668 6. Jul 08:45 CHANGELOG
    drwxr-xr-x 2 ts users 4096 6. Jul 08:45 doc
    drwx------ 3 ts users 4096 6. Jul 08:45 files
    -rwxr-xr-x 1 ts users 207986 6. Jul 08:45 libts3db_mysql.so
    -rwxr-xr-x 1 ts users 840714 6. Jul 08:45 libts3db_sqlite3.so
    -rw-r--r-- 1 ts users 24099 6. Jul 08:44 LICENSE
    -rw------- 1 ts users 891 6. Jul 08:45 licensekey.dat
    drwx------ 2 ts users 4096 28. Jul 16:16 logs
    -rw-r--r-- 1 ts users 1 6. Jul 08:45 query_ip_blacklist.txt
    -rw-r--r-- 1 ts users 10 6. Jul 08:45 query_ip_whitelist.txt
    -rw-r--r-- 1 ts users 112 6. Jul 08:45 serverkey.dat
    drwxr-xr-x 2 ts users 4096 6. Jul 08:45 serverquerydocs
    drwxr-xr-x 4 ts users 4096 6. Jul 08:45 sql
    -rwxrwxrwx 1 ts users 478 6. Jul 08:45 ts3backup.sh
    -rwxr-xr-x 1 ts users 5558284 6. Jul 08:45 ts3server_linux_x86
    -rwxr-xr-x 1 ts users 328 6. Jul 08:45 ts3server_minimal_runscript.sh
    -rw-r--r-- 1 ts users 729088 28. Jul 16:16 ts3server.sqlitedb
    -rwxr-xr-x 1 ts users 2731 6. Jul 08:45 ts3server_startscript.sh
    :/srv/ts3 #

    I've tryed to delete the files folder, but nothing changed - same problem.

  6. #6
    Join Date
    December 2007
    Location
    Germany
    Posts
    6
    Running as root -> no Change

    starch on the .sh gives some more information :

    ..
    open("/dev/tty", O_RDWR|O_NONBLOCK) = -1 EACCES (Permission denied)
    ..

  7. #7
    Join Date
    December 2007
    Location
    Germany
    Posts
    6
    No suggestions ?

  8. #8
    Join Date
    December 2009
    Location
    Germany
    Posts
    226
    perhaps apparmor or SELinux? AFAIK being root doesn't help against that... IIRC suse/novell developed apparmor, so it would be just normal that they have it activated in their distribution.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. restarting server strange log
    By ZoeFken in forum Server Support
    Replies: 2
    Last Post: October 12th, 2014, 02:22 AM
  2. restarting the server
    By Meriana in forum Linux / FreeBSD
    Replies: 6
    Last Post: January 21st, 2013, 02:16 AM
  3. Restarting Server
    By Schmitty in forum Server Support
    Replies: 0
    Last Post: January 24th, 2010, 12:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •