Forum

Results 1 to 12 of 12
  1. #1
    Join Date
    August 2006
    Location
    Gloucestershire, UK
    Posts
    7

    Exclamation Creative Software Causing Teamspeak Problems

    Hey,
    I am having a problem with when using Creative software and TeamSpeak together (software used is listed below). When I have TeamSpeak running and connected to a server and try to switch between modes (image in attachments), most of TeamSpeak's functions stop working.

    Immediately I am unable to hear any sound. Using my push to talk key doesn't work. Anyone who was speaking at the time will remain with their icon lit up (picture in attachments). If I try to exit the application it will disconnect me from the server and then do nothing.

    I can glance into channels, move channels, send messages (in writing) to other clients ect just fine.

    What did you try to fix the problem?
    I have updated all my sound drivers and Creative software to the latest versions but it has made no difference.

    Extra Details of My system:
    TeamSpeak Client Version: 3.0.0-Beta23 [Build 11937]
    Operating System: Windows 7 Professional 32-Bit
    DirectX Version: DirectX 11
    Sound card: Creative Sound Blaster X-Fi XtremeGamer
    Sound card Driver Version: Creative Sound Blaster X-Fi series Driver 2.18.0015
    Sound Card Software: Creative Console-Launcher Version 2.61.48
    Sound Card Software: Creative Volume Panel Version 2.20.65
    Error Messages:
    No Errors appear in the logs when I try to close the program or when I actually switch modes.

    Log content: connecting to a server, switching modes on Creative Volume panel, quitting the application and then finally ending it through task manager when the program fails to exit:
    Code:
    2010-08-04 18:58:10.097000|INFO    |              |   | Logging started, clientlib version: 3.0.0-beta23 [Build: 11937]
    2010-08-04 18:58:10.481000|INFO    |ClientUI      |   | TeamSpeak 3 client version: 3.0.0-beta23 [Build: 11937]
    2010-08-04 18:58:10.481000|INFO    |ClientUI      |   | Qt version: 4.6.2
    2010-08-04 18:58:10.481000|INFO    |ClientUI      |   | Using configuration location: C:/Users/Jethro/AppData/Roaming/TS3Client/ts3clientui_qt.conf
    2010-08-04 18:58:10.972000|INFO    |ClientUI      |   | Last update check was: Wed 4. Aug 13:50:22 2010
    2010-08-04 18:58:11.079000|INFO    |PreProSpeex   |  1| Speex version: speex-1.2beta3
    2010-08-04 18:58:12.066000|INFO    |ClientUI      |  1| Autosubscribe channel ID: 17
    2010-08-04 18:58:25.585000|INFO    |Bookmarks     |   | Disconnect, total time: 14 - 1001278
    At the moment, the only way I can change modes is to shut down TeamSpeak each time, change the mode and then start TeamSpeak back up otherwise I end up having to go into Task manager to close it down manually and restart it.
    Last edited by Jethro; August 5th, 2010 at 07:48 PM.

  2. #2
    Join Date
    December 2009
    Location
    Germany
    Posts
    56
    Isn't there a warning or at least a strong suggestion in your Mode Switcher screenshot? I think the sentence "It is recommended that you close all audio applications before switching modes." has a reason.

    Btw., I also have the X-Fi XtremeGamer but with DirectX 9.0c and the newest driver 2.18.0013 for Windows XP 32bit and I neither use the Console-Launcher nor the Volume Panel. But when I try to switch the modes via the normal Audio Control Panel when TS is running another warning pops up: "This operation cannot be carried out. This may be because the audio device is in use. Please quit all audio applications and games, and try again."

    IMHO the bottom line is: This behaviour is deeply rooted in the architecture of the sound card itself and therefore cannot be fixed from a TS dev.

  3. #3
    Join Date
    August 2006
    Location
    Gloucestershire, UK
    Posts
    7

    Cool

    Yeah it does say that but with Windows media player it works fine, games work fine and so did TeamSpeak 2 in the past. It's only TeamSpeak 3 which seemed t have the problem but maybe your right.

  4. #4
    Join Date
    June 2008
    Posts
    17,612
    I tryed to reproduce it here, but everything works fine after switching mode.
    The only thing that happens is ,that the whole sound stops for ~1 Second, but that's all.

    Tested with: client beta23 & beta24-pre
    Tested on Windows 7 x64
    Sound card: Creative Sound Blaster X-Fi Platinum Fatal1ty Champion Series
    Sound card Driver Version: Creative Sound Blaster X-Fi series Driver 2.18.0013
    Sound Card Software: Creative Konsole Launcher 2.61.09

    Let me update my unused soundcard. I will retest it with latest driver and update my post here.

    Update
    I retested it with latest drivers available, but nothing changed. Works fine for me.
    Sound card Driver Version: Creative Sound Blaster X-Fi series Driver 2.18.0015
    Sound Card Software: Creative Konsole Launcher 2.61.49
    Last edited by dante696; August 5th, 2010 at 12:10 PM.

  5. #5
    Join Date
    August 2006
    Location
    Gloucestershire, UK
    Posts
    7
    Dam it it would have to be just me that is having this issue

    Well I have previously reinstalled the drivers and all the software to ensure something hasn't become corrupted but doing that didn't work.
    Ill try the new Creative Console Launcher: 2.61.49 that was released today but I dought it will make a difference.
    Yep, TeamSpeak 2 worked fine on this found card and only made that audible clicking noise which is normal...

    Edit:
    Nope made no difference at all... Must be this sound card in particular or something that has been overlooked. Is anyone else using the same setup as me that can verify it is/isnt working?
    Thanks,
    Last edited by Jethro; August 5th, 2010 at 06:19 PM.

  6. #6
    Join Date
    June 2008
    Posts
    17,612
    I was able to reproduce it once (tryed it ~40 times), while a music bot was streaming and i was talking.
    I think this can't be fixed. The only workaround i have for you is:
    Click on your Server tab and remove the playback and capture profile and then put it back on.

  7. #7
    Join Date
    August 2006
    Location
    Gloucestershire, UK
    Posts
    7
    I don't understand why its only my sound card that's doing this. My TeamSpeak will bugger up every time I change modes even without anyone speaking. Suppose its not going to be fixed any time soon so I will take your advice and remove the capture profile each time,
    thanks

  8. #8
    Join Date
    December 2010
    Location
    Germany
    Posts
    8

    Lightbulb Possible solution to get rid of TS3 blocking other application's sound

    Hi everbody,

    I think I've found a solution to the issue that Teamspeak3 blocks the sound of other applications. This fix unfortunately only works on Creative Cards and only with Headphone-mode enabled, but as far as I found out, this problem only occurs to Creative-users anyway, so who cares

    1. Start up your Creative Console Launcher and switch to Gamemode if not yet selected.
    2. With headphones selected as audio mode, click on "Settings" at the bottom.
    3. In the window that opens, select the "Headphones"-Layer and uncheck both of the settings.


    Your sound should be fixed by now, atleast it is for me.

    regards

  9. #9
    Join Date
    November 2009
    Location
    Helgoland
    Posts
    23
    I found out is a problem with the CMSS3D for Headphones which is blocking other applications.

    The solution is also to switch the API, best is a direct signal to the card, the Creative ASIO driver is working fine for me and no more blocking problems.

    But a year after offical beta release and no solution from the dev side is a poor support, also if they think it is not their fault, it is in fact a problem for many users.

  10. #10
    Join Date
    December 2010
    Location
    Germany
    Posts
    8
    The solution provided by me should work, even with CMSS-3D enabled.
    Did you try it?

    By doing what I suggested above, my sound is now totally fixed, that means CMSS-3D enabled with headphone-mode and no sound issues at all.

    regards

  11. #11
    Join Date
    November 2009
    Location
    Helgoland
    Posts
    23
    Quote Originally Posted by 123justin321 View Post
    The solution provided by me should work, even with CMSS-3D enabled.
    Did you try it?

    By doing what I suggested above, my sound is now totally fixed, that means CMSS-3D enabled with headphone-mode and no sound issues at all.

    regards
    Hehe yeah it is clear that this works, but then you dont get the CMSS3D enabled enviroment for headphones, which is very usefull in games to create a virtual 3d enviroment on headphones.

  12. #12
    Join Date
    December 2010
    Location
    Germany
    Posts
    8
    Idk, for me there still is CMSS-3D?

    I can, without a problem, say where the enemy is coming from in (for example) Call of Duty 4.


    EDIT: Keep in mind that I DO USE headphone mode, I just disabled the function that Creative Software automatically switches to headphone mode when a headset is plugged in. Anyway, this feature is kinda overall useless for me since I never use any other sound mode than Headphones, since I do not even own any soundsystem apart from my headphones

    regards

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with creative pci512
    By Mardake in forum Windows
    Replies: 3
    Last Post: May 28th, 2010, 05:03 PM
  2. Replies: 3
    Last Post: January 19th, 2010, 08:27 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •