Forum

Results 1 to 13 of 13
  1. #1
    Join Date
    August 2010
    Location
    Finland
    Posts
    6

    Solved [Solved] Server crashes upon client connect (3.0.0-beta26 on Mac OS X 10.5)

    Hi,

    just upgraded TS3 server to latest beta26 from older beta17 and now when clients connect the server crashes on me with error message:

    server/serverlib/ts3IPCountryLookup.cpp:39452: failed assertion `(unsigned int)(node - (unsigned char*)m_IpBTree) < (NODECOUNT*NODESIZE)'
    Abort trap

    anyone else seen this? I can't go back to the older beta (which worked fine) since the users are using new clients that don't work with the old version.

    Sami

  2. #2
    Join Date
    December 2009
    Location
    Dublin, Ireland
    Posts
    379
    there was a beta version above 17 ( not sure which ) which required you to address specific values to the groups in ts, the update that followed worked only if you had assigned the values to the groups. So it looks like you skipped this important update and have screwed your settings because of it. i think you need a fresh install of beta 26.

  3. #3
    Join Date
    August 2010
    Location
    Finland
    Posts
    6
    resetting configuration had no effect. TS3 server still crashes on client connect:

    server/serverlib/ts3IPCountryLookup.cpp:39452: failed assertion `(unsigned int)(node - (unsigned char*)m_IpBTree) < (NODECOUNT*NODESIZE)'
    Abort trap

    I did remove all previous installations and restarted from beginning. No help. Symptoms are the same.

    Sami

  4. #4
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    Please retest with server beta27 and report.
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  5. #5
    Join Date
    August 2010
    Location
    Finland
    Posts
    6
    error message changed a bit, but beta27 still crashes on client connect:

    2010-08-07 15:22:58.977306|CRITICAL| | | assert failed in getCountryFor(84.249.8.241). offset=985472 max=636032

    did not reset configuration this time. should I?

    Sami

  6. #6
    Join Date
    June 2010
    Location
    Aalst
    Posts
    3
    Got the same thing going on

    All worked fine on beta 25.

    Beta 26 did strange things after update it didn't work. After simple reboot it worked and today i got: server/serverlib/ts3IPCountryLookup.cpp:39452: failed assertion `(unsigned int)(node - (unsigned char*)m_IpBTree) < (NODECOUNT*NODESIZE)'
    Abort trap

    And beta 27 i get: 2010-08-08 17:01:30.850228|CRITICAL| | | assert failed in getCountryFor(213.118.157.153). offset=1313088 max=636032


    *Just went back to beta25 and all works fine.
    Last edited by Bindi; August 8th, 2010 at 07:42 PM.

  7. #7
    Join Date
    August 2010
    Location
    Finland
    Posts
    6
    is beta25 available somewhere? I missed to download it.

    Sami

  8. #8
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    bindi, are you using osx as well?

    What hardware are you (both) using? ppc or intel
    Last edited by nwerensteijn; August 9th, 2010 at 08:07 AM. Reason: add hardware question

  9. #9
    Join Date
    August 2010
    Location
    Finland
    Posts
    6
    Hi,

    I'm running on Mac OS X 10.5.8 on my PPC Mac mini.

    and I found the beta25 package from 4netplayers.de. going to try that out next.

    Sami

  10. #10
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    Hey,

    we have a fix ready for you, please download and test:

    http://ftp.4players.de/pub/hosted/ts...odo-so/server/

    Awaiting your feedback.
    You think my answer is stupid ? Read This:
    http://www.catb.org/~esr/faqs/smart-...ons.html#intro

    In a world without fences and walls - who needs windows and gates ?

  11. #11
    Join Date
    June 2010
    Location
    Aalst
    Posts
    3
    I'm using an ppc Mac Mini. with Mac OSX 10.5.8 on it.

    Going to try out that solution this evening.

    I'll get to you when it's done

  12. #12
    Join Date
    June 2010
    Location
    Aalst
    Posts
    3
    Peter thx dude.

    The beta28_pre works like a charm

  13. #13
    Join Date
    August 2010
    Location
    Finland
    Posts
    6
    yes. beta28-pre solved the issue with crashing upon client connect.

    Sami

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: December 28th, 2013, 10:03 PM
  2. [solved] NPL License wont work after update beta26
    By Look_Up in forum Linux / FreeBSD
    Replies: 3
    Last Post: August 6th, 2010, 03:33 AM
  3. Replies: 3
    Last Post: August 5th, 2010, 04:56 PM
  4. Replies: 4
    Last Post: August 2nd, 2010, 03:42 PM
  5. Replies: 8
    Last Post: March 9th, 2010, 11:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •