Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    August 2010

    Unhappy Failed to connect to server

    I have Vista Home Edition and have been using Teamspeak3 for quite some time. It started lagging about a week ago every time I got on. Would reboot machine and sometimes was fine and sometimes not, then I started loosing connection to only Teamspeak. Other users of server are not having any issues. Today it said I lost connection even though I have an internet connection and when I tried to log back on it said Failed to connect to Server. I have rebooted and tried over and over, no connection. So I uninstalled and reinstalled. Still no connection. Any suggestions?

  2. #2
    Join Date
    May 2010

    Have you try to start teamspeak as admin (right click => "Start as Adminnistrator") ?

  3. #3
    Join Date
    June 2008
    What is your ping to that server and is there any kind of packet loss?
    did the server change it's IP?
    Are you using a LAN cable or wireless network?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: November 1st, 2015, 11:06 AM
  2. Replies: 1
    Last Post: September 20th, 2015, 11:09 AM
  3. Replies: 0
    Last Post: August 6th, 2015, 01:16 AM
  4. Replies: 0
    Last Post: January 3rd, 2015, 07:41 PM
  5. Replies: 12
    Last Post: September 1st, 2014, 05:20 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts