Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 8 of 8
  1. #1
    Join Date
    December 2009
    Location
    Norway
    Posts
    16

    Solved [Fixed] Invalid UTF-8 string passed to function, returning as-is

    Hi I am getting this warning all the time in my client.. (well all my friends also get this)...
    Currently using 3.0.0-beta18 build 10609, but I have had this since beta 5 or something...

    Is there a solution to this?

    2010-04-05 00:02:16.742974 StringHelp Warning Invalid UTF-8 string passed to function, returning as-is

    System: Win7 x64 English language, Local settings Norwegian
    Last edited by HotRod; April 5th, 2010 at 01:55 AM. Reason: Aditional info

  2. #2
    Join Date
    June 2008
    Posts
    18,513
    Do you know when this error appears? And is there a special character in a profile name or something?

  3. #3
    Join Date
    December 2009
    Location
    FRANCE - Loire
    Posts
    13
    Same here.
    Server: Beta 26
    Client: Beta 23

    Image: http://www.funstargate.com/media/Athar/TS-warning.png

    PS: IP on demand.

    Update: This error is show at the Startup of TS3, before ANY connections.

  4. #4
    Join Date
    February 2010
    Location
    switzerland
    Posts
    6

    Invalid UTF-8 string passed to function, returning as-is

    Each time I start TS3 Client, I find the following warning in client log :
    Invalid UTF-8 string passed to function, returning as-is
    I can reproduce this error by this way :

    1. Make a copy of ts3clienttui_qt.conf
    Under Windows XP you will find this file in directory
    C:\Documents and Settings\[UserName]\Application Data\TS3Client

    2. delete file ts3clienttui_qt.conf
    3. Start TS3 Client

    A new file ts3clienttui_qt.conf has been created,
    and in section [General] you will find a line like this :
    [email protected](\0\0\0\x10\0%wx\x2}\x98s\ xff)
    Client log show no error :
    Code:
    Logging started, clientlib version: 3.0.0-beta25 [Build: 11999]
    TeamSpeak 3 client version: 3.0.0-beta25 [Build: 11999]
    Qt version: 4.6.2
    Using configuration location: C:/Documents and Settings/[UserName]/Application Data/TS3Client/ts3clientui_qt.conf
    Last update check was: 
    Checking for updates...
    Update check, my version: 11999, latest version: 11999
    4. Exit & restart TS3 Client

    Code:
    Logging started, clientlib version: 3.0.0-beta25 [Build: 11999]
    TeamSpeak 3 client version: 3.0.0-beta25 [Build: 11999]
    Qt version: 4.6.2
    Using configuration location: C:/Documents and Settings/[UserName]/Application Data/TS3Client/ts3clientui_qt.conf
    Invalid UTF-8 string passed to function, returning as-is
    Last update check was: sam. 7. août 11:36:25 2010
    Did you notice that the date is in french ?
    If I use CTRL+L to show client log, û of "août" is not correctly displayed.
    I have a square in Windows XP SP3 32bits English
    and a strange sign in Windows 7 64bits English

    In Control Panel - Regional and Language Options I have :
    Code:
    Regional Options: French (Switzerland)
    Advanced Language for non-Unicode programs: English (United States)
    Thanks

  5. #5
    Join Date
    August 2010
    Location
    Copenhagen
    Posts
    1
    Same here

    I am running Client Beta 25

    I am pretty sure that the problem is that the client doesn not save the .conf file in UTF-8 format.

    If I close the client and open it in a text editor and save it as UTF-8 instead of ANSI the error no longer occurs when the client starts.

  6. #6
    Join Date
    June 2008
    Posts
    18,513
    Thank you all for your reports, we are able to reproduce it here.
    It will be noted into our bugtracker

  7. #7
    Join Date
    June 2008
    Posts
    18,513
    This bug will be fixed in client beta27.

  8. #8
    Join Date
    January 2010
    Location
    Catalunya
    Posts
    2,350
    Maybe. the bug comeback ?
    2011-08-18 01:30:18.356921|INFO | | | Logging started, clientlib version: 3.0.1 [Build: 14968]
    2011-08-18 01:30:19.338332|DEBUG |Direct Sound | | setting timer resolution to 1ms
    2011-08-18 01:30:19.548635|INFO |SoundBckndIntf| | Load Library failed with errorno 126
    2011-08-18 01:30:25.016497|INFO |ClientUI | | TeamSpeak 3 client version: 3.0.1 [Build: 14968]
    2011-08-18 01:30:25.016497|INFO |ClientUI | | Qt version: 4.7.2
    2011-08-18 01:30:25.016497|INFO |ClientUI | | Using configuration location: F:/TS3/config/ts3clientui_qt.conf
    2011-08-18 01:30:26.208211|INFO |Input | | Input device name: Mouse
    2011-08-18 01:30:26.238254|INFO |Input | | Input device name: Teclado
    2011-08-18 01:30:26.238254|INFO |ClientUI | | Last update check was: mié 17. ago 19:30:28 2011
    2011-08-18 01:30:26.238254|INFO | | | Checking for updates...
    2011-08-18 01:30:29.192502|INFO | | | Update check, my version: 14968, latest version: 14968
    2011-08-18 01:30:34.059500|WARNING |StringHelp | | Invalid UTF-8 string passed to function, returning as-is
    2011-08-18 01:30:34.059500|WARNING |StringHelp | | Invalid UTF-8 string passed to function, returning as-is
    2011-08-18 01:30:34.059500|ERROR |Direct Sound | | ERROR (-215): El par

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Regular Expression / Wildcard / Fixed String- Explained - Please?
    By squirrelof09 in forum General Questions
    Replies: 3
    Last Post: May 11th, 2018, 08:36 PM
  2. [Fixed] onTextMessageEvent : can't handle multibyte string
    By haru_arc in forum Bug Reports [EN/DE]
    Replies: 9
    Last Post: September 8th, 2010, 10:08 PM
  3. Replies: 3
    Last Post: August 25th, 2010, 08:22 AM
  4. [Fixed] URL encoded characters passed from links
    By SShaadd in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: April 13th, 2010, 09:36 AM
  5. [Fixed] Lua Function
    By Persane2 in forum Tools / Web Based
    Replies: 2
    Last Post: December 21st, 2009, 02:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •