Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 8 of 8
  1. #1
    Join Date
    May 2010
    Location
    Germany
    Posts
    9

    Solved [solved] server Crash - Select epoll_wait failed with 4

    Hi,
    at version beta26 was a problem with kernel 2.6.9 and older.
    In beta27 the problem should the problem be properly addressed. Just again my server is crashed with the following message:
    2010-08-07 09:15:47.727902|CRITICAL|NET | | Select epoll_wait failed with 4
    Systeminformation:

    Kernel: 2.6.18
    (Linux version 2.6.18-164.15.1.el5.028stab068.9)
    ts-server: beta27
    Debian Lenny with all updates

  2. #2
    Join Date
    January 2010
    Location
    Germany
    Posts
    9
    Dito - in all ways.

    2010-08-08 08:51:26.809949|CRITICAL|NET | | Select epoll_wait failed with 4

  3. #3
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    can you please post a little bit more log that leads up to the critical error?

  4. #4
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,191
    Hi,

    please post some log lines before the actual CRITICAL message. Also describe what you are doing and when the critical occures.

  5. #5
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    The only way I can currently reproduce this (with beta 27) is to send sigstop and then sigcont to the ts3 server process. I don't see how sigstop would be sent to ts3 though.

    Maybe relavant: What distro's are you using and x86 or amd64?

  6. #6
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,191
    Please (in addition to giving the requested information in above posts) give this test version a spin too, as it might contain a fix for your problem:

    http://ftp.4players.de/pub/hosted/ts...odo-so/server/

  7. #7
    Join Date
    January 2010
    Location
    Germany
    Posts
    9
    Hi and sorry - i was on a citytrip.

    The error occourse every morning. Without any reason.
    There aren't any prompt before in the logfile ->

    2010-08-09 22:35:47.301257|INFO |VirtualServer | 1| server was edited by 'BlessSonic'(id:3)
    2010-08-09 23:40:41.755600|INFO |VirtualServer | 1| client (id:593) was added to servergroup 'Normal'(id:7) by client 'Feuchtgebiete▄ █ ▄ █ ▄'(id:232)
    2010-08-10 08:46:39.005842|CRITICAL|NET | | Select epoll_wait failed with 4

    Also describe what you are doing and when the critical occures.
    nothing

    What distro's are you using and x86 or amd64?
    amd64


    I'll try the pre-beta28 thanx for the link.

    BlessSonic
    Last edited by BlessSonic; August 10th, 2010 at 07:39 PM.

  8. #8
    Join Date
    January 2010
    Location
    Germany
    Posts
    9
    Great job! Server is up and running since pre28.

    Thumbs up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Server crash (Assertion failed)
    By Bluscream in forum Server Support
    Replies: 2
    Last Post: October 2nd, 2015, 09:30 PM
  2. Replies: 14
    Last Post: August 10th, 2010, 04:41 PM
  3. [CRITICAL] Server crash (db_exec failed and assertion failed)
    By Slater in forum Bug Reports [EN/DE]
    Replies: 8
    Last Post: August 10th, 2010, 10:36 AM
  4. [SOLVED] beta 15 server crash
    By Crackerjam in forum Windows
    Replies: 17
    Last Post: January 21st, 2010, 07:19 PM
  5. select() failed crash
    By mavmike in forum Linux / FreeBSD
    Replies: 0
    Last Post: December 21st, 2009, 03:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •