Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    February 2010

    Solved [Fixed?] sendPluginCommand defined scope still not respected

    This bug still persists within B25, with fresh TS3 installs and deletion of all client/identity data.



    Currently, you are (assuming, it is not documented) able to specify a scope for a pluginCommand to be sent via sendPluginCommand(). However, TS3 does not respect the provided scope.

    ts3Functions.sendPluginCommand(ts3Functions.getCur rentServerConnectionHandlerID(), this->mCommandId, msg->getData(),
    PluginCommandTarget_CURRENT_CHANNEL, NULL);

    Broadcasts to *all* players on the server. no matter what channel they are in, all players receive this command.

    Repro steps:
    1. Register a valid plugin, with a valid command name.
    2. Setup the appropriate plugin callbacks
    3. Have 2 clients on a server, in seperate channels
    4. Call sendPluginCommand with PluginCommandTarget_CURRENT_CHANNEL
    5. See that all clients still receive the plugin command via ts3plugin_onPluginCommandEvent

  2. #2
    Join Date
    June 2008
    Krün, Germany
    You are right, there was still a bug with the sendPluginCommand function in the client. Should be fixed now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question regarding sendPluginCommand
    By MadStyleCow in forum General Questions
    Replies: 0
    Last Post: September 11th, 2013, 11:34 PM
  2. [Resolved] set3DWaveAttributes does not seem to be respected when playing files
    By jaynus in forum Bug Reports [EN/DE]
    Replies: 9
    Last Post: February 25th, 2011, 05:51 PM
  3. [Resolved] 3D Sound and Attenuation set via API's is not respected
    By jaynus in forum Bug Reports [EN/DE]
    Replies: 2
    Last Post: January 25th, 2011, 07:48 PM
  4. [PLUGIN API] sendPluginCommand SCOPE is not respected
    By jaynus in forum Client Plugins / Lua Scripts
    Replies: 4
    Last Post: July 2nd, 2010, 03:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts