Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    August 2010
    Location
    UK
    Posts
    1

    New Virtual Servers Not Working

    I have setup TS3 a number of times now trying to get to the bottom of this problem and so far got nowhere.

    For the server I am using CentOS 5.5 with all latest patches (this is a virtual server running on Parallels), TS3 version 3.0.0-beta25 [Build: 11421], also runs Apache and ProFTP plus a few other web relates services (nothing that could conflict with TS3). I also have the 512 user/10 virtual server NPL license.

    After setting up I can connect to the default virtual server on port 9987 with no problems at all. I have used the Privilege Key to gain admin access and have stayed connected for hours at a time chatting away.

    The problems start when I create a new virtual server... I can create the server using the server query tool, then after connecting to the new server with the client I get times out after a few seconds. I have tried using the Privilege Key but either the option is greyed out or if I can click it the server times out before I can paste and click OK.

    Below is a list of what I have tried/checked:
    • Tried many different ports when setting up the new virtual server
    • Checked ports are open on the firewall (both iptables and virtual server firewall)
    • Disabled firewalls completly
    • Connected from 3 different locations with 3 different PCs
    • Tried the 32bit and 64bit windows clients
    • Run as a new local 'teamspeak' user
    • Run as root (don't moan I am testing :P)
    • Oh yea and smashed my face on the keyboard many many times


    After all this any instance of TS that is not running on the default 9987 port connects then times out. I can connect again but not straight away, sometime a few seconds, sometimes a few minutes and sometimes never.

    As far as config and logs go here they are:
    CONFIG:
    Code:
    machine_id=
    default_voice_port=9987
    voice_ip=x.x.x.x
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=x.x.x.x
    query_port=10011
    query_ip=x.x.x.x
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    dblogkeepdays=90
    logpath=logs
    logquerycommands=0
    dbclientkeepdays=30
    LOG:
    Code:
    2010-08-02 12:49:03.068455|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta25 [Build: 11421], Linux
    2010-08-02 12:49:03.068754|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2010-08-02 12:49:03.068868|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.21
    2010-08-02 12:49:03.069133|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2010-08-02 12:49:03.086356|INFO    |SQL           |   | pruning old database log entries where timestamp is older than 90 days
    2010-08-02 12:49:03.610574|INFO    |Accounting    |   | Licensing Information
    2010-08-02 12:49:03.611202|INFO    |Accounting    |   | type              : Non-profit
    2010-08-02 12:49:03.611813|INFO    |Accounting    |   | starting date     : Fri Dec 25 23:00:00 2009
    2010-08-02 12:49:03.612272|INFO    |Accounting    |   | ending date       : Sat Dec 25 23:00:00 2010
    2010-08-02 12:49:03.612752|INFO    |Accounting    |   | max virtualservers: 10
    2010-08-02 12:49:03.613219|INFO    |Accounting    |   | max slots         : 512
    2010-08-02 12:49:03.636889|INFO    |FileManager   |   | listening on x.x.x.x:30033
    2010-08-02 12:49:03.667352|INFO    |VirtualServer |  1| listening on x.x.x.x:9987
    2010-08-02 12:49:03.691020|INFO    |VirtualServer |  2| listening on x.x.x.x:9876
    2010-08-02 12:49:03.691595|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1,
    2010-08-02 12:49:03.692583|INFO    |Query         |   | listening on x.x.x.x:10011
    CLIENT:
    Code:
    <14:33:32> Trying to connect to server on XXXX
    <14:33:32> Connected to server: XXXX
    <14:33:32> Welcome to TeamSpeak
    <14:33:47> Connection to server lost
    <14:33:47> Trying to connect to server on XXXX
    <14:33:48> Failed to connect to server
    <14:33:53> Trying to connect to server on XXXX
    <14:33:54> Failed to connect to server
    ...
    ...
    Hopefully someone will see this and know exactly what is wrong

    If you need any more information let me know.

    UPDATE:

    I have upgraded TS3 both client and server to the latest version.

    Also installed the old version of TS2 server and tried setting up virtual servers with that on the same ports as TS3. All servers worked so it points to TS3 being at fault.
    Last edited by emericklaw; August 3rd, 2010 at 11:35 AM. Reason: Added Upgrade and TS2 Info

  2. #2
    Join Date
    June 2008
    Posts
    18,513
    Can you paste the client log? Maybe they get a blacklist check timeout.
    Have you tryed another port for your second server?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Not possible] NPL +2 virtual servers +2 physical servers
    By Un0rThOd0x in forum Server Support
    Replies: 4
    Last Post: June 18th, 2014, 07:57 AM
  2. [Resolved] Virtual Servers
    By Tythus in forum Server Support
    Replies: 2
    Last Post: June 25th, 2013, 04:44 PM
  3. Replies: 1
    Last Post: October 8th, 2012, 03:44 PM
  4. Replies: 1
    Last Post: May 12th, 2012, 05:46 PM
  5. [Resolved] How can I get my TS servers virtual ID?
    By nbtc971 in forum General Questions
    Replies: 9
    Last Post: November 3rd, 2011, 01:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •