Forum

Results 1 to 2 of 2
  1. #1
    Join Date
    September 2008
    Location
    England...
    Posts
    40

    [PHP] TS interface error: invalid parameter count

    Hi guys, to cut a long story short and to let you know what I'm doing I'm just going to quickly explain.

    > Cron job runs
    > Check if member passes criteria
    > > if they do, skip to next member
    > > if they don't, delete member from Teamspeak


    Now I'm having a bit of a problem with the Teamspeak delete command. Here is the section of code.

    The error is with clientDeleteDb($cid)
    PHP Code:
    try {
        
    $ts TeamSpeak3::factory("serverquery://".$c->tsname.":".$c->tspass."@".$c->tshost.":".$c->tsport."/");
        
    $virt $ts->serverGetByPort($c->tscport);
        if (
    $c->usesta == true) {
            
    $virt->serverGroupClientDel($c->stagroup,$cid);
        }
        else {
            
    $virt->clientDeleteDb($cid);
        }

    Now here is the definition of "clientDeleteDb" in another file.

    PHP Code:
    /**
       * Deletes the clients properties from the database.
       *
       * @return void
       */
      
    public function deleteDb()
      {
        return 
    $this->getParent()->clientDeleteDb($this["client_database_id"]);
      } 
    From the manual, the command I need to send is "clientdbdelete cldbid=USER_ID". But the method was designed some time ago and the command may have changed... That's what I think is going wrong. I'm just not sure which bit I need to change in the method and how...


    Any help would be more than appreciated. Really.

  2. #2
    Join Date
    May 2010
    Posts
    6,310
    Hello

    This command has not change.

    But here :

    PHP Code:
    return $this->getParent()->clientDeleteDb($this["client_database_id"]); 
    "$this" is the class variable pointer or really array ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Disconnected From Server (Invalid Parameter)
    By johnkiriazis7 in forum Server Support
    Replies: 1
    Last Post: June 25th, 2015, 08:28 AM
  2. serversnapshotdeploy -> invalid parameter
    By govenka in forum Server Support
    Replies: 19
    Last Post: September 23rd, 2011, 10:56 AM
  3. TS interface error: invalid serverID
    By Mavrik347 in forum Tools / Web Based
    Replies: 3
    Last Post: October 14th, 2010, 08:45 PM
  4. TS interface error: invalid serverID
    By Mavrik347 in forum Server Support
    Replies: 0
    Last Post: October 13th, 2010, 06:31 PM
  5. Invalid Parameter size?
    By enortimus in forum Windows
    Replies: 4
    Last Post: December 21st, 2009, 01:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •