Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 11 of 11
  1. #1
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,191

    TeamSpeak 3 Client 3.0.0-beta29 Available

    Greetings,

    today we released TeamSpeak 3 Client version 3.0.0-beta29. The reason for this rather quick release following beta28 is a bug we discovered that prevented beta28 clients from opening the "Ban List" dialogue on beta28 servers. The new client is able to open the ban list dialogue again (independent of the server version).

    Complete list of changes:
    Code:
    === Client Release 3.0.0-beta29 10 Sep 2010
    - Fixed opening an empty banlist           
    - Fixed not writing logs and accessing sounds or plugins when path contains an
      apostrophe                                                                  
    - Fixed selecting channel and server group items in 3D setup with same id

  2. #2
    Join Date
    December 2009
    Location
    Germany, Cologne
    Posts
    1,364
    Updated and work's fine!

  3. #3
    Join Date
    July 2010
    Location
    California
    Posts
    4
    The windows 32 bit download appears to be corrupt. Cannot install.

  4. #4
    Join Date
    December 2009
    Location
    Europe
    Posts
    181
    Using a link like ts3server://95.168.183.182?port=9987 from within a web browser will cause trouble with the new version. The default icon pack is not found and thus the GUI looks awkward.

  5. #5
    Join Date
    December 2009
    Location
    France
    Posts
    9
    No default icon pack installed :/
    Client win 64

  6. #6
    Join Date
    May 2010
    Posts
    6,310
    Have you try this :

    TS3CLient => Settings => Security => "Clear Cache"

  7. #7
    Join Date
    December 2009
    Location
    Europe
    Posts
    181
    That did not change anything.

  8. #8
    Join Date
    August 2008
    Location
    Netherlands
    Posts
    25
    Got the same thing as Birdie.

  9. #9
    Join Date
    January 2010
    Location
    Sweden
    Posts
    7
    Both the 32-bit and 64-bit Linux clients have a dependency on a 2.7+ version of the glibc system library. This will cause problems for users of older distributions.

    The GLIBC_2.7 dependency applies to these two files, found in the "plugins" folder:
    • libclientquery_plugin.so
    • liblua_plugin.so


    How to see this:
    Code:
    $ ldd ./liblua_plugin.so 
    ./liblua_plugin.so: /lib/libc.so.6: version `GLIBC_2.7' not found (required by ./liblua_plugin.so)
            linux-gate.so.1 =>  (0xffffe000)
            libc.so.6 => /lib/libc.so.6 (0xf7e38000)
            /lib/ld-linux.so.2 (0x0020b000)
    
    $ ldd ./libclientquery_plugin.so 
    ./libclientquery_plugin.so: /lib/libc.so.6: version `GLIBC_2.7' not found (required by ./libclientquery_plugin.so)
            linux-gate.so.1 =>  (0xffffe000)
            libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf7d89000)
            libm.so.6 => /lib/libm.so.6 (0xf7d60000)
            libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf7d54000)
            libc.so.6 => /lib/libc.so.6 (0xf7bfc000)
            /lib/ld-linux.so.2 (0x0020b000)
    My Linux distribution is CentOS 5.5, whose glibc (libc.so.6) supports up to and including GLIBC_2.5 symbols, but not later versions.

    If possible, could these libraries be built so as to not require a "too new" glibc?

  10. #10
    Join Date
    December 2009
    Location
    germany
    Posts
    56
    same as birdie

    win7 64 bit

  11. #11
    Join Date
    May 2010
    Posts
    6,310
    Quote Originally Posted by gevatter View Post
    same as birdie

    win7 64 bit
    It's on Bug Report forum .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [No bug] User can kick after beta29
    By savio in forum Permission System
    Replies: 153
    Last Post: June 18th, 2011, 10:06 AM
  2. [No bug] User can kick after beta29
    By savio in forum Bug Reports [EN/DE]
    Replies: 133
    Last Post: February 27th, 2011, 07:26 AM
  3. Replies: 7
    Last Post: November 20th, 2010, 12:02 PM
  4. [No bug] User can kick after beta29
    By savio in forum Server Support
    Replies: 3
    Last Post: October 7th, 2010, 07:15 AM
  5. TeamSpeak 3 Server 3.0.0-beta29 Available
    By Peter in forum Archive
    Replies: 26
    Last Post: October 5th, 2010, 03:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •