Forum

Page 1 of 5 123 ... LastLast
Results 1 to 15 of 67
  1. #1
    Join Date
    June 2002
    Location
    Krün / Germany
    Posts
    1,638

    moved TeamSpeak 3 Server 3.0.0-beta30 PRERELEASE Available

    Note: This is a pre-release, meaning it has not passed the usual quality testing of a normal server release. We do NOT advise its use in production environments, please only use it to (a) preview and prepare for upcoming changes and (b) test and report flaws

    Greetings,

    we are happy to announce the pre-release of a new server build with version 3.0.0-beta30.

    Complete list of changes:
    Code:
    === Server Release 3.0.0-beta30-pre ?? Oct 2010
    ! experimental new tcp stack
    + reduced CPU usage for large servers
    + ServerQuery: added server port to "whoami" output
    + ServerQuery: added client_created and client_lastconnected times to output
      of "clientlist" when "-times" parameter is passed. Value is in seconds since
      1970.
    + ServerQuery: added parent id to output of "channelinfo"
    - fixed problem handling malformated client requests that could lead to the
      server shutting down after logging a critical log message.
    - fixed issue that lead to clients not being able to edit the slot count back to
      the value that was set when they originally connected to the server
    - fixed serversnapshotdeploy using wrong sql file on failure
    - fixed issue with servernotifyregister not unregistering serverquery clients
      on remote connection closed
    - fixed bug with temporary channels not being deleted immediately when a
      sub-channel was moved out of them and they so became empty
    - fixed bug that lead to the output of the ServerQuery command "hostinfo" to
      display wrong data in the bandwidth last minute and bandwidth last second
      fields
    download at:
    http://ftp.4players.de/pub/hosted/ts...leases/server/

  2. #2
    Join Date
    December 2009
    Location
    Germany, Cologne
    Posts
    1,364
    Oh, a Pre with a Thread.

    I will test it too.

  3. #3
    Join Date
    January 2010
    Location
    Germany
    Posts
    6
    /me previews and prepares for lower CPU usage

    No seriously, does anything need to be altered on my server environment for this version? Any changing of ports/protocols that could lead to firewall problems or stuff like that?

  4. #4
    Join Date
    January 2010
    Location
    New England USA / Marnbach, Weilheim i.OB, Germany
    Posts
    428
    I'm having an issue with query's connecting. I now have 13 query's connected (from Gametracker I believe. I traced IP to Gametrackers HQ). They are not disconnecting. Perhaps it is a fault of theirs, I do not know. TSViewer's scan is working fine. Anyone else getting this?

    I have yet to do any debug of this.

  5. #5
    Join Date
    May 2007
    Location
    Eastern NC
    Posts
    1,800
    downloading now, you know I'll test it.

  6. #6
    Join Date
    December 2009
    Location
    florida
    Posts
    263
    i have lost part of my tsviewer page since updating to pre 30.

    does not show server channels and users online.
    other than the error code: 0 everything else there works fine


    http://img834.imageshack.us/img834/2...30tsviewer.png

  7. #7
    Join Date
    June 2002
    Location
    Krün / Germany
    Posts
    1,638
    Quote Originally Posted by -{HGH}-GEN.Skylab View Post
    I'm having an issue with query's connecting. I now have 13 query's connected (from Gametracker I believe. I traced IP to Gametrackers HQ). They are not disconnecting. Perhaps it is a fault of theirs, I do not know. TSViewer's scan is working fine. Anyone else getting this?

    I have yet to do any debug of this.
    did gametracker handles already the new welcome message properly? (introduced with beta29) ?

  8. #8
    Join Date
    April 2009
    Location
    Germany
    Posts
    242
    Quote Originally Posted by R. Ludwig View Post
    did gametracker handles already the new welcome message properly? (introduced with beta29) ?
    No, they have not. Same as other Status Hosters like Instantteamspeak.com. None of them has it working again.

  9. #9
    Join Date
    June 2002
    Location
    Krün / Germany
    Posts
    1,638
    Quote Originally Posted by Wolfseye View Post
    No, they have not. Same as other Status Hosters like Instantteamspeak.com. None of them has it working again.
    ok.. i will try to get someone from our sales team to contact them and get them fix it.

  10. #10
    Join Date
    January 2010
    Location
    New England USA / Marnbach, Weilheim i.OB, Germany
    Posts
    428
    Just waking up and there are 81 queries :-O

    I just restart the server so that they disconnect for now. Other than that, server is running smoothly.

  11. #11
    Join Date
    June 2002
    Location
    Krün / Germany
    Posts
    1,638
    Quote Originally Posted by -{HGH}-GEN.Skylab View Post
    Just waking up and there are 81 queries :-O

    I just restart the server so that they disconnect for now. Other than that, server is running smoothly.
    can you check if the connections still exists? since my idle queries are removed after 10 minutes.

  12. #12
    Join Date
    June 2006
    Location
    Texas
    Posts
    85
    Quote Originally Posted by -{HGH}-GEN.Skylab View Post
    Just waking up and there are 81 queries :-O

    I just restart the server so that they disconnect for now. Other than that, server is running smoothly.
    I don't have this problem. Do you have "Show Server Query Clients" enabled and the Server Query users are actually connected and you counted 81?

    Or are you looking at the "virtualserver_query_client_connections"? That is just a total of the connections since reboot.

  13. #13
    Join Date
    December 2009
    Location
    florida
    Posts
    263
    hers more on my server with beta 30 pre release.

    this morning stats show 15 clients online when only 2
    restarted the server now up to 8 when only 2
    turned on show queryclinets and the ones on you see in screenshot
    have been on for some time now.
    tsviewer seems to connect and disconnect ok but shows server is down
    while it does show some stats.


    screenshot
    http://img177.imageshack.us/img177/7...iewererror.png

  14. #14
    Join Date
    October 2003
    Location
    Germany
    Posts
    2,528
    Just a little update for you guys... We've identified the issue with these "zombie" ServerQuery clients and the devs are working on a fix. Stay tuned!


  15. #15
    Join Date
    December 2009
    Location
    florida
    Posts
    263
    Quote Originally Posted by ScP View Post
    Just a little update for you guys... We've identified the issue with these "zombie" ServerQuery clients and the devs are working on a fix. Stay tuned!

    sweet
    you guys are the greatest!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: May 10th, 2015, 05:56 PM
  2. [PreRelease] TeamSpeak 3 Server 3.0.10
    By Chris in forum Archive
    Replies: 18
    Last Post: September 28th, 2013, 08:57 PM
  3. [PreRelease] TeamSpeak 3 Server 3.0.9
    By dante696 in forum Archive
    Replies: 16
    Last Post: September 12th, 2013, 09:50 AM
  4. [PreRelease] TeamSpeak 3 Server 3.0.8
    By Chris in forum Archive
    Replies: 53
    Last Post: August 11th, 2013, 11:21 PM
  5. TeamSpeak 3 Server 3.0.0-beta30 PRERELEASE Available
    By R. Ludwig in forum Server Support
    Replies: 19
    Last Post: November 21st, 2010, 05:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •