Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    October 2010
    Location
    Fla USA
    Posts
    4

    Having trouble updating my server files

    Howdy y'all ,

    I have been running a TS3 server for some months now and lately it was not being used , the server client running is Beta23 and no one can connect , so i downloaded the latest server files "beta29" and moved the files into my TS3 server folder and it crashes on start.

    I have tried:

    moving just the folders (server starts but no one can connect)
    moving just the folders and the .dll's (server starts but no one can connect)
    moving all the files (server crashes at start and requires a reboot to end the service)

    I have it installed on a Windows Home Server and I have the folder and files backed up so i can try just about anything , the old server still run but being so far back in date no one can connect.

    can anyone help me to get this resolved??

    thanks a million ,

    JBB

    PS Here is a log on the issue.

    2010-10-10 02:58:20.703125|INFO |ServerLibPriv | | Server Version: 3.0.0-beta29 [Build: 12473], Windows
    2010-10-10 02:58:20.703125|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2010-10-10 02:58:20.703125|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2010-10-10 02:58:20.703125|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2010-10-10 02:58:20.734375|INFO |SQL | | pruning old database log entries where timestamp is older than 90 days
    2010-10-10 02:58:21.843750|INFO |Accounting | | Licensing Information
    2010-10-10 02:58:21.843750|INFO |Accounting | | type : Non-profit
    2010-10-10 02:58:21.843750|INFO |Accounting | | starting date : Mon Mar 08 00:00:00 2010
    2010-10-10 02:58:21.843750|INFO |Accounting | | ending date : Tue Mar 08 00:00:00 2011
    2010-10-10 02:58:21.843750|INFO |Accounting | | max virtualservers: 10
    2010-10-10 02:58:21.843750|INFO |Accounting | | max slots : 512
    2010-10-10 02:58:21.906250|INFO |FileManager | | listening on 0.0.0.0:30033
    2010-10-10 02:58:22.|ERROR |VirtualServer | 1| bind failed on 0.0.0.0:9987
    2010-10-10 02:58:22.|ERROR |VirtualSvrMgr | | loading VirtualServer(1) failed to start, error: unable to bind network port
    2010-10-10 02:58:22.015625|INFO |VirtualServer | 1| stopped
    2010-10-10 02:58:22.015625|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2010-10-10 02:58:22.015625|ERROR |Query | | 0.0.0.0:10011 unable to bind error: 10013:An attempt was made to access a socket in a way forbidden by its access permissions
    2010-10-10 02:58:22.015625|ERROR |Query | | bind failed on 0.0.0.0:10011
    Last edited by JimBeamBlack; October 10th, 2010 at 04:05 AM. Reason: added Log:

  2. #2
    Join Date
    October 2010
    Location
    Fla USA
    Posts
    4
    OK , I am all screwed up , people CAN connect with the newest client and server beta23 , we get a message that the server files are outdated and that the text will not work properly.

    no big deal really , but I would like to update my server and I still cannot get the newest server files to work with my old data.

    Is there any easy way to update beta23 to beta29? as beta29 seems to act differently , it does not open a command prompt when started and therefore cannot be shut down??

    I really appreciate any help on this ,
    thanks JBB

  3. #3
    Join Date
    May 2010
    Posts
    6,310
    Hello

    Quote Originally Posted by JimBeamBlack
    2010-10-10 02:58:22.|ERROR |VirtualServer | 1| bind failed on 0.0.0.0:9987
    2010-10-10 02:58:22.|ERROR |VirtualSvrMgr | | loading VirtualServer(1) failed to start, error: unable to bind network port
    2010-10-10 02:58:22.015625|INFO |VirtualServer | 1| stopped
    2010-10-10 02:58:22.015625|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2010-10-10 02:58:22.015625|ERROR |Query | | 0.0.0.0:10011 unable to bind error: 10013:An attempt was made to access a socket in a way forbidden by its access permissions
    2010-10-10 02:58:22.015625|ERROR |Query | | bind failed on 0.0.0.0:10011
    Sounds like you haven't stop your server before put the new files in your server folder.

    So :

    1 - Stop your Teamspeak instance.
    2 - Make a backup of your server folder.
    3 - Download the latest version (beta 29) and put it (overwrite) in your server folder)
    4 - Start your Teamspeak server.

    Quote Originally Posted by JimBeamBlack
    Is there any easy way to update beta23 to beta29? as beta29 seems to act differently , it does not open a command prompt when started and therefore cannot be shut down??
    Read the changelog and documentation. You have, since beta 26 on windows, an icon in your task bar.

  4. #4
    Join Date
    October 2010
    Location
    Fla USA
    Posts
    4
    florian , thank you very much!!

    It must have been because I was starting the TS server but didn't see that it was running so I kept trying to start it and it got this error , not sure why I couldn't connect last night but now it seems to be working!!

    Thank you for taking your time to help , I owe you a beer!!

    Man I must have tried to do this like 10 times last night....I have no idea what I was doing wrong.


    well thanks again!!
    Last edited by JimBeamBlack; October 10th, 2010 at 03:44 PM.

  5. #5
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143

  6. #6
    Join Date
    October 2010
    Location
    Fla USA
    Posts
    4
    AWESOME link poisonpanik!! thank you , I'm going to grab a few older server files just incase.

    Now i have to try to figure out what the heck I was doing wrong last night , I had like 10 people trying to help me and I must have reboted my serer like 10 times lol!!

    Thnk y'all very much for your help!!

  7. #7
    Join Date
    May 2010
    Posts
    6,310
    Quote Originally Posted by JimBeamBlack
    Thank you for taking your time to help , I owe you a beer!!
    With pleasure, during my next business trip to usa

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Having trouble updating server
    By Chevys in forum Server Support
    Replies: 2
    Last Post: January 11th, 2014, 03:46 PM
  2. After updating the server to 3.0.7.2
    By PL_Grzegorz in forum Linux / FreeBSD
    Replies: 1
    Last Post: July 22nd, 2013, 08:02 PM
  3. updating a server
    By zteeters in forum Server Support
    Replies: 1
    Last Post: June 29th, 2011, 07:49 AM
  4. Need help updating my server
    By Krank in forum Windows
    Replies: 4
    Last Post: June 5th, 2010, 10:21 PM
  5. Updating TS3 Server
    By Flinty in forum General Questions
    Replies: 0
    Last Post: June 2nd, 2010, 10:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •