Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    May 2010
    Posts
    6,310

    Query channeledit and codec encrypted

    When "Channel voice data encryption" is on "Globally on" on the server settings, and when you use the channeledit command line to deactivate it, the server answer ok but of course no changes.

    Code:
    channeledit cid=5 channel_codec_is_unencrypted=1
    error id=0 msg=ok
    Same result with Globally off and ..._is_unencrypted=0

    Maybe add an information message in the result (a little bit like permreset and "invalid client type").

    Tested on server Beta 30-pre

  2. #2
    Join Date
    June 2008
    Posts
    18,015
    Looks good on here beta30-pre [Build: 12603]

    When channel_codec_is_unencrypted is set to 1, then it means encryption is deactivated. Confused me too =)

  3. #3
    Join Date
    May 2010
    Posts
    6,310
    Yes, at the begin it confused me too. It is indeed as I saw this little bug.

  4. #4
    Join Date
    June 2008
    Posts
    18,015
    As I said before, it looks good (it works for me). The query joins the server and edits encryption for channel.

    What build number do you use?

  5. #5
    Join Date
    May 2010
    Posts
    6,310
    I use the Beta-30 pre Build 12622

    This query command works perfectly if in the server settings there is Configure per Channel.

    But if there is Globally Off or Globally On this command have no effect (and of course that's normal) but the server answers as if he had changed the encryption mode.

    That's why I spoke with an information message (like permreset) for the understanding of script dev or the uers of the query command.

    It's true, this not really a bug.

  6. #6
    Join Date
    June 2008
    Posts
    18,015
    Oh sry, thought there is something wrong with that command. Grabbing some informations about that after dinner

    Update
    I asked around, but we think, a check for global encryption isn't needed, when your server settings overwrite it.
    Last edited by dante696; October 13th, 2010 at 01:11 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Encryption Question - What exactly is encrypted in TS3?
    By smithers33 in forum General Questions
    Replies: 16
    Last Post: August 7th, 2019, 04:13 AM
  2. [Resolved] channeledit channel_icon_id=x not saved
    By numma_cway in forum Bug Reports [EN/DE]
    Replies: 37
    Last Post: June 17th, 2019, 06:04 PM
  3. [Resolved] Can't set channel to encrypted
    By slick97477 in forum Linux / FreeBSD
    Replies: 11
    Last Post: May 20th, 2011, 09:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •