Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    October 2010
    Location
    Wolfsburg
    Posts
    2

    And another problem with licensekey.dat -.-

    Hi

    since one week I try to get my TS3-Server running -.-
    I got my licensekey.dat and everything was fine for the first time I started with the Non profit license:

    2010-10-03 19:49:13.230745|INFO |ServerLibPriv | | Server Version: 3.0.0-beta26 [Build: 11927], Linux
    2010-10-03 19:49:13.234465|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak $
    2010-10-03 19:49:13.234506|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2010-10-03 19:49:13.241622|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2010-10-03 19:49:13.413596|INFO |SQL | | pruning old database log entries where timestamp is older $
    2010-10-03 19:49:13.446200|INFO |SQL | | pruning old guest clients where last connected time is old$
    2010-10-03 19:49:13.949802|INFO |Accounting | | Licensing Information
    2010-10-03 19:49:13.950195|INFO |Accounting | | type : Non-profit
    2010-10-03 19:49:13.950461|INFO |Accounting | | starting date : Sun Oct 3 00:00:00 2010
    2010-10-03 19:49:13.950728|INFO |Accounting | | ending date : Mon Oct 3 00:00:00 2011
    2010-10-03 19:49:13.950962|INFO |Accounting | | max virtualservers: 10
    2010-10-03 19:49:13.951265|INFO |Accounting | | max slots : 512
    2010-10-03 19:49:13.985394|INFO |FileManager | | listening on 0.0.0.0:30033
    2010-10-03 19:49:14.054289|INFO |VirtualServer | 1| listening on 0.0.0.0:10467
    2010-10-03 19:49:14.054836|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2010-10-03 19:49:14.055385|INFO |Query | | listening on 0.0.0.0:10011
    2010-10-03 19:54:14.154163|DEBUG | | | Response from weblist: 0
    2010-10-03 19:57:49.038225|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2010-10-03 19:57:49.160618|INFO |VirtualServer | 1| stopped
    Then I have stopped it, and now it looks like:

    2010-10-19 19:45:26.758411|INFO |ServerLibPriv | | Server Version: 3.0.0-beta29 [Build: 12473], Linux
    2010-10-19 19:45:26.758639|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak $
    2010-10-19 19:45:26.758667|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2010-10-19 19:45:26.758864|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2010-10-19 19:45:26.855156|INFO |SQL | | pruning old database log entries where timestamp is older $
    2010-10-19 19:45:26.869268|WARNING |Accounting | | Unable to find valid license key, falling back to limited $
    2010-10-19 19:45:26.885235|INFO |FileManager | | listening on 0.0.0.0:30033
    2010-10-19 19:45:26.917313|INFO |VirtualServer | 1| listening on 0.0.0.0:10467
    2010-10-19 19:45:26.917819|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2010-10-19 19:45:26.918172|INFO |Query | | listening on 0.0.0.0:10011
    I've tried everything what I've found on google and here in Forum, but nothing works.

    I tried:
    - kill PID and restart
    - stop server and editing the .dat file that it looks like it must look
    - server stop .. deleting license.dat ... server start ... server stop .. copying the .dat again ... start server

    ... nothing works -.-

    I think its not a Port problem, because it has worked first time I start with key.dat

    Please help me


    greetz from germany

    EDIT//

    Now I had the idea to give chmod 755 to licensekey.dat ... it works now with max. 10 virt. Servers and 512 slots. But there are some lines I dont understand:

    2010-10-19 20:18:10.576051|INFO |Accounting | | Licensing Information
    2010-10-19 20:18:10.576134|INFO |Accounting | | type : Non-profit
    2010-10-19 20:18:10.576180|INFO |Accounting | | starting date : Sun Oct 3 00:00:00 2010
    2010-10-19 20:18:10.576206|INFO |Accounting | | ending date : Mon Oct 3 00:00:00 2011
    2010-10-19 20:18:10.576230|INFO |Accounting | | max virtualservers: 10
    2010-10-19 20:18:10.576251|INFO |Accounting | | max slots : 512
    2010-10-19 20:18:10.592939|ERROR |FileManager | | bind() failed: 98
    2010-10-19 20:18:10.592989|ERROR |FileManager | | bind failed on 0.0.0.0:30033
    2010-10-19 20:18:10.662111|ERROR |VirtualServer | 1| bind failed on 0.0.0.0:10467
    2010-10-19 20:18:10.662683|ERROR |VirtualSvrMgr | | loading VirtualServer(1) failed to start, error: unable to bind network port

    2010-10-19 20:18:10.695834|INFO |VirtualServer | 1| stopped
    2010-10-19 20:18:10.696495|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2010-10-19 20:18:10.713352|ERROR |Query | | 0.0.0.0:10011 unable to bind error: 98: Die Adresse wird bereits verwendet
    2010-10-19 20:18:10.713429|ERROR |Query | | bind failed on 0.0.0.0:10011
    Sounds not so good, but Server is running. What does it mean?!? ^^

    d(.)b
    Last edited by netshadow; October 19th, 2010 at 10:44 PM.

  2. #2
    Join Date
    May 2010
    Posts
    6,310
    Hello

    There seems you have an other teamspeak instance running.

    On shell :
    write "top" and kill all teamspeak process (kill -9 <process ID>)
    Now restart your server.

  3. #3
    Join Date
    October 2010
    Location
    Germany
    Posts
    2
    Hi there,

    I have a similar problem.
    I installed the current TS3 server version on a Debian 5 system. Everything is just fine. The server is running and I connected with the client and got admin rights.
    But the server doesn't recognize the NPL. I placed the .dat file in the root directory, chmod 755, but at the restart of the TS3 server the server doesn't accept it as a valid NPL license. Latest log file:

    2010-10-24 10:06:47.183006|INFO |ServerLibPriv | | Server Version: 3.0.0-beta29 [Build: 12473], Linux
    2010-10-24 10:06:47.183261|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2010-10-24 10:06:47.183305|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2010-10-24 10:06:47.183591|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2010-10-24 10:06:47.195748|INFO |SQL | | pruning old database log entries where timestamp is older than 90 days
    2010-10-24 10:06:47.213570|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2010-10-24 10:06:47.238635|INFO |FileManager | | listening on 0.0.0.0:30033
    2010-10-24 10:06:47.299489|INFO |VirtualServer | 1| listening on 0.0.0.0:9987
    2010-10-24 10:06:47.300288|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2010-10-24 10:06:47.300761|INFO |Query | | listening on 0.0.0.0:10011
    The licensekey.dat was placed in the TS3 directory with chown TS user and chmod 755:

    -rwxr-xr-x 1 teamspeak teamspeak 1242 Oct 24 12:03 licensekey.dat
    Am I missing anything? Any ideas what I could try?

    Greetings,
    Bina

  4. #4
    Join Date
    October 2010
    Location
    Wolfsburg
    Posts
    2
    Hi @ all,

    I've killed the server and updated it to latest version. Then restart, and now it works without problems.

    @ Binabik
    How is the licencekey.dat file formatted when u open it with the editor? Here in forum are many Threads about problems with licencekey.dat, maybe u try some of the solutions which are posted here.


    greetz

  5. #5
    Join Date
    May 2010
    Posts
    6,310
    Quote Originally Posted by netshadow View Post
    Hi @ all,

    I've killed the server and updated it to latest version. Then restart, and now it works without problems.
    Good news

  6. #6
    Join Date
    October 2010
    Location
    Germany
    Posts
    2
    Quote Originally Posted by netshadow View Post
    @ Binabik
    How is the licencekey.dat file formatted when u open it with the editor? Here in forum are many Threads about problems with licencekey.dat, maybe u try some of the solutions which are posted here.
    Hah, big big thanks! Downloaded the Licensekey.dat file with a webmail client, instead of the Mac OS X Mail client ... and whoosh it works now *g*

    Thanks a lot for your help :-)

    Greetz,
    Bina

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. licensekey.dat problem
    By vakotm in forum Windows
    Replies: 4
    Last Post: May 9th, 2013, 04:23 PM
  2. Licensekey problem
    By teamspeak user71 in forum Server Support
    Replies: 1
    Last Post: October 5th, 2012, 03:01 PM
  3. Problem with licensekey.dat
    By thaalesalves in forum Linux / FreeBSD
    Replies: 3
    Last Post: May 6th, 2012, 03:25 AM
  4. [Resolved] Licensekey.dat Problem
    By gugaa in forum Windows
    Replies: 3
    Last Post: October 20th, 2011, 03:50 PM
  5. Problem with licensekey.dat
    By VoidShadow in forum Linux / FreeBSD
    Replies: 11
    Last Post: September 7th, 2010, 12:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •