Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    November 2010
    Location
    usa
    Posts
    1

    Headset playback audio doesn't work in TS3

    I want to have my game play through my speakers but have TS voices come through my headset.

    Speakers I can hear voices. So TS is working.

    Playing music, my headset works fine. So it's not the headset that is broken.

    But when I set TS3 to use my platronics DSP 500 as the playback device, I only get a very very faint sound that is distorted.
    I've played around with windows settings and TS settings, and determined this is not an issue of the playback simply being too low. If I turn things up I just get a louder staticy distorting which is still so faint it can barely be heard.


    Even setting the headset to my default playback device in windows didn't change that.


    Vista 32 bit
    Soundblaster X-FI Fatal1ty champion
    TS3

  2. #2
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    Question, can you get TS to work correctly if you set it up to play all audio through the headset?

  3. #3
    Join Date
    June 2008
    Posts
    18,513
    And have you tryed different playback modes under settings > options > playback?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. my headset dont work: could not open playback device
    By anvienhponline in forum General Questions
    Replies: 0
    Last Post: August 14th, 2014, 04:06 PM
  2. Replies: 1
    Last Post: August 5th, 2011, 10:07 AM
  3. Headset doesn't work while talking
    By thor9978 in forum General Questions
    Replies: 1
    Last Post: April 23rd, 2011, 08:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •