Forum

Page 4 of 6 FirstFirst ... 23456 LastLast
Results 46 to 60 of 80
  1. #46
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,265
    If you have a problem with the query commands, try YaTQA.

  2. #47
    Join Date
    January 2014
    Posts
    9
    Did they really delete the answer to this? So we're prompted to view the forums, look at the .txt and look things up, but the answers are deleted? This was my exact issue as well. http://forum.teamspeak.com/showthrea...tions?p=400501

  3. #48
    Join Date
    June 2008
    Posts
    17,363
    I did replace the answer and author in post #2 of this thread and i have added more details about the ports that can be changed
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #49
    Join Date
    August 2014
    Posts
    2

    server is not using my port #

    Hi,

    I'm running the latest version of ts3 server on debian. when I set up the server, I had it create an ini file. within the ini file, I specified a port # of 9991, but it doesn't appear to be listening on that port.

    here's the ini file:

    Code:
    machine_id=
    default_voice_port=9991
    voice_ip=my ip
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=my ip
    query_port=10011
    query_ip=my ip
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    dbconnections=10
    logpath=logs
    logquerycommands=0
    dbclientkeepdays=30
    logappend=0
    query_skipbruteforcecheck=0
    when I start the server, I use the following command:

    Code:
    ./ts3server_startscript.sh start inifile=ts3server.ini
    if I do a netstat, it's listening on the default port, 9987:

    Code:
    [email protected]:/home/ts3/teamspeak3# netstat -lp | grep ts
    tcp        0      0 c1109711-12030.cl:30033 *:*                     LISTEN      3248/ts3server_linu
    tcp        0      0 c1109711-12030.cl:10011 *:*                     LISTEN      3248/ts3server_linu
    udp        0      0 c1109711-12030.clo:9987 *:*                                 3248/ts3server_linu
    am I doing something wrong here?
    Last edited by dante696; February 10th, 2015 at 10:33 AM. Reason: merged

  5. #50
    Join Date
    December 2004
    Location
    RF
    Posts
    2,989
    Yes. Search will tell you more.
    The key word is "default".

  6. #51
    Join Date
    September 2012
    Posts
    6,044
    The virtual server already existed before you specified the default port. As said this only affects the default port for the first virtual server. Since there was already a server you'll have to edit that server and change its port. See the query documentation for serveredit.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  7. #52
    Join Date
    June 2008
    Posts
    17,363
    Last edited by dante696; July 6th, 2015 at 10:55 AM. Reason: url has changed
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  8. #53
    Join Date
    July 2015
    Posts
    1

    TS3 PuTTY Login errors

    Attempting to login to my virtual server through the PuTTY interface and when I type in login serveradmin password it gives me the msg: "error id=0 msg=ok" and doesn't let me do anything.... I'm attempting to change my virtual server's port since my router is refusing to allow me to open or forward port 9987.


    EDIT: able to login to my virtual server with the PuTTY interface and changed my port, however even after changing my port and attempting to forward/open the ports I need through my router and making sure TS3 isnt being blocked by my windows firewall, I still cant get it to allow anyone else outside of my wifi-network to login.
    Last edited by Xine05; July 7th, 2015 at 03:22 AM. Reason: merged

  9. #54
    Join Date
    August 2015
    Posts
    8

    Can't change server port

    I'm running a server (3.0.11.3) on Ubuntu 14.04, and everything has been working great. I'm unable, however, to change the server port or apply any other command line settings. I edited ts3server_startscript.sh and put the command on the first line so it looks like this:
    Code:
    COMMANDLINE_PARAMETERS="${2} default_voice_port=1234" #add any command line parameters you want to pass here
    This doesn't work, however--the server is still being started on port 9987, the default port.

    I also tried running ts3server_minimal_runscript.sh createinifile=1, which DID create the .ini file, but after editing it and adding inifile=ts3server.ini to the command line setting like above it still starts on the default port.

    How do I properly force TeamSpeak Server on Linux to start on port 1234 every time it starts?
    Last edited by dante696; August 20th, 2015 at 03:03 PM. Reason: thread merged

  10. #55
    Join Date
    June 2008
    Posts
    17,363
    This is not how you change any voice port after the server isntance did run once already.
    Go to post #2 of this thread.

    Thread merged
    Last edited by dante696; August 20th, 2015 at 04:27 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  11. #56
    Join Date
    November 2015
    Posts
    1

    Unable to set custom port, ini file is loading.

    I cannot get my TS3 server to use a custom port (9122 or any other port). It keeps binding the default port (9987). This is running on Windows Server 2012 r2 using TeamSpeak 3 Server 3.0.11.4 x64. I have setup and maintain multiple (ARMA III, ARK) game servers and have never had this problem. Port 9122 is setup correctly in my firewall and not blocked. The TS3 ini file is loading, as any other changes go in affect.

    If I open port 9987 I can connect, but I would really, really like to use port 9122 with my dyn-dns so 30+ users won't have to update their TS links.

    launch shortcut: ts3server_win64.exe inifile=ts3server.ini

    ts3server.ini:
    machine_id=
    default_voice_port=9122
    voice_ip=167.114.208.41
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0
    query_port=10011
    query_ip=167.114.208.41
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    dbconnections=10
    logpath=logs
    logquerycommands=0
    dbclientkeepdays=30
    logappend=0
    query_skipbruteforcecheck=0

    logs:

    2015-11-19 20:40:10.723501|INFO |VirtualServer | 1| listening on 167.114.208.41:9987

    2015-11-19 20:40:09.590415|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.11.4 (2015-08-18 13:30:34)
    2015-11-19 20:40:09.590415|INFO |ServerLibPriv | | SystemInformation: Windows Server 2012 (9200) x64 (AMD or Intel) Binary: 64bit
    2015-11-19 20:40:09.590415|INFO |ServerLibPriv | | Using hardware aes
    2015-11-19 20:40:09.590415|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2015-11-19 20:40:09.590415|INFO |DatabaseQuery | | dbPlugin version: 3.8.0.2
    2015-11-19 20:40:09.591416|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2015-11-19 20:40:09.600425|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2015-11-19 20:40:10.698477|INFO | | | Puzzle precompute time: 1079
    2015-11-19 20:40:10.698477|INFO |FileManager | | listening on 0.0.0.0:30033
    2015-11-19 20:40:10.723501|INFO |Query | | listening on 167.114.208.41:10011
    Last edited by dante696; November 20th, 2015 at 08:17 AM. Reason: merged, this is not how you change a port

  12. #57
    Join Date
    December 2015
    Posts
    1

    Is it possible to change my server's query port?

    I would like the change my server's query port from 10011.

    I've looked at the serverquickstart, which provided little help, and the query pdf did nothing for me as well. Does anyone know how to accomplish this?
    Last edited by dante696; December 7th, 2015 at 08:46 AM. Reason: merged -> we havea forum search

  13. #58
    Join Date
    April 2007
    Location
    USA
    Posts
    7

    ts3 not binding to default_voice_port entry

    Hi,
    Using Fedora Core 23 X86_64. I changed the default values for voice port to 9999 and all IP addresses from default to 192.168.1.109.

    ini entry:
    default_voice_port=9999

    I pass the ts3server_startscript script the "start inifile=ts3server.ini"

    Server starts and now listens to default port of 9987:

    udp 0 0 192.168.1.109:9987 0.0.0.0:*


    Any guidance? I've tried a handful of port #s between 9800 to 60000.
    Last edited by dante696; February 29th, 2016 at 09:27 AM. Reason: merged

  14. #59
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,265
    This is for CREATING the first server. It does not change EXISTING servers.

  15. #60
    Join Date
    April 2007
    Location
    USA
    Posts
    7

    Only one server

    Quote Originally Posted by numma_cway View Post
    This is for CREATING the first server. It does not change EXISTING servers.
    I am only running a single teamspeak server.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Change TS3 Query Port
    By cddude in forum Windows
    Replies: 3
    Last Post: March 20th, 2014, 06:48 PM
  2. Replies: 10
    Last Post: April 9th, 2012, 08:55 AM
  3. [Resolved] Saving query/filetransfer port changes
    By erikz in forum General Questions
    Replies: 14
    Last Post: April 13th, 2011, 07:51 PM
  4. Change Query Port...
    By Rexikon in forum Linux / FreeBSD
    Replies: 4
    Last Post: August 28th, 2010, 10:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •