Forum

Page 5 of 6 FirstFirst ... 3456 LastLast
Results 61 to 75 of 82
  1. #61
    Join Date
    December 2004
    Location
    RF
    Posts
    3,007
    Your reply does not make sense.
    If you are running a server (already), the option is not going to help you in any way.
    It only exists for a very first start ever.

  2. #62
    Join Date
    April 2007
    Location
    USA
    Posts
    7

    Only one server

    Quote Originally Posted by ANR Daemon View Post
    Your reply does not make sense.
    If you are running a server (already), the option is not going to help you in any way.
    It only exists for a very first start ever.
    When I start the server it uses 9987. So I stop the server and try again, still 9987. I stop the server and write a post on this forum.

    From the docs...default_voice_port (9987) UDP port open for clients to connect to. This port is used by the first virtual server, subsequently started virtual servers will open on increasing port numbers. Default: The default voice port is 9987.

    I have default_voice_port=9999 in the ini. When I run the startup script passing ini file as argument the default port 9987 is used.

    I'd like the option to use a higher port.

    Thanks.

  3. #63
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    OK, to repeat it once again with other words.

    You have to set this option before the first start of the teamspeak3-server. If it has startet before, the voice-port is already set, saved within the database, and has to be changed via serverquery.
    An other way is to delete the server-database, then there will be a created a new database with the voice-port, you have set in your ini-file.

  4. #64
    Join Date
    September 2012
    Posts
    6,080
    Quote Originally Posted by Master_D View Post
    If it has startet before, the voice-port is already set, saved within the database, and has to be changed via serverquery.
    To do this you'll have to use the serveredit command with the virtualserver_port parameter. Like serveredit virtualserver_port=22222


    Quote Originally Posted by Master_D View Post
    An other way is to delete the server-database, then there will be a created a new database with the voice-port, you have set in your ini-file.
    Doing so will obviously delete everything in regards to your server setup. This includes any channels, permissions etc. pp.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  5. #65
    Join Date
    April 2007
    Location
    USA
    Posts
    7

    Resolved default port on new setup

    Quote Originally Posted by Master_D View Post
    OK, to repeat it once again with other words.

    You have to set this option before the first start of the teamspeak3-server. If it has startet before, the voice-port is already set, saved within the database, and has to be changed via serverquery.
    An other way is to delete the server-database, then there will be a created a new database with the voice-port, you have set in your ini-file.
    That was specific enough for me to fix! Thank you.

    I didn't realize the default port was saved in the SQLite database. I didn't find that in the docs. Since this is a friend/family TS server and new I simply deleted the ts3serversqlitedb file and launched the ts3 script to start server passing in the inifile parameter. All the optional parameter values are now active.

    Thanks again! I can now cancel my Mumble subscription and use TeamSpeak3 with 1 Gbps synchronous connection on very fast hardware for friends / family!

  6. #66
    Join Date
    April 2016
    Posts
    1

    Get Teamspeak running on VPS with limited/provided ports

    Hello together,

    I've recently rented a VPS, which provides me a limited portrange. It's running on ubuntu-15.10-x86_64 and I've managed to install teamspeak. The server is running, but it just wont let me change the default 9987 port, so I'm not able to get a connection.

    Let's say the Portrange is 27212 to 27231, the external IP is 121.34.255.30 and the internal IP is 192.168.2.1

    My ts3server.ini:
    Code:
    machine_id=
    default_voice_port=27212
    voice_ip=192.168.2.1
    licensepath=
    filetransfer_port=27213
    filetransfer_ip=192.168.2.1
    query_port=27214
    query_ip=192.168.2.1
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    dbconnections=10
    logpath=logs
    logquerycommands=0
    dbclientkeepdays=30
    logappend=0
    query_skipbruteforcecheck=0
    This part works fine (from _0.log, ports and ip changed)
    Code:
    2016-04-06 17:57:42.253199|INFO    |ServerLibPriv |   |TeamSpeak 3 Server 3.0.12.3 (2016-03-04 08:31:20)
    2016-04-06 17:57:42.253586|INFO    |ServerLibPriv |   |SystemInformation: Linux 2.6.32-042stab113.11 #1 SMP Fri Dec 18 17:32:04 MSK 2015 x86_64 Binary: 64bit
    2016-04-06 17:57:42.253625|WARNING |ServerLibPriv |   |The system locale is set to "C" this can cause unexpected behavior. We advice you to repair your locale!
    2016-04-06 17:57:42.253647|INFO    |ServerLibPriv |   |Using hardware aes
    2016-04-06 17:57:42.257099|INFO    |DatabaseQuery |   |dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2016-04-06 17:57:42.257162|INFO    |DatabaseQuery |   |dbPlugin version: 3.8.6
    2016-04-06 17:57:42.259119|INFO    |DatabaseQuery |   |checking database integrity (may take a while)
    2016-04-06 17:57:42.270794|WARNING |Accounting    |   |Unable to find valid license key, falling back to limited functionality
    2016-04-06 17:57:43.958959|INFO    |              |   |Puzzle precompute time: 1663
    2016-04-06 17:57:43.959223|INFO    |FileManager   |   |listening on 192.168.2.1:27213
    2016-04-06 17:57:43.992972|INFO    |CIDRManager   |   |updated query_ip_whitelist ips: 127.0.0.1,
    2016-04-06 17:57:43.993266|INFO    |Query         |   |listening on 192.168.2.1:27214
    This part drives me nuts (from _1.log, ports and ip changed)
    Code:
    2016-04-06 17:57:43.992234|INFO    |VirtualServer |1  |listening on 192.168.8.161:9987
    I've created the ts3server.ini File using
    Code:
    ./ts3server_minimal_runscript.sh createinifile=1
    before starting the server itself. Now I'm afraid that I've created the virtual server which is using the default port 9987. My attemp to change the port viaserver query/telnet on localhost failed on both ports, 10011 and 9987:
    Code:
    [email protected]:~/teamspeak3-server_linux_amd64$ telnet 127.0.0.1 10011
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused
    Even following modification to the iptables had no effect on the Connection refused Part
    Code:
    [email protected]:/home/teamspeak/teamspeak3-server_linux_amd64# iptables -L -n
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0            udp dpt:9987
    ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0            udp spt:9987
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:30033
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp spt:30033
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:10011
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp spt:10011
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    Can somebody please point out, what I am donig wrong? I've read a lot of tutorials, but would't mind reading more that fit my problem. Also a complete reset would't be an issue, since it would't be the first attempt.

    Thanks in advance!
    Last edited by dante696; April 7th, 2016 at 09:51 AM. Reason: merged, read post #2

  7. #67
    Join Date
    May 2016
    Location
    Florida
    Posts
    2
    Im having a BIG problem, my modem says that is must be way bigger than 9987!
    Any alternatives?
    Last edited by dante696; June 13th, 2016 at 10:28 AM. Reason: merged

  8. #68
    Join Date
    June 2008
    Posts
    18,404
    Your Modem or your router?

    Just change your port as explained in post #2 of this thread.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  9. #69
    Join Date
    December 2016
    Posts
    2

    Change port on Linux ?

    Hi, to start, sorry for my English, I'm French.

    So, I would like to change the port of a teamspeak server because I want to host like 3/4 on the same VPS but I don't find how, I searched like 1h/1h30 on Google and this forum but don't find, I fond only for windows with the server query, or maybe I don't know how to search

    So please, help me, I'm tired to search without results, thank you in advance, cordially.

  10. #70
    Join Date
    June 2008
    Posts
    18,404
    Please read post 2 of this thread for a detailed step by step answer.

    You could have found it on your own by using the word change in our forum search.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  11. #71
    Join Date
    December 2016
    Posts
    2
    Quote Originally Posted by dante696 View Post
    Please read post 2 of this thread for a detailed step by step answer.

    You could have found it on your own by using the word change in our forum search.
    Hi already find this post, thank you, but I'm on a virtual private server (VPS) so it don't work

  12. #72
    Join Date
    June 2017
    Posts
    2

    How do I change the voice server port? (For Dummies answer please)

    Hi all,

    To calibrate my level of aptitude, I'm not completely tech non-savvy (I know how to forward ports, and I know what a command line parameter is, for instance) but I don't know what "SQL" means.

    We used to run our home server just fine, but our new router (or ISP--their tech support was basically useless) won't let us open the Teamspeak 3 default voice port 9987.

    It seems like the easiest solution is just to change the port we are using, and have our friends add ".newportnumber" to the end of our IP for connection. Correct?

    The problem is, I have searched this forum and the internet, and I can't find any simple instructions for how to do this that don't involve downloading some third party software (Putty is the one I keep seeing).

    Do we *really* need to download extra software just to change our port? If not, would anyone be able to give me simple step-by-step instructions that work for my level of tech aptitude?

    Thanks for your time.
    Last edited by dante696; June 12th, 2017 at 10:57 AM. Reason: merged

  13. #73
    Join Date
    September 2012
    Posts
    6,080
    Well to change the port you need to use the server query interface, which is telnet based. As such you will need a telnet client.
    Putty is (one of, if not the) the most used one for Windows, which is why you keep seeing it. You can also enable/install the one that comes with Windows if you prefer.

    In any case to change the port of your existing virtual server:

    Connect putty to your server on the query port (default 10011) and then run these commands:

    Code:
    login serveradmin PASSWORD
    use port=9987
    serveredit virtualserver_port=9999
    serverprocessstop
    After that, just start your server again.
    You will have to replace PASSWORD with the actual password that you received when you first created your TeamSpeak Instance. If you do not remember the password anymore, please see this knowledgebase article.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  14. #74
    Join Date
    June 2017
    Posts
    1

    How to change Teamspeak ports on Linux

    Hello,

    I'm hosting an VPS with a portrange of 13002-13099
    So I can not use the default teamspeak server ports.

    How do I change them on Linux?


    Thanks for helping me out
    ~ MagicalHosting
    Last edited by dante696; June 12th, 2017 at 07:01 PM. Reason: merged

  15. #75
    Join Date
    June 2017
    Posts
    2
    Quote Originally Posted by Chris View Post
    Well to change the port you need to use the server query interface, which is telnet based. As such you will need a telnet client.
    Putty is (one of, if not the) the most used one for Windows, which is why you keep seeing it. You can also enable/install the one that comes with Windows if you prefer.

    In any case to change the port of your existing virtual server:

    Connect putty to your server on the query port (default 10011) and then run these commands:

    Code:
    login serveradmin PASSWORD
    use port=9987
    serveredit virtualserver_port=9999
    serverprocessstop
    After that, just start your server again.
    You will have to replace PASSWORD with the actual password that you received when you first created your TeamSpeak Instance. If you do not remember the password anymore, please see this knowledgebase article.
    Thanks, that makes sense. We'll just activate the Windows Telnet client since it is simple to do. However, I'm not sure how to connect to our server through it. Is there a guide for that somewhere?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Change TS3 Query Port
    By cddude in forum Windows
    Replies: 3
    Last Post: March 20th, 2014, 06:48 PM
  2. Replies: 10
    Last Post: April 9th, 2012, 08:55 AM
  3. [Resolved] Saving query/filetransfer port changes
    By erikz in forum General Questions
    Replies: 14
    Last Post: April 13th, 2011, 07:51 PM
  4. Change Query Port...
    By Rexikon in forum Linux / FreeBSD
    Replies: 4
    Last Post: August 28th, 2010, 10:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •