Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 30
  1. #1
    Join Date
    December 2009
    Location
    Germany
    Posts
    289

    [BETA] libNotify-Plugin

    This is a beta-relase of a libNotify-Plugin.

    All functions are based on the libnotify-lua-scripts and are portet to a native TS3-Plugin.

    Plugin is based on Qt and needs Client-Version RC1-Pre12 or above.

    Current Version: 0.4-RC4

    Download approved:
    http://addons.teamspeak.com/director...libNotify.html
    Last edited by Master_D; April 15th, 2011 at 12:26 PM.

  2. #2
    Join Date
    December 2009
    Location
    Germany
    Posts
    289

    Changelog

    Changelog:
    0.1
    ! Implemented all Features of the Lua-Scripts
    0.2
    + Added Client-Log Debug-Output
    - fixxed minor bugs
    0.2a
    * 64Bit-Version available
    0.3
    + Abillity to recognize Nickname-changes
    - fixxed a bug leading to crash the client
    Last edited by Master_D; November 20th, 2010 at 12:06 PM.

  3. #3
    Join Date
    November 2010
    Location
    Lisbon
    Posts
    7
    Great Work. This is a Nice iniciative... All Plugins I see is M$ only compatible.

    Can this be made to work on OSX as well? Since is unix based...!

    Thks in Advance!

  4. #4
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    There have to be some changes in notification-system, because libnotify isn't available on MacOS, so you have to rewrite it with using growl-notifications.

    The only problem is, that i have no macOS to test, or compile.

  5. #5
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    OK, now an Update of the running process.

    The plugin will get a complete rewrite with using Qt4.6 as only needed Library. Also the Plugin will use DBus, so also KDE-Users can use this plugin, and the configuration should be implemented with GUI.

    After version 0.4 the focus will be porting to Mac OSX and Windows, both using Growl.

  6. #6
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    Port to Qt4.6 complete.
    All Functions are portet, and the Configuration is now implemented as a gui.
    Plugin usable for Linux 32 and 64Bit.

    CHANGELOG:

    0.4-RC1
    * Tested Plugin on Linux x86_64

    0.4-Alpha4
    - Fixed Bug in ChatEvent
    - Fixed Bug in ServerConfig-Saving
    - Fixed Display-Bug in ServerConfig
    + Added Commands for opening Configuration
    ! /notify config for base-config
    ! /notify about for Informations
    ! /notify server for server-based configuration
    ! /notify notification for configuration notification-sinks
    + added Notification-Config
    + added GrowlNotification over Network
    * Sending Notifications is now Threaded

    0.4-Alpha3
    + Added Individual-Configuration for Servers

    0.4-Alpha2
    ! Complete rewrite with Qt 4.6.2
    ! Using Plain DBUS for Linux (freedesktop.org - specification)
    + Configuration-Gui
    + Multi-Lang-Support (Messages only atm)

    0.3
    + Ability to recognize Nickname-Changes
    - Client-Crash-Bug

    0.2a
    * Precompiled 64Bit-Version

    0.2
    + Added Debug-Output for Client-Log
    - minor bugs

    0.1
    ! Implemented all Functionality of the LUA-Scripts

  7. #7
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    Fixed Bug with Thread-Spamming (100% CPU-Usage)

    Changelog:
    0.4-RC2
    - Fixed Bug with Notification-Thread(Thread-Spam)

  8. #8
    Join Date
    February 2011
    Posts
    1
    Hi,

    I'm very interested in your plugin so i downloaded the latest version (0.4-RC2). Then i copied the library files to the TS3 base directory and the plugin one to the plugins directory. I am running Ubuntu 10.10 x64 so i took the x64 versions of the files. Maybe i missed something in the installation procedure because the plugin does not load at all -> in the TS3 plugins configuration window i have this :

    http://img4.hostingpics.net/pics/255240libNotify.png


    Thank you in advance for your help !

  9. #9
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    There was a API-Version-upgrade with Client-Version RC1, so the plugin ist only usable with the pre-releases in beta-channel atm.

    Please update your client using beta-channel, or wait for the official RC1-Release.

  10. #10
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    0.4-RC4
    * Changed to Interface-Version 10
    * Qt-Version changed to 4.7.2 (Synced with TS3-Client)

    0.4-RC3
    * Added additional Newline for DBUS-Notification while using notifyOSD in appendMode
    - Fixed wrong text-encoding
    - Fixed Reading Clients in new Channel
    - Fixed Reading Client-Informations of Query-Clients

    Download at Addon-Page
    Last edited by Master_D; April 15th, 2011 at 12:27 PM.

  11. #11
    Join Date
    March 2011
    Posts
    13
    The latest version of TS3 has api version 11. Can this plugin be made compatible with that?

    http://imageshack.us/photo/my-images/862/ts3plugin.png/
    Last edited by FaykFox; May 12th, 2011 at 07:18 PM.

  12. #12
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    Newly compiled version available.

  13. #13
    Join Date
    March 2011
    Posts
    13
    Are there any plans to make this plugin compatible with the gnome indicator applet?

  14. #14
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    indicator-applets are ubuntu-specific, so there will be no special compatibility.
    The plugin sends all Notifications over DBus, so every Linux-Desktop will them show in the way, it is defined.
    Ubuntu will show them in a bubble (until 10.10, i haven't tested unity yet), and gnome3 on the other side, shows them in the middle of the bottom of the screen.

    But i don't know exactly, what you mean, so can you describe your whish a little more. Maybe i haven't understand, waht you exactly mean.

  15. #15
    Join Date
    March 2011
    Posts
    13
    I'm talking about the indicator panel applet in ubuntu gnome. I've included a screenshot of the applet in question here:

    http://imageshack.us/photo/my-images...unotifier.png/

    You can see the integration of Pidgin, XChat, Thunderbird, and Gwibber. I was not aware this was specific to ubuntu, but it wouldn't surprise me terribly much if it is. That said, it would still be useful for me to have teamspeak show up in that applet.
    Last edited by FaykFox; May 20th, 2011 at 03:59 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Beta] Frigyd - Bot Plugin
    By VenomAK in forum Client Plugins / Lua Scripts
    Replies: 20
    Last Post: July 24th, 2011, 10:08 AM
  2. Add to the gnome indicator panel (libnotify)
    By FaykFox in forum Suggestions and Feedback
    Replies: 2
    Last Post: May 14th, 2011, 05:19 AM
  3. [LUA-Script] Notification with libnotify
    By Master_D in forum Tools / Web Based
    Replies: 3
    Last Post: September 30th, 2010, 02:03 PM
  4. Replies: 5
    Last Post: March 9th, 2010, 02:46 PM
  5. (beta-17) Can't load MySQL plugin
    By Armada651 in forum Server Support
    Replies: 2
    Last Post: February 7th, 2010, 03:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •