Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 3 of 3 FirstFirst 123
Results 31 to 43 of 43
  1. #31
    Join Date
    June 2008
    Posts
    18,513
    Ok I tyred it with laggy Server.
    Pic 1 Connected once and I try to open the dialog.
    Pic 2 I create a channel to get CA and can ope nthe dialog
    Pic 3 I switch back to a channel, I have no member add power.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  2. #32
    Join Date
    December 2009
    Location
    Taiwan
    Posts
    313
    have fun. just did this on the public server.

    http://www.ts3chinese.com/images/bug/init.png

    Just to show that I'm not just changing the text color

    http://www.ts3chinese.com/images/bug/proof.png

    voila

    Steps:

    1. log in the server
    2. wait for the channel lists to populate (since connecting from china, takes a while to populate the channels)
    3. started getting tons of people join/leave notice (since all the join/leaves while you are populating is queued)
    PS: I've also noticed that if it's queued too much, you'll get a connection lost
    4. just when you started hearing the notice -> right click on yourself -> set server group, and you should see the show servergroup dialog is highlighted.
    4a. In case where it did not show up, scroll away from "set server group" option, but keep the popup menu highlighted! -> press a hotkey to change your status (in my case, I used toggle mic mute, with my middle mouse button) serveral times quickly (so the server is taking some time to respond) -> in the meanwhile, scroll back to "set server group" option
    5. select "show server group dialog", and voila

    **Edit: you don't have to be logged in the first time to do it, I can do it with my old identities on the public server even when I'm not in the chinese talk channel.
    Last edited by willy_sunny; December 11th, 2010 at 06:13 PM.

  3. #33
    Join Date
    June 2008
    Posts
    18,513
    Thank you Willy.
    The How to needed an Hotkey (mic mute) and the dialog opened.

    It will be fixed with next client version
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #34
    Join Date
    December 2009
    Posts
    244
    The Hotkey is not on obligation...

    I did it without hotkey too.

    But hop that with the hotkey you found the source of the problem ^^

  5. #35
    Join Date
    January 2011
    Posts
    1
    Hello All,

    Has anyone solved/fix this bug? I have exactly the same issue. So far it is very random but it does allow guests to have admin powers so far I can reproduce it as the pics show above on my laptop on my server.

    I think (not totally sure) that it began when I set the server security level from 8 to 22 (according to a post here somewhere). I then noticed that when I waited to log in, I came in with admin powers so I set the level back to 8. The PC that loged in when the security level was 22 now seems to be the one that has this "exploit" or bug.

    This is just the evidence I have however it may not be due to the series of events described above.

    Any help/advice will be useful

  6. #36
    Join Date
    June 2008
    Posts
    18,513
    Quote Originally Posted by Grenth View Post
    Hello All,

    Has anyone solved/fix this bug? I have exactly the same issue. So far it is very random but it does allow guests to have admin powers so far I can reproduce it as the pics show above on my laptop on my server.

    I think (not totally sure) that it began when I set the server security level from 8 to 22 (according to a post here somewhere). I then noticed that when I waited to log in, I came in with admin powers so I set the level back to 8. The PC that loged in when the security level was 22 now seems to be the one that has this "exploit" or bug.

    This is just the evidence I have however it may not be due to the series of events described above.

    Any help/advice will be useful
    this bug should be fixed with Beta38 and above (rc1-pre3 [Build: 13427] as an example).

    What you describe here makes no sense with the bug as it was described above :-/

  7. #37
    Join Date
    December 2008
    Location
    Michigan
    Posts
    2

    Server Groups Dialog

    I think I may have found a minor bug. When a client first connects to a server. There is a small window where they can access the Server Groups Dialog. I have found this only happens when a linux user is connecting to the server. It does not matter if the person is just connecting or doing a reconnect, they have a small window to access the server groups dialog.

    I have tested to see if a windows user can do the same thing, and it is not possible.

    Linux version: Ubuntu 10.04
    Teamspeak Version: beta 36

  8. #38
    Join Date
    March 2011
    Posts
    2
    i hate to bump this, this may be fixed in beta38? but last i checked that's not out yet, and this sort of exploit is starting to become very erm.. exploited to the point my server has been taken over twice today and now that i know how to do it (and how EASY it is) we've had to put a password (which is an inconvenience, but now necessary) just to stop it.

  9. #39
    Join Date
    June 2008
    Posts
    18,513
    Ye i also hate senseless bumps..

    There is no scecurity risk, when he can ope nthat dialog.... Set a needed_member_add_power into your groups and nothing will happen. Anyways, this should be done before.

    And we released RC1 a while ago > Reading helps
    http://forum.teamspeak.com/showthrea...1-pre-releases
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  10. #40
    Join Date
    March 2011
    Posts
    2
    thanks for that response, but there is a problem, even though I'm set as a server admin, I get the feeling my host has locked certain settings down as that option remains grey to me, secondly the rc1 is currently optional? and if certain people don't update then they can keep exploiting that bug, so why would they update?

    I will email the host and ask them to change it, but I think my point is, this could have easily been fixed by a tiny update.

  11. #41
    Join Date
    June 2008
    Posts
    18,513
    This is no exploit and they can't do anything bad wit hit. This is just something visual and the clienbt already knows the server groups.
    Yes it's optional, we use a new sound system for windows and we won't release a new public version, as long it's not done for linux and Mac.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  12. #42
    Join Date
    March 2011
    Location
    Boise, ID, USA
    Posts
    27
    @TotoIsBack

    I was looking into resolving this asap as I'm experiencing morons coming in my server doing this.

    I have found a solution!

    As simple as this has seemed to have fix, I went through several trials on finding the location of the permission.

    Open Permissions
    Client > i_client_needed_modify_power change it to anything, I've tested it at '25' and it works.

    Now... It kind of works..

    You are still able to open the server dialog windows however when you choose to select a server group, it'll give you the error:
    insufficient client permissions (failed on i_client_needed_modify_power)

    I hope this helps everyone out there and can be stickied as a temporary fix until the newer stable version is released.
    This is my first post in the bugs, so please forgive me if this didn't work for you, but I'm trying to be as helpful as possible in assisting everyone resolve issues such as this one.
    Last edited by Fujiwara; March 24th, 2011 at 11:42 PM.

  13. #43
    Join Date
    December 2009
    Posts
    244
    I know this solution.
    The thing was that it was not correctly done on new groups with good default value, and coupled with this bug lead to a possible exploit.

    As for now, until the visual glitch is corrected, this is the only solution and should always be used as it is an important part of group configuration

    Anyway, thanks for the post as some may have not know this as we did not really talk about it here.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 12
    Last Post: April 24th, 2012, 09:52 PM
  2. Replies: 9
    Last Post: April 23rd, 2012, 08:56 PM
  3. Replies: 4
    Last Post: December 7th, 2011, 06:46 PM
  4. Override client permission with server group
    By binary in forum Permission System
    Replies: 4
    Last Post: July 22nd, 2011, 01:36 PM
  5. [Fixed] Channel to client permission
    By florian_fr40 in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: October 18th, 2010, 10:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •