Hello dear people,

I have tried everything. seriously.

My system: win7 ultimate 64bit, amd phenom II x3, ati hd5770 1gb, 4gb 1666mhz ram, gigabyte GA-870A-UD3

But first, this is the problem:

When I start a (or maximize an already started) game, I can no longer talk in teamspeak3, but I can still hear everyone. this occurs even if I start the game after teamspeak, or teamspeak after the game.
I then continue being unable to "speak" until I go to settings -> voice test thingy (where I can hear myself perfectly fine). after that people can hear me again (same thing when I restart ts3).

but as soon as I maximize the game again, the same thing happens.

What I've tried so far:

  • Running ts3 with admin rights
  • Running ts3 in different compatibility modes
  • Set win7 to "do nothing when communication is detected"
  • Disallow applications to exclusively control the device
  • Reinstalling ts3 about 100 times. Including installing the beta 20 version (which leads to me not being able to join any servers anymore)

I've read pretty much anything google returned for like 20 different search queries related to this problem aswell as all the threads here I found related to this matter.
Some people seem to have (had) the same problem with games (fullscreen programs in general it seems), but somehow all of their problems got resolved with solutions that did not help me (running ts3 with admin rights).

Any clues?

Thanks for any help in advance, really.

P.s: this problem occurs only in ts3, not in mumble, ventrilo 2.x - 3.0 or skype.