Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    November 2010

    Friends Keep Getting "Failed to connect" Error...

    Okay, here's what I've done. I've set up a team-speak 3 server, I've forwarded the ports, and it's hosted on my laptop which resides in my spare room. The server works fine when it's working, no problems what so ever, until for some random unknown reason, it decides to stop working. For some reason, when it's working, I can connect to my server via it's LAN IP, but when it stops working, I can only connect to it using my External IP, but my friends can't connect to it at all.

    My friends all get a "Failed to connect to server" message and so do I if I try and connect through it's LAN IP. I've tried restarting my router, checking the ports, enabling DMZ and renewing my external IP address so that it's completely different but none of these worked permanently. The renewing IP address worked for a bit, and then it stopped working again after about 3 hours of up time. So did enabling DMZ. I have no idea what's triggering this and so far I've done all I can to stop it.

    Could anyone help?

  2. #2
    Join Date
    May 2010

    What is your server version ?
    What is your operating system ?
    Have you something in your server log ?
    Have you a firewall soft ?

  3. #3
    Join Date
    December 2010
    I have a similary problem.
    I installed Teamspek 3 Server on my hosted VServer with OpenSuse 10.3.
    The Start-Protocol said after start './' (passwords here I changed to xxxxxx):
    TeamSpeak Server 3.0.0-beta30 [Build: 12998]
    (c)TeamSpeak Systems GmbH

    Logging started
    2010-12-16 23:37:15.095769|INFO |ServerLibPriv | | Server Version: 3.0.0-beta30 [Build: 12998], Linux
    2010-12-16 23:37:15.096163|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems Gmb H
    2010-12-16 23:37:15.096235|INFO |DatabaseQuery | | dbPlugin version: 3.7.3
    2010-12-16 23:37:15.096690|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2010-12-16 23:37:15.148823|INFO |SQL | | db_CreateTables() tables created

    I M P O R T A N T
    Server Query Admin Acccount created
    loginname= "serveradmin", password= "xxxxxxxx"

    2010-12-16 23:37:15.665865|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionali ty
    2010-12-16 23:37:15.709359|INFO |FileManager | | listening on
    2010-12-16 23:37:15.718848|INFO |VirtualSvrMgr | | executing monthly interval
    2010-12-16 23:37:15.718913|INFO |VirtualSvrMgr | | reset client traffic statistics
    2010-12-16 23:37:15.719309|INFO |VirtualSvrMgr | | reset virtualserver traffic statistics
    2010-12-16 23:37:16.234330|INFO |VirtualServer | 1| listening on
    2010-12-16 23:37:16.235482|INFO |VirtualServer | 1| client 'server'(id:0) added privilege key for servergroup 'Server Adm in'(id:6)
    2010-12-16 23:37:16.236083|WARNING |VirtualServer | 1| --------------------------------------------------------
    2010-12-16 23:37:16.236656|WARNING |VirtualServer | 1| ServerAdmin privilege key created, please use the line below
    2010-12-16 23:37:16.237230|WARNING |VirtualServer | 1| token=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    2010-12-16 23:37:16.237798|WARNING |VirtualServer | 1| --------------------------------------------------------

    I M P O R T A N T
    ServerAdmin privilege key created, please use it to gain
    serveradmin rights for your virtualserver. please
    also check the doc/token_guide.txt for details.


    2010-12-16 23:37:16.238762|INFO |CIDRManager | | updated query_ip_whitelist ips:,
    2010-12-16 23:37:16.239326|INFO |Query | | listening on
    So far so good. The Teamspeak runs. I can connect with my Home PC (Windows XP SP3 32bit). There I have two Teamspeak-Users with different IDs. The ServerAdmin and a Test-User with Guest-Privileges, both have no problems to use this TS-Server.
    Now my problem:
    I tested my Teamspeak-Server with my laptop (Windows 7 64bit) now. But I can't connect to my server. I tried other free Teamspeak-Servers with the same standard-port "9987" and I can connect to these. So I think it can't be a blocked Port or the firewall. A friend also tried to connect to my server from his home (he has a Laptop Windows 7 32bit) but has the same problem with and without an active Software-Firewall:
    <16:41:35> Versuche zum Server auf zu verbinden
    <16:41:41> Verbindung zum Server fehlgeschlagen
    (english: Failed to connect)

    My Server: (no password)
    Tested Client-OS: Windows 7 32bit and 64
    TS 3 Version: 3.0.0-beta30 [Build: 12998]
    Server-OS: OpenSuse 10.3
    Last Log (client 'xxxxx' is my first ServerAdmin-Account):
    2010-12-17 00:53:21.723236|INFO |ServerLibPriv | | Server Version: 3.0.0-beta30 [Build: 12998], Linux
    2010-12-17 00:53:21.724637|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2010-12-17 00:53:21.724704|INFO |DatabaseQuery | | dbPlugin version: 3.7.3
    2010-12-17 00:53:21.725122|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2010-12-17 00:53:21.749155|INFO |SQL | | pruning old database log entries where timestamp is older than 90 days
    2010-12-17 00:53:21.766146|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2010-12-17 00:53:21.815433|INFO |FileManager | | listening on
    2010-12-17 00:53:21.941494|INFO |VirtualServer | 1| listening on
    2010-12-17 00:53:21.942441|INFO |CIDRManager | | updated query_ip_whitelist ips:,
    2010-12-17 00:53:21.943068|INFO |Query | | listening on
    2010-12-18 19:29:30.252829|INFO |VirtualServer | 1| client 'xxxxx'(id:2) added privilege key for servergroup 'Normal'(id:7)
    Thanks for help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: January 1st, 2014, 10:28 PM
  2. "Failed to connect to server" error
    By Ducktape1983 in forum Windows
    Replies: 3
    Last Post: August 26th, 2012, 11:15 AM
  3. "TS3ANetwork::Connect failed error: 10055"
    By FighterGSF in forum Server Support
    Replies: 5
    Last Post: April 28th, 2011, 06:30 PM
  4. Replies: 1
    Last Post: December 14th, 2010, 12:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts