Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    November 2010

    Question Port 9987 cannot be modified...?

    I have a WRT54g, v5, latest firmware. I'm trying to set up a server on my netbook. I have both a laptop and a netbook, and it was set up successfully and runs fine on the laptop, but not on the netbook. Firewall is not the issue, whether software or router (Windows Firewall paired with avast! - turning off Windows Firewall makes no difference; router firewall is off). Router is set up to allow anonymous internet requests, and to forward the 3 ports correctly (9987 on UDP, 10011 and 30033 on TCP).

    The problem is this:
    Port 9987 permanently remains open on my laptop's IP only. It appears unable to be opened on any other machine, no matter what I do.
    At first, I was attempting to see if I could get the server to run on both machines (not at the same time, mind you), but now it looks like the adventure is becoming a quest to find out why port 9987 can't be modified on my network.

    Here's what I've done.
    First, I set the three forwarded ports to my laptop's WAN IP. Ran PFPortChecker on my laptop, all three show as open. Checked them on netbook, all three closed. This is expected.
    Changed the IP for the forwarded ports to my netbook's WAN IP. On the netbook, ports 10011 and 30033 now show as open, but 9987 still shows as closed. Checked port 9987 on my laptop, and it is still open. This is NOT expected.

    I read about setting a DMZ machine, so I set my netbook's IP as the DMZ IP, and voila, port 9987 was suddenly opened on my netbook. I opened the server on my netbook, tried to connect, no dice. Closed the server, checked port 9987 on my netbook, and it's closed on my netbook and open on my laptop again! I retried the DMZ method, and now not even that will get port 9987 to open up on my netbook.

    I believe our network has static WAN IPs, since both the laptop and netbook have the same WAN IP as before when reconnected, so I don't think IPs are the problem.

    I discovered port 9987 on my netbook only closes when I attempt to connect to the server that is hosted on my netbook. When I tried the DMZ method, it stayed open up until that point, even when starting the server, shutting it down, and checking the port.
    I also discovered that, when going to, both my netbook and laptop seem to have the same external IP... Is that even possible?

    I can't figure out what's up for the life of me. Please halp. :'(
    Last edited by thefowles1; January 2nd, 2011 at 12:34 AM. Reason: Clarification purposes.

  2. #2
    Join Date
    February 2006
    Texas, USA
    Based on what you've said it sounds like you just haven't forwarded the ports to the netbook's IP address? The two computers you speak of should have different LAN IP addresses but both should have the same WAN IP address if they share the same internet connection.

  3. #3
    Join Date
    November 2010
    The problem with that is I did forward the ports to the netbook's IP. That's why this is bothering and confusing me.

    I may have gotten LAN and WAN mixed up. Is LAN the address? If so, then that's what I meant instead of WAN. They do have different LAN addresses.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Port 9987 won't open
    By AM-99 in forum Server Support
    Replies: 3
    Last Post: November 20th, 2016, 07:16 PM
  2. port 9987 not working
    By modyghost in forum Linux / FreeBSD
    Replies: 2
    Last Post: September 4th, 2015, 03:18 PM
  3. Yet another port 9987 Issue
    By Rooster2xl in forum Windows
    Replies: 3
    Last Post: August 22nd, 2012, 01:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts