Results 1 to 11 of 11
  1. #1
    Join Date
    May 2010
    Verona - Italy

    I can't close terminal. Server will shutdown

    today if I run ts with this command:
    cd /teamspeak3-server_linux-amd64
    ./ start
    I can't close the terminal (putty) because if I close it the server go shoutdown!
    It is strange, usually I can close it without problems (after the starting appear the word "Logging started")
    What can I do for close the terminal without that the server will go shoutdown?
    Thank you

  2. #2
    Join Date
    May 2010

    Read the documentation :
    Quote Originally Posted by Documentation
    Example (On Screen):
    $ tar xzf teamspeak3-server-linux_x86.tar.gz
    $ cd teamspeak3-server-linux_x86
    $ ./

    Example (Background):
    $ tar xzf teamspeak3-server-linux_x86.tar.gz
    $ cd teamspeak3-server-linux_x86
    $ ./ start
    Use the second solution.

  3. #3
    Join Date
    May 2010
    Verona - Italy
    Oh my god, I wrong the file .sh, thank you (and is since may 2010 that I use teamspeak! ahah)

  4. #4
    Join Date
    October 2014

    Teamspeak Linux x64 Server 3.1.0 - Crashing When ServerQuery Is Closed


    I just upgraded from to 3.1.0. I've noticed that when I disconnect from a ServerQuery session (which I initiate after Telneting in a SSH session) by closing my terminal (through using ALT+F4) my entire server shuts down. To clarify, I SSH (on my remote TS server) -> Telnet (on localhost:10011) -> ServerQuery (within the Telnet session) -> ALT+F4 the terminal I'm in to cause this crash.
    Last edited by dante696; February 25th, 2018 at 09:10 AM. Reason: merged

  5. #5
    Join Date
    June 2008
    Use command ./ start to start your server and it will not shutdown when you close the terminal.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #6
    Join Date
    April 2018

    TeamSpeak Server stopping when closing SFTP/SSH connection

    Hey forum,

    I've been noticing some problems running a TeamSpeak Server in a VirtualBox VM.
    Every time I close a connection (WinSCP or PuTTY), the TeamSpeak server immediately stops running.

    I tried starting the TeamSpeak Server in a screen or doing it the "regular/normal" way.
    Nothing works, atleast not for me. The same thing running in a Hyper-V VM on my Windows Server 2016 works just fine.
    (I don't want to use Hyper-V tho cause of problems with the Linux Kernel and I/O errors.)

    Here is what I tried:
    - running the TeamSpeak Server in a screen ( /
    - running the TeamSpeak Server the "regular" way (./ start inifile=ts3server.ini)
    - running the TeamSpeak Server using nohup
    - using Ubuntu 16.04 instead of Debian 9.4
    - detaching the GUI in VirtualBox
    - attaching the GUI in VirtualBox

    The VM is running a single TeamSpeak Server + 2 SinusBots. It has 1 CPU core with 2.8GHz, 2GB RAM and 8GB HDD storage.
    Closing PuTTY or SFTP doesn't affect anything else running in the VM, it's just the TeamSpeak Server. The SinusBots keep on running just fine.

    Logging in as user "teamspeak" via SFTP -> disconnecting from the SFTP session -> TeamSpeak Server stops
    Logging in as user "sinusbot" via SFTP -> disconnecting from the SFTP session -> SinusBots keep on running

    Well, you can see ... I've tried it all.
    It just makes no sense for me ... this seems to be a TeamSpeak Server problem with VirtualBox, since every other program works just perfectly fine.

    I hope someone can help me with this! =)
    Thanks in advance!


    Screen: screen -AmdS teamspeak-1 /home/teamspeak/server-1/ start inifile=ts3server.ini -- /usr/bin/Xvfb :1 -screen 0 800x600x16 -ac <- Also tried this with the

    Cron: @reboot cd /home/teamspeak/server-1 && ./

    VirtualBox: 5.2.8r121009
    VirtualBox OS: Debian 9.4.0
    TeamSpeak Server: 3.1.1

    2018-04-12 20:30:15.470520|INFO |VirtualServer |1 |listening on, [::]:9987
    2018-04-12 20:34:42.644441|INFO |VirtualServerBase|1 |stopped

  7. #7
    Join Date
    June 2011
    Post log0.

  8. #8
    Join Date
    April 2018
    Hey there, here's the log:

    2018-04-15 00:03:58.451989|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.1.1 (2018-02-26 11:14:04)
    2018-04-15 00:03:58.458450|INFO |ServerLibPriv | |SystemInformation: Linux 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+deb9u3 (2018-03-02) x86_64 Binary: 64bit
    2018-04-15 00:03:58.677296|INFO |DatabaseQuery | |dbPlugin name: MariaDB plugin, version 3, (c)TeamSpeak Systems GmbH
    2018-04-15 00:03:58.677363|INFO |DatabaseQuery | |dbPlugin version: 2
    2018-04-15 00:03:59.675350|WARNING |Accounting | |Unable to open licensekey.dat, falling back to limited functionality
    2018-04-15 00:03:59.718946|INFO |Accounting | |Licensing Information
    2018-04-15 00:03:59.719000|INFO |Accounting | |licensed to : Anonymous
    2018-04-15 00:03:59.719039|INFO |Accounting | |type : No License
    2018-04-15 00:03:59.719083|INFO |Accounting | |starting date : Wed May 31 22:00:00 2017
    2018-04-15 00:03:59.719122|INFO |Accounting | |ending date : Fri Aug 31 22:00:00 2018
    2018-04-15 00:03:59.719157|INFO |Accounting | |max virtualservers: 1
    2018-04-15 00:03:59.719190|INFO |Accounting | |max slots : 32
    2018-04-15 00:04:05.329233|INFO | | |Puzzle precompute time: 5332
    2018-04-15 00:04:06.762886|INFO |FileManager | |listening on, [::]:30033
    2018-04-15 00:04:07.046121|INFO |CIDRManager | |updated query_ip_whitelist ips:, ::1/128,
    2018-04-15 00:04:07.046384|INFO |Query | |listening on, [::]:10011
    2018-04-15 00:04:10.753951|ERROR |Accounting | |failed to update local accounting service

    I've switched back from VirtualBox to Hyper-V... again ...
    But I've found out something, here's the scenario that makes the problem occur still:

    Rebooting VM -> Cronjob opens the TS3 Server -> I open SFTP as user "teamspeak" (which is the same user running the server on the VM) -> I close SFTP -> TeamSpeak Server closes too


    if I start the TeamSpeak Server manually after I closed it using "SFTP" (uh magic) and THEN trying to close it using SFTP, it doesn't close. It only works for the first time when the cronjob is starting the TeamSpeak server.

    Is that a bug in the new 3.1.1 release of the TeamSpeak server?
    If it is, please fix it! It is annoying as hell!


  9. #9
    Join Date
    June 2011
    If that is the full log0, then something instantly kills TeamSpeak. You should not be getting a message like "server is shutting down" but rather "connection timed out".
    Anyway. If nobody else is encountering this issue, it's your server configuration. The fact that closing SFTP closes the server makes it 100% clear it's not a TeamSpeak-related issue at all. Why would TeamSpeak care about completely unrelated SSH sessions?

  10. #10
    Join Date
    April 2018
    Thanks for your reply.

    So ... if there's an issue with my config, what could the issue be?
    No idea what I did wrong tbh.

  11. #11
    Join Date
    April 2018
    Any ideas what could be wrong with my config?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Not possible] Teamspeak server settings via Terminal?
    By disco-dave in forum Linux / FreeBSD
    Replies: 1
    Last Post: July 15th, 2016, 07:17 AM
  2. [Not possible] Close Tab / Close Private Messages
    By Superk in forum Client Plugins / Lua Scripts
    Replies: 1
    Last Post: July 7th, 2016, 07:19 AM
  3. [Not possible] Getting Connected IP Via Terminal
    By RaJiska in forum Linux / FreeBSD
    Replies: 6
    Last Post: May 29th, 2014, 12:05 AM
  4. [Outdated] Close root window = Shutdown Server
    By 2Fast08 in forum Linux / FreeBSD
    Replies: 3
    Last Post: December 24th, 2009, 12:26 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts