Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 11 of 11
  1. #1
    Join Date
    February 2011
    Posts
    4

    Exclamation Teamspeak Server didnīt start after Upgrade Debian 6.0

    Hi

    my English is very bad .. sorry for this ..

    Iīve updated Debian Lenny -> Sqeeze then i made a reboot and now i became following error message when i will start my TS3 Server:

    Code:
    2011-02-11 05:41:13.236690|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta30 [Build: 12998], Linux
    2011-02-11 05:41:13.236846|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2011-02-11 05:41:13.236870|INFO    |DatabaseQuery |   | dbPlugin version: 3.7.3
    2011-02-11 05:41:13.237027|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2011-02-11 05:41:14.954820|CRITICAL|SQL           |   | db_CreateTables() unable to load instance default values
    Please help me..

    Hudson

  2. #2
    Join Date
    May 2010
    Posts
    6,310
    Hello

    This thread can help you :
    http://forum.teamspeak.com/showthrea...ts3db_mysql.so

    Search function

  3. #3
    Join Date
    February 2011
    Posts
    4
    This is not the answer of my problem ..

    Iīve setup new ts3server instance that would be running but the old one doesnīt run anymore..

    I think the old ts3server.sqlitedb doesnīt work anymore..

    BUT WHY?????

    itīs a file of 26MB the new one has 191KB ..

  4. #4
    Join Date
    May 2010
    Posts
    6,310
    Read good :
    TeamSpeak uses libmysqlclient.so.15 but Debian Squeeze serves libmysqlclient.so.16.
    Install the old version of mysqlclient or (make a backup before) create a symbolic link 15 => 16

  5. #5
    Join Date
    February 2011
    Posts
    4
    Sorry but how do i do this ??? can u send me a how to ???

  6. #6
    Join Date
    February 2011
    Posts
    4
    I have both 15 + 16 ..

  7. #7
    Join Date
    May 2010
    Posts
    6,310
    You have all documentation on the Debian web site.

    Or use the search function with the "libmysqlclient" keyword.
    You'll find many many threads with a method to fixe your poblem.
    Last edited by florian_fr40; February 12th, 2011 at 06:53 PM.

  8. #8
    Join Date
    February 2011
    Posts
    6
    thanks florian teamspeak3 server beta 30 has sql incompatibility with debian squeeze (libmysql)
    solution please ??

  9. #9
    Join Date
    January 2010
    Location
    The Netherlands
    Posts
    8

    Lightbulb

    It's quite easy to fix this problem, once you know the solution.
    All you have to do is download the package 'libmysqlclient15off' from packages.debian.org and install it.

    You can do so with the following commands:
    Code:
    wget http://ftp.nl.debian.org/debian/pool/main/m/mysql-dfsg-5.0/libmysqlclient15off_5.0.51a-24+lenny5_i386.deb
    sudo dpkg -i libmysqlclient15off_5.0.51a-24+lenny5_i386.deb
    After doing this, you can start your TeamSpeak3-server.

  10. #10
    Join Date
    March 2009
    Location
    Germany
    Posts
    74

    Exclamation

    I have the same problem with Server x86 3.0.0 on Debian squeeze which uses libmysqlclient16 instead of libmysqlclient15 and the problem is that TeamSpeak 3 explicitly wants libmysqlclient15.

    I already found libmysqlclient.so and libmysqlclient.so.16 (both are symlinks to libmysqlclient.so.16.0.0) in my /usr/lib/ dir but no libmysqlclient.so.15 so i just created a symlink named libmysqlclient.so.15 to libmysqlclient.so.16.0.0

    Now the lib is found but TS3 still wont start. Here is what ldd says:

    Code:
    [email protected]:~/teamspeak3$ ldd libts3db_mysql.so
    ./libts3db_mysql.so: /usr/lib/libmysqlclient.so.15: version `libmysqlclient_15' not found (required by ./libts3db_mysql.so)
            linux-gate.so.1 =>  (0xb77ba000)
            libmysqlclient.so.15 => /usr/lib/libmysqlclient.so.15 (0xb75b1000)
            libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb74bc000)
            libm.so.6 => /lib/i686/cmov/libm.so.6 (0xb7495000)
            libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7477000)
            libc.so.6 => /lib/i686/cmov/libc.so.6 (0xb7331000)
            libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xb7318000)
            libcrypt.so.1 => /lib/i686/cmov/libcrypt.so.1 (0xb72e6000)
            libnsl.so.1 => /lib/i686/cmov/libnsl.so.1 (0xb72ce000)
            libz.so.1 => /usr/lib/libz.so.1 (0xb72ba000)
            /lib/ld-linux.so.2 (0xb77bb000)
    @ TeamSpeak-Team: Please update your libts3db_mysql.so!

  11. #11
    Join Date
    May 2010
    Posts
    6,310
    Hello

    Please follow the ERIKvanPAASSEN's instruction.
    On debian a simple link doesn't works.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Teamspeak won't start on Debian
    By CalibeR.50 in forum Linux
    Replies: 6
    Last Post: March 30th, 2015, 05:36 AM
  2. Problem to start my server (upgrade debian)
    By v1g00 in forum Linux / FreeBSD
    Replies: 10
    Last Post: February 17th, 2011, 11:24 PM
  3. [Solved] My Server didn't start after ip changing
    By MasterM in forum Server Support
    Replies: 7
    Last Post: March 11th, 2010, 04:57 PM
  4. Debian Linux Server Upgrade
    By craighton in forum Linux / FreeBSD
    Replies: 1
    Last Post: February 26th, 2010, 08:01 AM
  5. How to upgrade from ts2 to ts3 on Debian Lenny?
    By StRiANON in forum Linux / FreeBSD
    Replies: 4
    Last Post: December 23rd, 2009, 06:49 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •