Forum

Page 1 of 4 123 ... LastLast
Results 1 to 15 of 49
  1. #1
    Join Date
    February 2011
    Posts
    10

    Error, could not open the selected capture device

    I recently had to start using the rc1 pre10 release of 3.0.0 TS3 due to a plugin requiring it. But once I try to use my USB Mic it says

    "Error, could not open the selected capture device"

    This has only happened with the rc1 version, help please?

  2. #2
    Join Date
    February 2011
    Posts
    10
    (Some extra information just in case).

    I recently updated my TS3 to rc1 pre 10 since one of my plugins (A.C.R.E) required me to. Now the issue is that when I try to configure my settings so that I use my USB mic (Actually from my webcam) it says "error, could not open selected capture device." Before I started using this version of TS, the mic worked fine without this issue and I'm sure the issue is due to TS, since the mic works in any other program. Thanks in advance for any help
    Last edited by Khaki; March 4th, 2011 at 11:35 PM.

  3. #3
    Join Date
    February 2011
    Posts
    10
    Can anyone help? I'm at a complete loss here

  4. #4
    Join Date
    June 2008
    Posts
    17,714
    Have you tryed to change the capture mode for this device?
    What device do you use?
    Do yuo get an error in your client log?

    Please update your soundcard or usb headset driver.
    Try another USB port for your USB headset or soundcard.
    Last edited by dante696; December 9th, 2015 at 12:59 PM.

  5. #5
    Join Date
    February 2011
    Posts
    10
    I've tried both Auto best mode and direct sound capture modes.
    The device itself is the Logitech pro 9000 webcam, which I use the mic attached to it.
    Also, I did not see any errors in the client log.

    EDIT:

    My bad, there were errors in the log... whoops

    Here's an exact copy of the log

    2011-03-04 18:39:27.671875|INFO | | | Logging started, clientlib version: 3.0.0-rc1-pre10 [Build: 13849]
    2011-03-04 18:39:27.750000|DEBUG |Direct Sound | | setting timer resolution to 1ms
    2011-03-04 18:39:27.765625|INFO |SoundBackendInterface| | Load Library failed with errorno 126
    2011-03-04 18:39:27.781250|INFO | | | Registering plugin command id: {b3af956d-001b-41db-912c-22d3a8b7b109} acre
    2011-03-04 18:39:27.781250|INFO | | | Registering plugin command id: {90fb1e59-e1f1-4ca1-89a1-cb1544d25b1a} appscanner_plugin
    2011-03-04 18:39:27.781250|INFO |Query | | listening on 127.0.0.1:25639
    2011-03-04 18:39:27.921875|INFO |SoundDevManager| | STOPWATCH1 closePlaybackDevice: 0 ms-1
    2011-03-04 18:39:27.921875|INFO |SoundDevManager| | STOPWATCH1 closePlaybackDevice: 0 ms-1
    2011-03-04 18:39:28.187500|INFO |ClientUI | | TeamSpeak 3 client version: 3.0.0-rc1-pre10 [Build: 13849]
    2011-03-04 18:39:28.187500|INFO |ClientUI | | Qt version: 4.6.2
    2011-03-04 18:39:28.187500|INFO |ClientUI | | Using configuration location: C:/Documents and Settings/Paul/Application Data/TS3Client/ts3clientui_qt.conf
    2011-03-04 18:39:28.656250|INFO |ClientUI | | Last update check was: 금 3 4 18:31:30 2011
    2011-03-04 18:39:31.828125|ERROR |SoundBackendInterface| | C:/Documents and Settings/Paul/Local Settings/Application Data/TeamSpeak 3 Client/soundbackends/directsound.dll error: CAPTURE_FORMAT_NOT_SUPPORTED
    2011-03-04 18:39:31.828125|INFO |SoundDevManager| | STOPWATCH1 internalOpenDevice: 2 ms-1
    2011-03-04 18:39:31.828125|INFO |SoundDevManager| | STOPWATCH1 openCaptureDevice: 2 ms-1
    2011-03-04 18:39:31.828125|ERROR |CapSoundSet | | Failed to open capture device when updating capture system: 2310
    2011-03-04 18:39:31.843750|INFO |SoundDevManager| | STOPWATCH1 internalOpenDevice: 12 ms-1
    2011-03-04 18:39:31.843750|INFO |SoundDevManager| | STOPWATCH1 internalStartDevice: 1 ms-1
    2011-03-04 18:39:31.843750|INFO |SoundDevManager| | STOPWATCH1 openPlaybackDevice: 14 ms-1
    2011-03-04 18:39:31.843750|ERROR |CapSoundSet | | Error setting PreProcessorConfigValues onPTTActivated: 2304
    2011-03-04 18:39:31.843750|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:31.875000|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:31.890625|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:31.906250|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:31.937500|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:31.953125|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:31.968750|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:31.984375|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.015625|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.031250|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.046875|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.062500|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.093750|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.109375|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.125000|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.156250|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.171875|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.187500|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.203125|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.234375|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.250000|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.265625|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.296875|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.312500|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.328125|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.343750|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-04 18:39:32.359375|INFO |SoundDevManager| | STOPWATCH1 closeCaptureDevice: 0 ms-1
    2011-03-04 18:39:32.359375|INFO |SoundDevManager| | STOPWATCH1 closeCaptureDevice: 0 ms-1
    2011-03-04 18:39:32.546875|INFO |SoundDevManager| | STOPWATCH1 internalCloseDevice: 10 ms-1
    2011-03-04 18:39:32.546875|INFO |SoundDevManager| | STOPWATCH1 closePlaybackDevice: 10 ms-1
    2011-03-04 18:39:33.875000|INFO |SoundDevManager| | STOPWATCH1 closeCaptureDevice: 0 ms-1
    2011-03-04 18:39:34.046875|INFO |SoundDevManager| | STOPWATCH1 closePlaybackDevice: 0 ms-1

  6. #6
    Join Date
    March 2011
    Posts
    1
    I'm getting the same exact thing as Khaki and need the program as well for ACRE. I am using a usb webcam as well. I'm using a Logitech Netbook web-cam. Works fine on previous builds of TS. Not going to post log files, same as Khaki with the 2304 error. Will post logs if requested though.

  7. #7
    Join Date
    February 2011
    Posts
    10
    I think this may just be a bug with the beta version of TS3, if so it'll have to be fixed and hopefully fixed in a new release

  8. #8
    Join Date
    March 2011
    Posts
    3

    Failed to open capture device settings

    Hey all, Ts3 used to to work on my old system and when I installed it on my new computer it says "failed to open capture device settings. Please check capture device settings". When I look at the capture window under options it says that the capture device is an "invalid device". I have looked around and spoken to others but cannot seem to find an answer.

    I also tried to uninstall the program but when I reinstalled it there must be a file somewhere as all of my details were automaticly installed as well and the problem continued.

    Thanks for any help.

  9. #9
    Join Date
    March 2011
    Posts
    3
    After having posted the above, similar threads came up so I had a look at them( search function is not working at the top of the page?). It seems that there are several people that are having similar problems but there seems to be no response and no real advice being given to overcome this issue.

  10. #10
    Join Date
    June 2008
    Posts
    17,714
    I send this post's to a developer, maybe he has an solution for this.
    RC1-pre 11 will be released today or tomorrow, mayber it solves your problems.

    Hope this will be added into RC1-pre11 release for today. A developer will fix this immediately.
    Last edited by dante696; March 9th, 2011 at 08:29 AM.

  11. #11
    Join Date
    June 2002
    Location
    Netherlands
    Posts
    1,049
    A fix is added. It will probably solve your problem

  12. #12
    Join Date
    March 2011
    Posts
    3
    Thanks guys, will try to download now and see where it leaves me. Appreciate all of your time. Tc.

  13. #13
    Join Date
    February 2011
    Posts
    10
    Hey, thanks for the help Dante and nwerensteijn =)

    I updated to rc11 and sadly..same problem persists. I'll add the log of the session.

    2011-03-11 21:35:50.875000|INFO | | | Logging started, clientlib version: 3.0.0-rc1-pre11 [Build: 13907]
    2011-03-11 21:35:50.953125|DEBUG |Direct Sound | | setting timer resolution to 1ms
    2011-03-11 21:35:50.968750|INFO |SndBckndIntf | | Load Library failed with errorno 126
    2011-03-11 21:35:50.968750|INFO | | | Registering plugin command id: {c8707559-9dfd-4552-89a0-0eff5e27e0d7} appscanner_plugin
    2011-03-11 21:35:50.984375|INFO |Query | | listening on 127.0.0.1:25639
    2011-03-11 21:35:51.109375|INFO |SoundDevManager| | STOPWATCH1 closePlaybackDevice: 0 ms-1
    2011-03-11 21:35:51.312500|INFO |ClientUI | | TeamSpeak 3 client version: 3.0.0-rc1-pre11 [Build: 13907]
    2011-03-11 21:35:51.312500|INFO |ClientUI | | Qt version: 4.6.2
    2011-03-11 21:35:51.312500|INFO |ClientUI | | Using configuration location: C:/Documents and Settings/Paul/Application Data/TS3Client/ts3clientui_qt.conf
    2011-03-11 21:35:51.781250|INFO |ClientUI | | Last update check was: 금 3 11 16:42:18 2011
    2011-03-11 21:35:55.531250|ERROR |SndBckndIntf | | C:/Documents and Settings/Paul/Local Settings/Application Data/TeamSpeak 3 Client/soundbackends/directsound.dll error: CAPTURE_FORMAT_NOT_SUPPORTED
    2011-03-11 21:35:55.531250|INFO |SoundDevManager| | STOPWATCH1 internalOpenDevice: 6 ms-1
    2011-03-11 21:35:55.531250|INFO |SoundDevManager| | STOPWATCH1 openCaptureDevice: 7 ms-1
    2011-03-11 21:35:55.531250|ERROR |CapSoundSet | | Failed to open capture device when updating capture system: 2310
    2011-03-11 21:35:55.546875|INFO |SoundDevManager| | STOPWATCH1 internalOpenDevice: 19 ms-1
    2011-03-11 21:35:55.546875|INFO |SoundDevManager| | STOPWATCH1 internalStartDevice: 0 ms-1
    2011-03-11 21:35:55.546875|INFO |SoundDevManager| | STOPWATCH1 openPlaybackDevice: 19 ms-1
    2011-03-11 21:35:55.546875|ERROR |CapSoundSet | | Error setting PreProcessorConfigValues onPTTActivated: 2304
    2011-03-11 21:35:55.546875|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.562500|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.578125|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.593750|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.625000|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.640625|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.656250|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.671875|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.703125|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.718750|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.734375|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.765625|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.781250|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.796875|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.812500|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.843750|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.859375|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.875000|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.906250|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.921875|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.937500|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.953125|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:55.984375|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:56.|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:56.015625|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:56.031250|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:56.062500|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:56.078125|ERROR | | | VADDisplay timer: Error reading voice power: 2304
    2011-03-11 21:35:56.078125|INFO |SoundDevManager| | STOPWATCH1 closeCaptureDevice: 0 ms-1
    2011-03-11 21:35:56.078125|INFO |SoundDevManager| | STOPWATCH1 closeCaptureDevice: 0 ms-1
    2011-03-11 21:35:56.328125|INFO |SoundDevManager| | STOPWATCH1 internalCloseDevice: 0 ms-1
    2011-03-11 21:35:56.328125|INFO |SoundDevManager| | STOPWATCH1 closePlaybackDevice: 0 ms-1
    2011-03-11 21:35:57.562500|INFO |SoundDevManager| | STOPWATCH1 closeCaptureDevice: 0 ms-1
    2011-03-11 21:35:57.734375|INFO |SoundDevManager| | STOPWATCH1 closePlaybackDevice: 0 ms-1

  14. #14
    Join Date
    February 2011
    Posts
    10
    So I guess rc12 will have a fix for this then? rc11 didn't help out.

  15. #15
    Join Date
    June 2008
    Posts
    17,714
    Nope not yet, but i have send this thread to to the develoepr again. I think, he will have a look at it tomorrow.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Error, Could not open Capture device???
    By Alfred_Timperley in forum General Questions
    Replies: 0
    Last Post: December 28th, 2015, 07:03 PM
  2. Error Could Not Open Capture Device
    By |DHC|John in forum Windows
    Replies: 0
    Last Post: March 26th, 2014, 04:06 PM
  3. Error, could not open Capture Device.
    By feral in forum Windows
    Replies: 1
    Last Post: January 5th, 2012, 05:05 PM
  4. Error: Could not open selected capture device. HELP!!!!!
    By CrispyFries in forum Bug Reports [EN/DE]
    Replies: 0
    Last Post: August 19th, 2011, 08:02 PM
  5. Replies: 1
    Last Post: April 19th, 2011, 07:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •