Forum

Results 1 to 8 of 8
  1. #1
    Join Date
    March 2011
    Posts
    13

    more issues with pulseaudio

    I'm currently running the TS3 client on Fedora 14 and having some issues with transmitting audio. After doing some research, I found that a similar problem had been occurring about a year ago, but a more recent update appears to have fixed that issue.

    On my system, I'm able to receive audio without problems. However, on transmitting and testing capture volume, the input is very choppy. I can even see the input level on the teamspeak "test voice" meter lagging severely. Consequently, nobody on the teamspeak server can understand me; my voice comes through in small "chunks".

    This issue has only cropped up as of my switch to new hardware. I did not experience this issue on an old AMD Athlon 64 running F14. My new AMD E-350 Zacate system is showing this problem however, with PulseAudio's process reaching 35% CPU usage. I've switched between ALSA and PulseAudio as my selected input sound system, with no change in performance.

    Any suggestions or ideas would be welcome.

  2. #2
    Join Date
    March 2011
    Posts
    13
    Some more information on this issue:

    I installed Audacity to test recording there. When using the default input, I receive the same issue of high CPU usage as well as the sound stuttering.

    However, in Audacity, I'm able to select "ALSA: HDA ATI SB: ALC892 Analog (HW:1,0)". Selecting this seems to fix the recording issues. I am able to record sound with no stutters.

    When selecting ALSA in teamspeak, I have no options other than "Internal Analog Stereo", which produces the same results as the identical PulseAudio selections.

    I continue to be baffled by this.

  3. #3
    Join Date
    June 2008
    Posts
    18,301
    There is a new sound system work in progress for Linux and Mac OSX (windows version already exists). The developers don't try to fix old bugs, we hope your sound problem will be fixed automatically :-/
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #4
    Join Date
    July 2006
    Location
    Sweden
    Posts
    76
    Must be some issue with Fedoras PulseAudio then.

    I have used TeamSpeak 3.0.0-beta36 [Build: 12815] 64 bit since it was released 8th of November. About 4 hours a day since that. With some extremely fast calculations that is about 512 hours, never ever had any CPU issues since they fixed it.

  5. #5
    Join Date
    March 2011
    Posts
    13
    I think it's actually more to do with the new AMD hardware architecture I'm running. The last box I had TS3 running on with the same version of Fedora still runs just fine. However, that was an old, power-hungry system that I'm replacing.

    As far as I can tell, the only difference between the two systems is in the hardware, not the software

    Keeping my fingers crossed that a new build of the sound system in TS will fix the issue, or at least provide a viable work-around for me.

  6. #6
    Join Date
    June 2008
    Posts
    18,301
    Please read this post, to get a preview version of our nofmod version
    http://forum.teamspeak.com/showthrea...950#post277950
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #7
    Join Date
    March 2011
    Posts
    13
    I ran the new build, and was experiencing the same issue. Unfortunately, it looks like this is probably not an issue with Teamspeak itself. This appears to be a problem with the Realtek drivers for the sound card on this motherboard (ATI Technologies Inc SBx00 Azalia).

    Apparently this card has issues with ALSA for input. The best solution currently is to switch to OSS, which is not terribly feasible on a stock install of Fedora or Ubuntu.

    Thanks for the assistance!

  8. #8
    Join Date
    March 2011
    Posts
    13
    thought I would update this thread. Running the latest ubuntu (11.04) with the latest x64 linux teamspeak client has solved the issue . I had to set my capture mode to ALSA and my device to HDA ATI SB(ALC892 Analog) [plughw:1,0].

    Interestingly, left at the default settings, teamspeak would crash when trying to capture sound with a segmentation fault.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems using Pulseaudio
    By anony in forum Linux
    Replies: 0
    Last Post: November 1st, 2014, 09:48 PM
  2. PulseAudio and my Interface/Microphone
    By SmallTock in forum Linux
    Replies: 1
    Last Post: May 31st, 2014, 09:41 AM
  3. problems _without_ pulseaudio
    By sk1p_ in forum Linux
    Replies: 0
    Last Post: March 5th, 2010, 12:32 AM
  4. Pulseaudio Update, no CPU Bug for me
    By Stephan13360 in forum Linux
    Replies: 3
    Last Post: January 28th, 2010, 01:05 PM
  5. Replies: 20
    Last Post: December 21st, 2009, 12:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •