Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 8 of 8
  1. #1
    Join Date
    December 2009
    Location
    Germany
    Posts
    289

    Teamspeak mutes other Audio-Sources

    When i starts rhythmbox after teamspeak3 Client is started, the output of rhythmbox is mutet within Pulseaudio.

    Tested with Teamspeak3-Client Build 14208 and earlier of RC1-pre12 (32Bit)
    The used system is Archlinux, if this infirmation is needed.

  2. #2
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,191
    If your sound-card can (in hardware) only playback one audio stream, then you must make sure that all applications use pulse audio (or something like dmix, which I will ignore here). So, make sure TS3 is using playback via pulse audio, and also make sure your rhythmbox is set to use pulse audio (I hope it can?). The scenario you describe is expected if (a) your sound-card only supports one sound stream in hardware (b) TS3 and rhythmbox are not both set to use pulse as playback mode.

  3. #3
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    OK, i've said already, the audio-stream of Rhythmbox is muted within pulseaudio. The image attached show you exactly, what i mean.

    All audio-streams are routed through Pulseaudio, so that is not the problem. I'm Using the pulseaudio-backend of teamspeak since it was possible, but after introducing the new audio-backend, this problem is appearing.

    What you can see on the image, is reproducable like this.

    Start teamspeak-client and connect to a server.
    Start rhythmbox and play something. You won't hear anything from the Rhytmbox-audio, because it is muted.
    Attached Images Attached Images  

  4. #4
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    OK, Update!

    Testet with Pre13. Nothing changed.

    Audio-Stream becomes mutet if teamspeak is already connected to a server or while connecting to a server. You have to unmute the Rhythmbox-Audio-Stream after that.
    Only appears with the first server-connection. New connection in new tab does not mute Rhythmbox.

  5. #5
    Join Date
    June 2008
    Posts
    18,513
    I talke to peter about it and he can't reproduce this :-/
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #6
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    Ok, i've tested it enough now.

    Everytime i start a audio-stream in Pulseaudio, which comes from an Application of the Gnome-Desktop, it will be muted within Pulseaudio. Other applications are not muted in Pulseaudio.

    Tested Applications (only a few):
    Rhytmbox, muted
    Totem, muted
    Banshee, not muted
    VLC, not muted

    I don't know what it is, but it appears after Fmod was removed, so it has to be in the new audio-backend of teamspeak.
    There were no changes on the audio-System, and only appears, when teamspeak-client is connected to a server.

    I will test it on ubuntu in the next few days, and tell my results after the test.

  7. #7
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    Tested with Ubuntu 10.04. Problem does not appear.

    Seems to be a special problem, based on the packages of archlinux.
    Other posibility, Flag, that is not used with ubuntu, pulseaudio-packages are patched by ubuntu.

  8. #8
    Join Date
    December 2009
    Location
    Germany
    Posts
    289
    I've tested some more, and it seems, that i've found the Problem.

    You seem to have your Audio-stream tagged with "voice" or something like this, that you send to pulseaudio. The upstream-version of pulseaudio mutes streams from other programms that are tagged with "music" or something like this. Ubuntu may have patched this behaviour out, so this does not appear in ubuntu.
    The suggestion is created under http://forum.teamspeak.com/showthrea...817#post281817

    This behaviour is reproducable with other applications like Skype, which also tags his audio-streams.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: November 23rd, 2017, 04:56 PM
  2. Audio mutes.
    By lift_off in forum iOS
    Replies: 2
    Last Post: January 10th, 2014, 02:24 PM
  3. [SUGGESTION] Possibility to select DEFAULT/OS Audio Sources
    By Agrikaan in forum Suggestions and Feedback
    Replies: 8
    Last Post: January 13th, 2011, 11:53 PM
  4. Restart for audio sources?
    By Whinis in forum Linux
    Replies: 0
    Last Post: February 11th, 2010, 08:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •