Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    October 2009
    Location
    Paris (France)
    Posts
    12

    TS3 Serveur stop when logout from ssh

    Hi all,

    I have installed a TS3 Server on my synology 710+. It work like a charm, when i start it via putty (root). But when i exit from SSH, the server stop runing.

    Someone can help me ?

    Thanks.

  2. #2
    Join Date
    May 2010
    Posts
    6,310
    Hello

    In documentation :
    Example (On Screen):
    $ tar xzf teamspeak3-server-linux_x86.tar.gz
    $ cd teamspeak3-server-linux_x86
    $ ./ts3server_minimal_runscript.sh

    Example (Background):
    $ tar xzf teamspeak3-server-linux_x86.tar.gz
    $ cd teamspeak3-server-linux_x86
    $ ./ts3server_startscript.sh
    You have to use the second start command.

    This question has been answered many times on this forum. Next time please use the search function (and read the doc ).

  3. #3
    Join Date
    October 2009
    Location
    Paris (France)
    Posts
    12
    Thanks for your answer,

    But i already use the second start command and the server still stop running when i left my SSH session

  4. #4
    Join Date
    December 2009
    Location
    New Jersey USA
    Posts
    77
    CTRL-A followed by D lets you detach from a screen without closing it.

  5. #5
    Join Date
    October 2009
    Location
    Paris (France)
    Posts
    12
    Thanks for your answer.

    still not working. CTRL-A followed by D close putty, Then few seconds after the client is disconnect from the server (cause the server crash when putty close).

    I presume there is a possibility to let the TS3 server runing even when closing the SSH. But can't find it on the forum.

    Mumble sever in runing fine on my syno 710+ so i dont understand why the TS3 server process close (or crash) when leaving SHH.

    TS3 linux server is install on the syno, then i m using ts3server_startup.sh for running it (fine, until leaving putty)

    Thanks for your help.

  6. #6
    Join Date
    October 2009
    Location
    Paris (France)
    Posts
    12
    Few more informations that can help to understand my problem :
    This is the end if the log file of my server, as you can see, the server stop runing cause it receive the SIGHUP Signal.

    11-04-24 17:20:39.819655|WARNING |Accounting | | Unable to find valid license key, falling back to limited
    2011-04-24 17:20:40.394928|INFO |FileManager | | listening on 0.0.0.0:30033
    2011-04-24 17:20:40.548708|INFO |VirtualServer | 1| listening on 0.0.0.0:9987
    2011-04-24 17:20:40.550338|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2011-04-24 17:20:40.551817|INFO |Query | | listening on 0.0.0.0:10011
    2011-04-24 17:29:14.151919|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.152284|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.152474|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.152671|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.152852|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.153032|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.151982|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.152117|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.153279|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.153453|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.153652|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.153832|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    2011-04-24 17:29:14.153998|INFO |ServerMain | | Received signal SIGHUP, shutting down.
    So i have add a nohup command in ts3server_startscript.sh like this :


    echo "${BINARYNAME} is not executable, trying to set it"
    chmod u+x "${BINARYNAME}"
    fi
    if [ -x "$BINARYNAME" ]; then
    export LD_LIBRARY_PATH="${LIBRARYPATH}:${LD_LIBRARY_PATH} "
    nohup "./${BINARYNAME}" ${COMMANDLINE_PARAMETERS} > /dev/null &
    echo $! > ts3server.pid
    echo "TeamSpeak 3 server started, for details please view the log file"
    else
    echo "${BINARNAME} is not exectuable, cannot start TeamSpeak 3 server"
    fi
    else



    But that doesn't work.

    Any idea ?

    Btw, this is a Syno 710+ and the screen command does not work on it (for me, but i'm a noob)

    Thanks

  7. #7
    Join Date
    May 2011
    Posts
    3
    try the command "screen" instate of nohup.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. login -logout from members
    By muellionaer in forum General Questions
    Replies: 4
    Last Post: August 16th, 2010, 02:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •