Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 2 of 2 FirstFirst 12
Results 16 to 25 of 25
  1. #16
    Join Date
    May 2006
    Location
    Europe/Czech Rep.
    Posts
    1,616
    touch: Debian 6.0 teamspeak3.0.* error: unable to load database plugin library "libts3db_mysql.so", halting!
    solution:
    edit /etc/apt/sources.list
    by adding ....lenny main contrib
    then by using aptitude/apt search libmysql
    that should offer you that libmysqlclient15off package in list, and you are set to go (aptitude install, .... run) :]

  2. #17
    Join Date
    May 2011
    Location
    Vienna
    Posts
    4

    libmysqlclient.so.15 not found

    hey,
    i have a problem with my teamspeak server.

    Code:
    2011-05-06 09:06:58.881776|INFO    |ServerLibPriv |   | Server Version: 3.0.0-rc1 [Build: 14262], Linux
    2011-05-06 09:06:58.881904|INFO    |DatabaseQuery |   | Please make sure you use the supplied ts3server_minimal_runscript.sh to run the server, or set LD_LIBRARY_PATH yourself
    2011-05-06 09:06:58.881927|CRITICAL|DatabaseQuery |   | unable to load database plugin library "libts3db_mysql.so", halting!
    Code:
    ldd libts3db_mysql.so
            linux-vdso.so.1 =>  (0x00007fffffd8e000)
            libmysqlclient.so.15 => not found
            libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fa2d4c95000)
            libm.so.6 => /lib/libm.so.6 (0x00007fa2d4a12000)
            libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007fa2d47fc000)
            libc.so.6 => /lib/libc.so.6 (0x00007fa2d449b000)
            /lib64/ld-linux-x86-64.so.2 (0x00007fa2d51b4000)
    i think he can't found my libmysqlclient.so.15 ... but i have the libmysqlclient.so.16 instead...

    can teamspeak handle with this lib?

    are there solutions for this problem?
    i hope you can help me

  3. #18
    Join Date
    May 2011
    Location
    Vienna
    Posts
    4
    SOLUTION:

    wget http://ftp.nl.debian.org/debian/pool...51a-24+lenny5_amd64.deb
    dpkg -i libmysqlclient15off_5.0.51a-24+lenny5_amd64.deb

    now your teamspeak server should start without problems. it worked for me.

    if you get a error when you try to connect to your mysql database try this:

    mysql_save &

    now you should can connect to your database without getting a sock error

  4. #19
    Join Date
    October 2011
    Posts
    0

    TS3 useing mysql in cloud

    ts3server_2011-10-03__20_40_15.366653.logok guys i have a hard one i am useing CENTOS 6 lates install and updated

    here is a link to my core enviroment useing make_core_environment.sh script from ts3 about crashes and hangs and other stuff pleases
    http://filesmelt.com/dl/core_environment.tar.gz

    Linux kernal x86_64 2.6.32-71.e16 installed

    ts3 installed and configurd to use my cloud Mysql server from godday

    i start the server and i get this error critical|databasequery| | unable to load database plugin library "libts3db_mysql.so", halting!

    server config files are as fallows
    [ts3server.ini]
    machine_id=
    default_voice_port=9987
    voice_ip=0.0.0.0
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0
    query_port=10011
    query_ip=0.0.0.0
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_mysql
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    dbconnections=10
    dblogkeepdays=90
    logpath=logs
    logquerycommands=0
    dbclientkeepdays=30

    [ts3db_mysql.ini]
    [config]
    host=192.168.1.1
    port=3306 not going to give you mysql ip or login info
    username=*
    password=*
    database=*
    socket=

    i am running the server useing this command
    ./ts3server_linux_amd64 inifile=ts3server.ini

    so i do a ldd on libts3db_mysql.so and it says this
    libmysqlclient.so.15 => not found

    now this is a fresh install useing the Centos 6 minimal install iso and then running they command yum update

    i have tryed to get the libmysqlclient.so.15.0.0 file into the install dir of ts3 with no avail to it working still getting the same error oh and my database is working fine in windows use cloud mysql

    is there a libts3db_mysql.so compiled for libmysqlclient.so.16 shared library as that is all ready installed and working other than that nothing else is broken and i can run the ts3server useing the sqlite and it works fine just when i try to get mysql db is when it craps out

    if there is a libts3db_mysql.so complied for libmysqlclient.so.16 were can i downlod this as this would fix a lot of the problems with ts3 server on a linux host

    as to my knowalge of Centos 6 there is no way to get mysql5.0 install on centos 6 because it come prepackagd with mysql5.1.XX

    any help would be greatful

    help as i can not get a copy of libmysqlclient.so.15 to install and i do not want to download any more linux os's
    Last edited by Saberwolf; October 4th, 2011 at 06:20 AM.

  5. #20
    Join Date
    May 2010
    Posts
    6,310
    Hello

    You have several informations on the top of this thread.

    And
    Quote Originally Posted by Saberwolf
    ./ts3server_linux_amd64 inifile=ts3server.ini
    NEVER use this binary to start your server. Use the startscript or the minimal_runscript.
    Last edited by florian_fr40; January 12th, 2012 at 08:51 AM.

  6. #21
    Join Date
    March 2011
    Location
    Worldwide
    Posts
    6

    Lightbulb Solution for Debian "Squeeze"

    The silver bullet on a Debian machine would be to install the MySQL database client library through the aptitude/apt-get mechanism, in particular since manual library installations, as suggested from a previous poster, are a mess and get quite hard to handle.

    Edit /etc/apt/sources.list and add the Debian "Lenny" repositorys.
    Code:
    deb http://archive.debian.org/debian/ lenny main non-free contrib
    deb-src http://archive.debian.org/debian/ lenny main non-free contrib
    # Volatile:
    deb http://archive.debian.org/debian-volatile lenny/volatile main contrib non-free
    deb-src http://archive.debian.org/debian-volatile lenny/volatile main contrib non-free
    # Backports:
    deb http://archive.debian.org/debian-backports lenny-backports main contrib non-free
    then execute
    Code:
    aptitude update && aptitude install libmysqlclient15off
    and you are ready to go.


    Although this works perfectly well, using deprecated librarys would not be necessary if the TeamSpeak developers would kindly draw into consideration making it able to use an up-to-date client library for MySQL for one of the next releases. Regarding Debian Lenny, relying on the distribution security updates is not longer possible since Lenny is EOL since a few weeks.

  7. #22
    Join Date
    December 2009
    Location
    Hannover, Germany
    Posts
    35
    Quote Originally Posted by TeamSpeak24 View Post
    Regarding Debian Lenny, relying on the distribution security updates is not longer possible since Lenny is EOL since a few weeks.
    Aye, I am not able to download source or deb. Can anyone provide me one please? I use Debian Squeeze amd64.

  8. #23
    Join Date
    June 2008
    Posts
    18,513
    Quote Originally Posted by burnersk View Post
    Aye, I am not able to download source or deb. Can anyone provide me one please? I use Debian Squeeze amd64.
    http://forum.teamspeak.com/showthrea...ot-Squeeze-Way

    This thread can help you
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  9. #24
    Join Date
    March 2011
    Location
    Worldwide
    Posts
    6
    Quote Originally Posted by burnersk View Post
    Aye, I am not able to download source or deb. Can anyone provide me one please? I use Debian Squeeze amd64.
    I already mentioned a perfect solution for you, you quoted it.
    Even if you would like to download the library directly, you'll find it in the Debian archives.

  10. #25
    Join Date
    July 2010
    Location
    Chicago
    Posts
    154
    Killswitch's download link is broken, so I uploaded libmysqlclient.so.15 to MediaFire where it will never die:

    http://www.mediafire.com/download/ke...qlclient.so.15

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 15
    Last Post: June 1st, 2013, 01:43 AM
  2. Replies: 2
    Last Post: August 15th, 2011, 01:23 PM
  3. libmysqlclient.so.15 vs libmysqlclient.so.16
    By slavig in forum Linux / FreeBSD
    Replies: 0
    Last Post: February 26th, 2011, 12:03 PM
  4. libmysqlclient.so.15
    By BenzinNZ in forum Linux / FreeBSD
    Replies: 2
    Last Post: October 12th, 2010, 03:42 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •