Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19
  1. #16
    Join Date
    May 2011

    qt trouble version mismatch

    --- 2011-05-19 13:43:56.000000000 +0200
    +++ 2011-05-19 13:44:41.000000000 +0200
    @@ -12,2 +12,3 @@
    + ldd ts3client_linux_amd64
    ./ts3client_linux_amd64 [email protected]

    /usr/opt/TeamSpeak3$ ./ => (0x00007fff6557b000) => ./ (0x00007ff6bfc04000) => ./ (0x00007ff6beff9000) => ./ (0x00007ff6bed0a000) => /lib/ (0x00007ff6beae0000) => /lib/ (0x00007ff6be8dc000) => /lib/ (0x00007ff6be6bf000) => /usr/lib/ (0x00007ff6be3b5000) => /lib/ (0x00007ff6be133000) => /lib/ (0x00007ff6bdf1c000) => /lib/ (0x00007ff6bdb99000) => /usr/lib/ (0x00007ff6bd982000) => /usr/lib/ (0x00007ff6bd77d000) => /lib/ (0x00007ff6bd48c000) => /lib/ (0x00007ff6bd265000) => /usr/lib/ (0x00007ff6bcfcb000) => /usr/lib/ (0x00007ff6bcd79000) => /usr/lib/ (0x00007ff6bcb71000) => /usr/lib/ (0x00007ff6bc955000) => /usr/lib/ (0x00007ff6bc74b000) => /usr/lib/ (0x00007ff6bc543000) => /usr/lib/ (0x00007ff6bc33c000) => /usr/lib/ (0x00007ff6bc132000) => /usr/lib/ (0x00007ff6bbf30000) => /usr/lib/ (0x00007ff6bbcf9000) => /usr/lib/ (0x00007ff6bbae6000) => /usr/lib/ (0x00007ff6bb7a4000)
    /lib64/ (0x00007ff6c007d000) => /lib/ (0x00007ff6bb568000) => /lib/ (0x00007ff6bb364000) => /usr/lib/ (0x00007ff6bb13b000) => /usr/lib/ (0x00007ff6baf1f000) => /usr/lib/ (0x00007ff6bad1c000) => /usr/lib/ (0x00007ff6bab16000)

    Cannot mix incompatible Qt library (version 0x40703) with this library (version 0x40702)
    ./ line 15: 2429 Aborted ./ts3client_linux_amd64 [email protected]

    $ apt-show-versions -a libqtcore4
    libqtcore4 4:4.7.3-1 install ok installed
    libqtcore4 4:4.7.3-1 sid
    libqtcore4/sid uptodate 4:4.7.3-1

    i am not sure how to resolve this problem ... maybe you could provide fully static linked version. I hope you can provide some instructions as debian sid might not be on the supported os list i guess ill use a virtualbox for now but i like to have this issue fixed As it might be an upcoming problem with other distributions I hope it is interesting enough to build ts against the new libs

    When I do not preload your libs the gui will start up but the sound does no work at all. I wonder if it has always been like that because you upgraded to 702 in the latest patch and I have never had trouble before using ts3. And SID was certainly ahead from time to time concerning the libs. So maybe your build process changed that there are more dynamic dependence than before or some libs are dropped from the tar file. But that is wild guessing As i do not have the time to look at it closely.


    Attachment 4923

    log updated - forgot to use -f flag
    Attached Files Attached Files
    Last edited by obiwahn; May 19th, 2011 at 01:51 PM.

  2. #17
    Join Date
    May 2011
    Forcing cleanlooks works here as well!
    Last edited by obiwahn; May 19th, 2011 at 02:02 PM.

  3. #18
    Join Date
    January 2010
    With RC2 the problem is still present. So I am currently still starting the binay directly instead of using the startscript.

    Is there any progress / hope for this being fixed for the final release?


  4. #19
    Join Date
    June 2004

    Long dead thread?

    I ended up with the following lock-up:

    1) Running via shell not possible, library version mismatch.
    2) cleanlooks solution not possible, as I had to uninstall qtconfig application due to hundreds of conflicts in aptitude and just now tried to re-install but solutions are like 250+ packages to remove (half of KDE )
    3) running binary directly ends with no sound output (via configuration->play test sound, even if PulseAudio mixer shows new TS3 output stream when activated in TS client.

    Any chance that:
    1) This bug will continue to be solved or
    2) statically linked library binary version will be made available?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Linux Problems...
    By JackBauer in forum Linux / FreeBSD
    Replies: 6
    Last Post: February 9th, 2010, 07:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts