Forum

Results 1 to 11 of 11
  1. #1
    Join Date
    April 2011
    Location
    United Kingdom
    Posts
    43

    MESSAGE: Not all permissions could be applied

    Hi Guys,

    Since the update I am having trouble making changes to server groups.

    I want to assign "Client can subscribe channels". I change the "Group will be set as.." from unknown to guset. I assign the permission. I click apply and it offers to keep or remove existing permissions. If I click either keep or remove and it returns the message: Not all permissions could be applied and it seems to reset to default.

    What am I doing wrong?

  2. #2
    Join Date
    December 2009
    Location
    PA, U.S.
    Posts
    35
    I was able to get past this by generating a Server query admin token (Privilege key). I used the key and retried to save the settings and it worked. Go to "ServerQuery Login" to create a query user and password, then go to "ServerQuery" and enter the following:

    Code:
    login serveradmin pass
    use port=yourport
    privilegekeyadd tokentype=0 tokenid1=2 tokenid2=0
    Note that you must have the serveradmin password to do this (superuser; i.e. you host this yourself).
    Last edited by JakkFrosted; May 15th, 2011 at 09:25 AM. Reason: learned some stuff

  3. #3
    Join Date
    May 2011
    Posts
    4

    hmmm

    Hey JakkFrosted, could you tell me how to do, im new to ts, i mean a deaph guide.

  4. #4
    Join Date
    April 2011
    Location
    United Kingdom
    Posts
    43
    Ahh ok. Thanks for the reply. I managed to just enable advanced permissions and do it the original way.

  5. #5
    Join Date
    December 2009
    Location
    PA, U.S.
    Posts
    35
    aww, I just found that option in settings, of all places, you'd think there would be a button in permissions for this. Lame. Well now we have 2 ways of doing it.

  6. #6
    Join Date
    May 2011
    Posts
    4
    So how to do it?

  7. #7
    Join Date
    May 2011
    Posts
    4
    Where to find my port?

  8. #8
    Join Date
    December 2009
    Location
    PA, U.S.
    Posts
    35
    Just do like Sgt said, go to settings > options, and check advanced permissions system.

  9. #9
    Join Date
    June 2008
    Posts
    18,396
    With Client RC1 or RC2 it is not possbile to add all permissions on Server beta30*, because some permissions are missing there.
    Please update to our RC1 server (we plan to release it today or tomorrow).

    *This is for default settings in your server groups!
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  10. #10
    Join Date
    May 2011
    Posts
    4
    Cant find it.

  11. #11
    Join Date
    June 2008
    Posts
    18,396
    The port is the normal voice port. 9987 as an example
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Private text message permissions
    By Bandus in forum Permission System
    Replies: 1
    Last Post: August 8th, 2014, 03:43 PM
  2. Not all permissions could be applied
    By roun512 in forum General Questions
    Replies: 5
    Last Post: September 7th, 2012, 11:57 AM
  3. Not all permissions could be applied
    By Creativeee in forum General Questions
    Replies: 8
    Last Post: July 21st, 2011, 02:24 AM
  4. [Solved] Text message permissions
    By Air SeaTac in forum Permission System
    Replies: 10
    Last Post: June 9th, 2010, 02:49 PM
  5. Style not re-applied on new invocation
    By Coredump in forum Linux
    Replies: 0
    Last Post: June 4th, 2010, 11:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •