So I've been struggling with the licensekey.dat not working.

I received the e-mail in Google Apps. I tried inserting it into the server running on CentOS 5.6, x86_64.

It starts fine, but ignores the license key. So I googled and found some people saying to try opening port 2008 for TCP, so I've done that.

I also tried the decoder software meant to enable you to get the license key set up correctly... no go.

I think Google Apps borked it beyond repair.

What do I do?

Also, logs:


2011-05-17 05:51:00.871049|INFO |ServerLibPriv | | Server Version: 3.0.0-beta30 [Build: 12998], Linux
2011-05-17 05:51:00.871264|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
2011-05-17 05:51:00.871300|INFO |DatabaseQuery | | dbPlugin version: 3.7.3
2011-05-17 05:51:00.871528|INFO |DatabaseQuery | | checking database integrity (may take a while)
2011-05-17 05:51:00.903397|INFO |SQL | | pruning old database log entries where timestamp is older than 90 days
2011-05-17 05:51:00.918342|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
2011-05-17 05:51:00.944063|INFO |FileManager | | listening on 0.0.0.0:30033
2011-05-17 05:51:01.114874|INFO |VirtualServer | 1| listening on 0.0.0.0:9987
2011-05-17 05:51:01.115297|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
2011-05-17 05:51:01.115545|INFO |Query | | listening on 0.0.0.0:10011

It says it can't find it... but I dunno why since it's in the root of the TS3 folder. O_o;

Note: If I need to get a new key, how would I go about this if all else fails?