Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 4 123 ... LastLast
Results 1 to 15 of 60
  1. #1
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192

    TeamSpeak 3 Server 3.0.0-rc1 available

    Greetings,

    we just released a new server version, called 3.0.0-rc1. Since this is no pre-release version, everybody is encouraged to update to it, and those that fail to do so within one week will see "server version is outdated" warnings when connecting to the server via TS3 Client. Since the last release that we recommended for a production environment was back in November, there are quite a few changes. Especially noteworthy are:
    - TSDNS is now added to to the package. We recommend hosters to take a look at this, as addresses like "myclan.hoster.com" are much easier to remember than "hoster.com:46233"
    - The server now uses multiple database connections to decrease waiting times and increase speed
    - A bug fix for a bug that would cause a CRITICAL log message and the server to terminate...it could be triggered remotely

    Code:
    === Server Release 3.0.0-rc1 23 May 2011
    ! mysql users, please alter your table channel_properties and 
      extend the "value varchar(255)" field to varchar(8192)
    ! mysql users, please alter your table bans and 
      extend the "ban_name varchar(255)" field to varchar(2048)
    ! server uses now 10 database connections (sqlite and mysql)
    ! added new parameter "dbconnections" for defining max database
      connections to use (1-100) default is 10
    ! i_group_auto_update_type values changed  
    * channel permissions got their own needed/power permissions instead 
      of using the group labeled ones
    * renamed i_client_modify_power > i_client_permission_modify_power
              i_client_needed_modify_power > i_client_needed_permission_modify_power
              i_client_max_clones > i_client_max_clones_uid
    + added new parameter "disable_db_logging" which turns off logging
      to database (logview commands wont work anymore)
    + added the TSDNS server to the server installer. Read the documentation in
      the "tsdns" subfolder for details
    + added permissions i_channel_delete_power, i_channel_needed_delete_power
            i_channel_permission_modify_power, i_channel_needed_permission_modify_power
    + added permission i_group_auto_update_max_value
    + added permissions i_client_needed_whisper_power and i_client_whisper_power
      that determine who can whisper to whom
    + Added total bytes transfered by filetransfer to serverinfo, hostinfo and
      server connectioninfo
    + improved permission add/delete performance
    + channelgroupaddperm, channelgroupdelperm, servergroupaddperm, servergroupdelperm added
      optional parameter "continueonerror"
    + uploading and deleting of icons will be logged if filetransfer log is enabled  
    + added some indexes for speedup lookups regarding servers.server_port and messages.message_flag_read
    + added permission b_virtualserver_change_template
    + serveredit and serverinfo command can be used with use 0 to modify and display
      virtualserver template values (serverinfo display is different from normal output!)
    + added server property VIRTUALSERVER_HOSTBANNER_MODE:
            HostBannerMode_NO_ADJUST=0
            HostBannerMode_ADJUST_IGNORE_ASPECT=1
            HostBannerMode_ADJUST_KEEP_ASPECT=2
    - fixed bogus mysql create script for channel_properties
    - default groups cant be permanent anymore
    - removing double group assignements on server start
    - fixed problem where multi-line client descriptions where stored in database
    - fixed query gave out wrong error messages
    - fixed permreset did not remove icon_id assignments
    - fixed double assigned permissions where deleted completly
    - fixed channelmove / channelcreate not checking b_channel_create_child and i_channel_needed_modify_power
    - fixed sql parameter errors while inserting defaults.sql
    - fixed not removing privilege key on channel deletion
    - fixed snapshotdeploy would fail on virtualserver_max_slots / virtualserver_limit reached
    - fixed not checking correct permissions for CHANNEL_FLAG_MAXFAMILYCLIENTS_UNLIMITED,
      CHANNEL_FLAG_MAXFAMILYCLIENTS_INHERITED
    - fixed not checking notifyregister / notifyunregister permissions
    - fixed server critical while using notifyregister=server and multiple queries dropping at the same time
    - fixed set channelgroup did not include channel name info in server log
    - fixed create subchannel did not include parent channel info in server log
    - fixed issue mac osx server uses 100% cpu
    - Fixed a bug that could be triggered remotely and would cause the server to
      shut down with a critical message in the log file.

  2. #2
    Join Date
    December 2009
    Location
    Germany, Cologne
    Posts
    1,364
    Works fine for me! Nice to see that we're slowly goes to Final.

  3. #3
    Join Date
    December 2009
    Location
    Taiwan
    Posts
    313
    So I guess this is still not fixed / being noted?

    http://forum.teamspeak.com/showthrea...self.?p=284066

  4. #4
    Join Date
    June 2008
    Posts
    18,513
    "We don't know, that this is supported" this has been said there. Wait for another reply. thank you
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    January 2010
    Location
    Secret Base in Arctic Region
    Posts
    1,671
    Nice to see finally a new server update.
    One question:
    + added new parameter "disable_db_logging" which turns off logging
    to database (logview commands wont work anymore)
    If set, will TS still write to the log files (logs-folder)?

    Thanks.

  6. #6
    Join Date
    June 2002
    Location
    Krün / Germany
    Posts
    1,638
    ts writes always to the log folder.

    Quote Originally Posted by Alcazar View Post
    Nice to see finally a new server update.
    One question:
    If set, will TS still write to the log files (logs-folder)?

    Thanks.

  7. #7
    Join Date
    September 2010
    Location
    England
    Posts
    12
    Nice to see things are progressing well. Working great on CentOS 64bit dedicated server, noticed a decrease in memory and CPU usage with this version. Also fixed the DB problems I was having on other windows dedicated server.

  8. #8
    Join Date
    December 2009
    Location
    germany
    Posts
    56
    ubuntu 64bit und linux 32bit server works both fine...

  9. #9
    Join Date
    May 2011
    Posts
    2
    I can not connect to this server version.

    Maybe you changet the default port ? I tested 9987 and i cant connect.

    every time i got connection to the server failt. Its the rc1 server and a fresh install no update from the old version clint is the rc1 too.

    The older beta version runs without probs after reinstall.


    EDIT:

    I found the problem i can not use my old npo lizenz i get every time "too much slots hostet" with that npo how i can fix that problem ? no other server running with that npo and with a downgrade to the beta version works fine .
    Last edited by neo300; May 23rd, 2011 at 02:23 PM.

  10. #10
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,360
    I updated my TS3 server to rc1 20 minutes ago and everything is working without problems (Debian 5 / 64 bit).

  11. #11
    Join Date
    July 2002
    Location
    Germany
    Posts
    2,192
    Quote Originally Posted by neo300 View Post
    I found the problem i can not use my old npo lizenz i get every time "too much slots hostet" with that npo how i can fix that problem ?
    Sounds very much like your "old server version" is still running when you updated. We did not change anything (that I know of) in the licensing code...

  12. #12
    Join Date
    May 2011
    Posts
    2
    No i have stop the server than i deleting the old server folder. Install the new one past the old lizens on the new folder and starting the server. I can not login with the lizenz so than i del the lizenz restart the server and its work. maybe i must wait a time for using the lizenz again ?

  13. #13
    Join Date
    February 2006
    Location
    Texas, USA
    Posts
    4,143
    Wait about 2-3 hours and then place your license back in the TS3 server folder.

  14. #14
    Join Date
    July 2007
    Location
    Germany
    Posts
    68
    Runs perfectly on Debian Squeeze 64bit, thanks!

  15. #15
    Join Date
    October 2005
    Location
    The Netherlands
    Posts
    5
    Today i updated towards the new version only did get a problem with it, the server won't start anymore (running on debian lenny)

    So i manually try to start it

    Code:
    debian:/opt/ts3# /etc/init.d/teamspeak start dbconnections=1
    The output i get is:

    Code:
    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file
    debian:/opt/ts3# 2011-05-23 15:15:45.692210|CRITICAL|DatabaseQuery |   | getDBCo
    nnection failed getting db connection
    If i check the logfiles i see the following
    Code:
    2011-05-23 15:15:45.652494|INFO    |ServerLibPriv |   | Server Version: 3.0.0-be
    ta30 [Build: 12998], Linux
    2011-05-23 15:15:45.652671|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite
    3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2011-05-23 15:15:45.652704|INFO    |DatabaseQuery |   | dbPlugin version: 3.7.3
    2011-05-23 15:15:45.652902|INFO    |DatabaseQuery |   | checking database integr
    ity (may take a while)
    2011-05-23 15:15:45.692210|CRITICAL|DatabaseQuery |   | getDBConnection failed g
    etting db connection
    The reason for trying the dbconnections=1 was worth a try, since default is 10 and also gives the same error. (release notes reading ftw).

    This morning on the beta release it worked perfectly, only i deleted the file already so can't downgrade for the time being.

    EDIT: Google is your friend, found an link towards the older release. Just downloaded them and overwrite the old version.
    server is now rebooting

    EDIT2: Downgrading ain't working either, (beta 3.0), errors stay the same

    EDIT3: Fixed the problem, the new files from the rc1 where not overwriting the old server files for some reason. After manual deleting the files and then copying the new files fixed it.
    Last edited by kahless; May 23rd, 2011 at 06:25 PM. Reason: fixed

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: March 17th, 2015, 08:20 PM
  2. Replies: 17
    Last Post: February 13th, 2015, 09:38 AM
  3. Replies: 1
    Last Post: September 17th, 2013, 09:51 PM
  4. Replies: 3
    Last Post: August 2nd, 2010, 08:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •