Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 4 123 ... LastLast
Results 1 to 15 of 59
  1. #1
    Join Date
    December 2009
    Location
    France
    Posts
    11

    Solved TS3ANetwork::Send failed error: 1

    Hi,
    i re-installed my server and now i have this problem with teamspeak. What do it mean? licence problem?

    2010-08-17 16:18:31.041063|DEVELOP | | | TS3ANetwork::Send failed error: 1
    2010-08-17 16:26:37.979100|ERROR |Accounting | | not started, shutting down!

    And my server shuts down by itself!

  2. #2
    Join Date
    June 2008
    Posts
    18,513
    Please make sure, that port "2008 TCP" is opened, when you use a license for your server. Also make sure, that your server can reach the address "accounting.teamspeak.com". This is needed to validate your license.

  3. #3
    Join Date
    December 2009
    Location
    France
    Posts
    11
    i have added this port in my iptable. But it's doesn't work more.
    When i do "traceroute accounting.teamspeak.com", i get "send: Opération non permise".

    So it means my iptable block connections with "accounting.teamspeak.com".
    What can i do to permit connection with accounting.teamspeak.com in my iptable?

  4. #4
    Join Date
    December 2009
    Posts
    237
    Make sure that the port is open for inward and outward traffic

    To test the hostname resolution try pingig the accounting server via
    Code:
    ping accounting.teamspeak.com

  5. #5
    Join Date
    December 2009
    Location
    France
    Posts
    11
    i have this in my iptable :

    Code:
    iptables -t filter -A INPUT -p udp --dport 9987 -j ACCEPT
    iptables -t filter -A OUTPUT -p udp --dport 9987 -j ACCEPT
    iptables -t filter -A INPUT -p tcp --dport 30033 -j ACCEPT
    iptables -t filter -A OUTPUT -p tcp --dport 30033 -j ACCEPT
    iptables -t filter -A INPUT -p tcp --dport 10011 -j ACCEPT
    iptables -t filter -A OUTPUT -p tcp --dport 10011 -j ACCEPT
    iptables -t filter -A INPUT -p tcp --dport 2008 -j ACCEPT
    iptables -t filter -A OUTPUT -p tcp --dport 2008 -j ACCEPT
    and ping is ok

  6. #6
    Join Date
    December 2009
    Posts
    237
    hmm whats the output of netstat -P TCP ?
    Is there any other program trying to use the port?

    Also could you post the whole serverlog please?

  7. #7
    Join Date
    December 2009
    Location
    France
    Posts
    11
    Code:
    Connexions Internet actives (sans serveurs)
    Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat        PID/Program name
    tcp        0      0 myHostName.com:2244       ARennes-359-1-67-:60665 ESTABLISHED 8509/sshd: myHostName
    tcp        0      0 myHostName.com:2244       ARennes-359-1-67-:60501 ESTABLISHED 7413/0
    udp        0      0 myHostName:45380      hardy.teamspeak.4p:2010 ESTABLISHED 8046/ts3server_linu
    Sockets du domaine UNIX actives(sans serveurs)
    Proto RefCnt Flags       Type       State         I-Node   PID/Program name    Chemin
    unix  2      [ ]         DGRAM                    834      1538/udevd          @/org/kernel/udev/udevd
    unix  7      [ ]         DGRAM                    8563     3274/rsyslogd       /dev/log
    unix  3      [ ]         STREAM     CONNECTE      35200    8509/sshd: myHostName
    unix  3      [ ]         STREAM     CONNECTE      35199    8512/1
    unix  2      [ ]         DGRAM                    35198    8509/sshd: myHostName
    unix  3      [ ]         STREAM     CONNECTE      33384    3402/mysqld         /var/run/mysqld/mysqld.sock
    unix  3      [ ]         STREAM     CONNECTE      33383    8046/ts3server_linu
    unix  2      [ ]         DGRAM                    29803    7413/0
    unix  2      [ ]         DGRAM                    10491    4161/perl
    unix  2      [ ]         DGRAM                    8746     3403/logger
    unix  2      [ ]         DGRAM                    8609     3308/named
    and server log

    Code:
    2010-08-18 10:42:27.385231|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta27 [Build: 12002], Linux
    2010-08-18 10:42:27.386128|INFO    |DatabaseQuery |   | dbPlugin name:    MySQL plugin, (c)TeamSpeak Systems GmbH
    2010-08-18 10:42:27.386155|INFO    |DatabaseQuery |   | dbPlugin version: 1
    2010-08-18 10:42:27.389984|INFO    |SQL           |   | pruning old database log entries where timestamp is older than 90 days
    2010-08-18 10:42:27.572640|INFO    |Accounting    |   | Licensing Information
    2010-08-18 10:42:27.572868|INFO    |Accounting    |   | type              : Non-profit
    2010-08-18 10:42:27.573021|INFO    |Accounting    |   | starting date     : Thu Feb 11 23:00:00 2010
    2010-08-18 10:42:27.573166|INFO    |Accounting    |   | ending date       : Fri Feb 11 23:00:00 2011
    2010-08-18 10:42:27.573310|INFO    |Accounting    |   | max virtualservers: 10
    2010-08-18 10:42:27.573438|INFO    |Accounting    |   | max slots         : 512
    2010-08-18 10:42:27.587492|INFO    |FileManager   |   | listening on 0.0.0.0:30033
    2010-08-18 10:42:27.644476|INFO    |VirtualServer |  1| listening on 0.0.0.0:9987
    2010-08-18 10:42:27.644765|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1,
    2010-08-18 10:42:27.645117|INFO    |Query         |   | listening on 0.0.0.0:10011
    2010-08-18 10:47:27.703784|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 10:47:27.703874|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 10:47:29.004533|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 10:47:29.004609|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 10:47:31.004515|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 10:47:31.004587|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 10:57:27.713081|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 10:57:27.713181|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 10:57:29.013054|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 10:57:29.013145|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 10:57:31.011534|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 10:57:31.011626|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 11:07:27.816582|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 11:07:27.816666|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 11:07:29.015541|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 11:07:29.015632|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 11:07:31.016550|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-18 11:07:31.016642|DEVELOP |              |   | TS3ANetwork::Send failed error: 1

  8. #8
    Join Date
    December 2009
    Posts
    237
    As far as I can see there is already an instance of the server running with the pid 8046

    You should kill that one before starting the server again.

    Also sorry, i kinda mixed up the netstat command a bit.
    Could you post the netstat output for :
    netstat --tcp --all --programs
    so we can see the servers too?

  9. #9
    Join Date
    December 2009
    Location
    France
    Posts
    11
    The netstat:
    Connexions Internet actives (serveurs et établies)
    Proto Recv-Q Send-Q Adresse locale Adresse distante Etat PID/Program name
    tcp 0 0 *:2244 *:* LISTEN 3325/sshd
    tcp 0 0 localhost.localdo:mysql *:* LISTEN 3402/mysqld
    tcp 0 0 *:webmin *:* LISTEN 4161/perl
    tcp 0 0 *:www *:* LISTEN 4013/apache2
    tcp 0 0 *:30033 *:* LISTEN 8046/ts3server_linu
    tcp 0 0 *:ftp *:* LISTEN 3877/proftpd: (acce
    tcp 0 0 myHostName.com:domain *:* LISTEN 3308/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 3308/named
    tcp 0 0 localhost.localdom:smtp *:* LISTEN 3724/exim4
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 3308/named
    tcp 0 0 *:10011 *:* LISTEN 8046/ts3server_linu
    tcp 0 0 myHostName.com:2244 ARennes-359-1-67-:60665 ESTABLISHED 8509/sshd: myHostName
    tcp 0 52 myHostName.com:2244 ARennes-359-1-67-:60501 ESTABLISHED 7413/0
    if i kill it, i loose all the data? include user, and channels?

    some details. The database was created by an 64bit ts installation. And now it's a 32bit ts installation

  10. #10
    Join Date
    December 2009
    Posts
    237
    Why would you lose all your data? The data is written into your database immediately.
    If you still have a ts3server.pid file you can also use the startscipt to stop the server.

    64 to 32 bit does not make any difference for the database.

  11. #11
    Join Date
    December 2009
    Location
    France
    Posts
    11
    so, you just want i restart my ts3 installation with ts3server_startscript?

  12. #12
    Join Date
    February 2006
    Location
    Michigan
    Posts
    21

    TS3ANetwork::Send failed error: 1 Problem

    Code:
    2010-08-19 11:13:15.946637|INFO    |ServerLibPriv |   | Server Version: 3.0.0-beta27 [Build: 12002], Linux
    2010-08-19 11:13:15.947009|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2010-08-19 11:13:15.947047|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.21
    2010-08-19 11:13:15.947350|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2010-08-19 11:13:16.507796|INFO    |SQL           |   | pruning old database log entries where timestamp is older than 90 days
    2010-08-19 11:13:17.946515|INFO    |Accounting    |   | Licensing Information
    2010-08-19 11:13:17.947148|INFO    |Accounting    |   | type              : Non-profit
    2010-08-19 11:13:17.947542|INFO    |Accounting    |   | starting date     : Fri Dec 25 23:00:00 2009
    2010-08-19 11:13:17.948084|INFO    |Accounting    |   | ending date       : Sat Dec 25 23:00:00 2010
    2010-08-19 11:13:17.948435|INFO    |Accounting    |   | max virtualservers: 10
    2010-08-19 11:13:17.948811|INFO    |Accounting    |   | max slots         : 512
    2010-08-19 11:13:17.979166|INFO    |FileManager   |   | listening on 70.40.217.72:30033
    2010-08-19 11:13:18.047584|INFO    |VirtualServer |  1| listening on 70.40.217.72:9987
    2010-08-19 11:13:18.068219|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1, 85.25.120.233, 
    2010-08-19 11:13:18.069297|INFO    |Query         |   | listening on 70.40.217.72:10011
    2010-08-19 11:18:18.130996|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-19 11:18:18.131121|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-19 11:18:20.037992|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-19 11:18:20.038100|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-19 11:18:22.043718|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    2010-08-19 11:18:22.043863|DEVELOP |              |   | TS3ANetwork::Send failed error: 1
    Getting alot of these in my log files am hoping this is the source to my server going offline every couple of days.

    I've spoke to my webhost and they said ports 10011 30033 9987 & 2008 are all open inbound and outbound.
    Last edited by stewie316; August 19th, 2010 at 01:30 PM.

  13. #13
    Join Date
    December 2009
    Location
    France
    Posts
    11
    so, we have the same problem. And nobody know a solution

  14. #14
    Join Date
    February 2006
    Location
    Michigan
    Posts
    21
    I reinstalled my ts3 server because it needed to be done i never did the serverquery rights and i didn't write down the admin password. lol

    After doing that and the serverquery admin stuff it still continued to spam those messages.

    went down to the Webhost thread and did this

    username serveradmin passwordhere
    use sid=1
    serveredit virtualserver_weblist_enabled=0

    no more spam messages thus far. I quess the only question is what port is the webhost using? I noticed regardless my server didn't show up anyway.

  15. #15
    Join Date
    June 2008
    Posts
    18,513
    The port for the weblist is 2010 TCP.
    Good to know, when it happens again.
    Last edited by dante696; November 4th, 2010 at 08:49 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3ANetwork::Send failed error: 1
    By brodach in forum Linux / FreeBSD
    Replies: 1
    Last Post: October 2nd, 2015, 12:10 AM
  2. TS3ANetwork::Send failed error: 1
    By Gallitin in forum Server Support
    Replies: 4
    Last Post: January 31st, 2014, 07:56 PM
  3. TS3ANetwork::Send failed error: 1
    By Barut in forum Linux / FreeBSD
    Replies: 14
    Last Post: October 3rd, 2012, 04:01 PM
  4. TS3ANetwork::Send failed error: 113
    By burnacid in forum Linux / FreeBSD
    Replies: 1
    Last Post: November 8th, 2010, 02:39 PM
  5. TS3ANetwork::Send failed error: 1
    By Teddy in forum Linux / FreeBSD
    Replies: 3
    Last Post: November 4th, 2010, 08:49 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •