Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    June 2011

    Problem configuring / executing TS client on a ubuntu server (console only, no GUI)


    Have searched client/linux subforums here on TS forums with not much success. Google searches directed me to these forums.

    I have an Atom-based embedded PC which I'd like to run a TS3 client on. It have to SSH into it as it has no dedicated mouse/keyboard/screen. My goal is to configure the ts3 client, and connect to server automatically on bootup.


    [email protected]:~/TeamSpeak3-Client-linux_x86$ cat /etc/*-release
    DISTRIB_DESCRIPTION="Ubuntu 10.04.2 LTS"
    my kernel:
    [email protected]:~/TeamSpeak3-Client-linux_x86$ uname -a
    Linux pico 2.6.32-28-generic-pae #55-Ubuntu SMP Mon Jan 10 22:34:08 UTC 2011 i686 GNU/Linux
    my cpu:
    [email protected]:~/TeamSpeak3-Client-linux_x86$ cat /proc/cpuinfo
    processor	: 0
    vendor_id	: GenuineIntel
    cpu family	: 6
    model		: 28
    model name	: Intel(R) Atom(TM) CPU Z510   @ 1.10GHz
    stepping	: 2
    cpu MHz		: 1100.000
    cache size	: 512 KB
    fdiv_bug	: no
    hlt_bug		: no
    f00f_bug	: no
    coma_bug	: no
    fpu		: yes
    fpu_exception	: yes
    cpuid level	: 10
    wp		: yes
    flags		: fpu vme de tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx constant_tsc up arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 xtpr pdcm movbe lahf_lm
    bogomips	: 2194.59
    clflush size	: 64
    cache_alignment	: 64
    address sizes	: 32 bits physical, 32 bits virtual
    power management:
    I'm running server-only version, not a GUI version of linux. When I installed the TeamSpeak3-Client for linux, i get the following error:

    [email protected]:~/TeamSpeak3-Client-linux_x86$ ./ 
    ./ts3client_linux_x86: error while loading shared libraries: cannot open shared object file: No such file or directory
    As you can see I am executing this from the TeamSpeak3-Client-linux_x86 directory, which was one suggestion which I found on this forum. However this does not fix the issue and I couldn't find other posts which seemed related to my problem.

    I've also tried running it as sudo sh with same error.

    It would seem that I am missing a library or package but a previous forum post implied this error goes away if you execute from the same directory.

    Can the ts3client run in command line form only or does it require a window manager? This system is battery powered so I would like to avoid having to install GNOME or other window manager if at all possible to maximize battery life.

    Thanks in advance for any insight on this problem.

  2. #2
    Join Date
    January 2011
    Every time I ran it displays it in GNOME. I am not sure whether it could run w/o a graphical interface though. I imagine that would be difficult to use even if it supports it... ("Push-to-talk"???)

  3. #3
    Join Date
    March 2010
    Runnemede, NJ
    There's no way I know of to run TS3 without a GUI, but it is possible to use tightvncserver to create a VNC-accessible only X display. I assume you also have nothing related to xorg installed, so I would go and install xserver-xorg, xserver-xorg-video-vesa, xserver-xorg-input-mouse, and xserver-xorg-input-kbd. That's all you would need for the X server to run properly.

    Just a note... the packages I listed are debian packages, but I would imagine they're not too different in ubuntu.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Problem configuring the temporary channel delete delay
    By Mastaz in forum Permission System
    Replies: 3
    Last Post: October 28th, 2015, 07:57 PM
  2. Problem with Server Query console
    By Eole92 in forum Windows
    Replies: 8
    Last Post: December 31st, 2012, 05:03 PM
  3. Install client on console server
    By Hakaori in forum Linux
    Replies: 13
    Last Post: November 3rd, 2010, 12:23 AM
  4. Replies: 5
    Last Post: March 12th, 2010, 04:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts