Forum

Results 1 to 5 of 5

Thread: MySQL

  1. #1
    Join Date
    July 2011
    Posts
    13

    MySQL

    I don't know if this is going to be a cry for help or an observation. I would much rather use MySQL for TeamSpeak 3 for starters. I updated my Centos from 5.6 to 6.0 and I am sticking with 6. My problem is the "unable to load database plugin library "libts3db_mysql.so", halting!" error.

    MySQL version is 5.1.52
    Centos 6.0 with all updates

    I've tried starting server with ./ts3server_minimal_runscript.sh start inifile=ts3server.ini with the same results.

    I've also tried running a older version of MySQL hosted on another computer, but can't get past the plugin error.

    Is this because of the newer version of MySQL?

  2. #2
    Join Date
    December 2009
    Location
    Germany
    Posts
    288
    please check the library-depencies with "ldd libts3db_mysql.so". I think you need the client-libs of mysql5.1, which have compatibillity for 5.0 (client-side).

  3. #3
    Join Date
    July 2011
    Posts
    13
    The output of ldd libts3db_mysql.so is:

    linux-gate.so.1 => (0x00fbf000)
    libmysqlclient.so.15 => not found
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x0036a000)
    libm.so.6 => /lib/libm.so.6 (0x00c63000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00847000)
    libc.so.6 => /lib/libc.so.6 (0x00110000)
    /lib/ld-linux.so.2 (0x008b7000)
    I have libmysqlclient.so.15 installed in the ts3 root folder and tried

    ln -s libmysqlclient.so.15.0.0 libmysqlclient.so.15
    and
    ldconfig /usr/lib/mysql

    with the same results, unable to load database plugin library "libts3db_mysql.so", halting!"

  4. #4
    Join Date
    May 2010
    Posts
    6,310
    Hello

    Try with the method from this post : http://forum.teamspeak.com/showthrea...202#post236202

    Search function

  5. #5
    Join Date
    July 2011
    Posts
    13
    Got it working. Thank you, florian_fr40 for your help, I have been searching google and these threads for the solution. My problem was Centos 6.0 upgraded MySQL to v. 5.1.52 and the file libmysqlclient.so.15 is not included. In the above thread link:

    If you can't use the original CentOS packages, you may be able to solve the problem by downloading the CentOS mysql package from one of the mirrors (mysql-5.0.77-4.el5_5.4.i386.rpm) and then extract the RPM file in some temporary location and copy the working libmysqlclient library file.
    Code:

    $ mkdir /tmp/ts3
    $ cd /tmp/ts3
    $ wget <URL-to-one-of the-mysql-5.0.77-packages>
    $ rpm2cpio mysql-5.0.77-4.el5_5.4.i386.rpm | cpio -idv

    After that last command, you'll find the library file in ./usr/lib/mysql. Copy both the file "libmysqlclient.so.15" and put it in your TS3 folder and see if things improve. Running "ldd" again will seem to fail unless you
    Code:

    export LD_LIBRARY_PATH=/path/to/my/ts3server/folder

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock'
    By Svenskunganka in forum Server Support
    Replies: 2
    Last Post: September 12th, 2013, 10:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •