Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    January 2013
    Posts
    8

    ToDo List complainlist "invalid ClientID"

    Hello, i have a problem to display complaints, it happens with boths query and GUI

    In query i tried this

    Code:
    login Magissia <my password>
    use port=9987
    whoami
    complainlist
    result
    Code:
    error id=0 msg=ok  (22 ms)
    error id=0 msg=ok  (86 ms)
    virtualserver_status=online virtualserver_id=1 virtualserver_unique_identifier=xxxxxxxxDiwROTovQ9Eq9wFAaBQ= virtualserver_port=9987 client_id=29 client_channel_id=1 client_nickname=[Server]\sMagissia\sfrom\s89.xxx.xxx.xxx:54964 client_database_id=390 client_login_name=Magissia client_unique_identifier=xxxxxxxxxxJ3UPZ9pDK+187QBU4= client_origin_server_id=1
    error id=0 msg=ok  (19 ms)
    error id=512 msg=invalid\sclientID(51 ms)
    Total: 178 ms
    When opening the complain list in GUI, i get "invalid clientID" shown on main channel, i tried from 3.0.9.2 and 3.0.8.1 clients. Server is running on Windows, version 3.0.6.1

    - Note :
    All users with b_client_complain_list right have this problem. No errors when adding new complains.

  2. #2
    Join Date
    September 2012
    Posts
    6,080
    Client A complained about Client B and either Client A or Client B was removed from the server database.
    To fix it just edit the server and set the complain expire time to a low value, to force the server to auto remove the complaints ( edit virtual server -> misc -> complain remove time). Set it to 1 second for example, apply the change and restore the original value. It will cause the server to forget all the complains, making the list available again.
    Last edited by Chris; March 1st, 2013 at 10:57 AM.

  3. #3
    Join Date
    January 2013
    Posts
    8
    Not optimal but works.

    Thanks you.

  4. #4
    Join Date
    September 2012
    Posts
    6,080
    Never said it was optimal, but it is a great quick 100% workaround to make it working again while we fix the actual problem beneath.

  5. #5
    Join Date
    May 2007
    Location
    Eastern NC
    Posts
    1,799
    So the fixed needed for this may also work with offline messages?

  6. #6
    Join Date
    June 2002
    Location
    Krün / Germany
    Posts
    1,638
    release server for monday will include a temp fix for that. (ComplainList)

    *current build was updated to reflect this changes

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: July 8th, 2015, 11:39 AM
  2. Replies: 3
    Last Post: October 1st, 2013, 04:23 PM
  3. ServerGroup Dialoug says "invalid clientID"
    By Sebi94 in forum Server Support
    Replies: 3
    Last Post: October 25th, 2012, 04:38 PM
  4. [Fixed] Disconnect Problem "invalid clientID: 0"
    By Chaos234 in forum Bug Reports [EN/DE]
    Replies: 62
    Last Post: September 22nd, 2010, 08:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •