Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 3 123 LastLast
Results 1 to 15 of 38
  1. #1
    Join Date
    June 2011
    Posts
    2

    [3.0.1] Client: Fail to connect message "Keep-Alive"

    Hello,

    I am a new teamspeak user and I have a connection problem. I was on a server when without warning TS3 begun having connection issue. Now every time I want to get into a server, I get the same message and get kick out over and over. Even when I just open TS without connecting to any server it says the following:

    <19:11:55> Trying to resolve hostname Keep-Alive
    <19:11:58> Failed to resolve hostname ' Keep-Alive'

    And this is what it say on the client log:

    6/17/2011 7:11:55 PM-ClientUI-Info-ts3server:Keep-Alive/?port=9987&nickname=onnection&password=%20Keep%2dA live
    6/17/2011 7:11:58 PM Info No TSDNS found at " keep-alive"

    Thank you for the help!

  2. #2
    Join Date
    July 2010
    Location
    USA
    Posts
    71
    Would be nice to know what causes this... I have 3 clan members who have the same issue and get booted every minute or two and sometimes less.

  3. #3
    Join Date
    June 2011
    Posts
    2
    I have the same problem which annoys me as alot of my friends are on a ts3 server....I just recently installed it and when I tried to log in im on for 30 sec and I get the same issues as described and half the time 30sec is a dream as it only last 10 or so......Its rather annoying....And its funny cause I dont have this issue what so ever with ventrillo....hmmm wonder why.

  4. #4
    Join Date
    June 2008
    Posts
    18,508
    Keep-Alive is no address. please add the full hostname into your bookmark.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    June 2011
    Posts
    2
    ummm what else is there to add all I have is a numeric address and a port number and I put that in and it logs me in then I get disconnected as there was nothing else I could add in there Im curious as to what you mean.....

  6. #6
    Join Date
    June 2008
    Posts
    18,508
    Quote Originally Posted by Chivalry1978 View Post
    ummm what else is there to add all I have is a numeric address and a port number and I put that in and it logs me in then I get disconnected as there was nothing else I could add in there Im curious as to what you mean.....
    You gave no inforamtions about any address or server version.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #7
    Join Date
    June 2011
    Posts
    2
    I know that "keep-alive" is not a server. I have never tried to connect to this server. I was in a server when it booted me out and this message started to pop out. I did try different server (after ht eproblem) and it always kicked me out saying the same thing. The only server it didn't kick me out from was your test server. And this is all the info I can give you because I dont have any more.

  8. #8
    Join Date
    June 2011
    Posts
    1
    Im having the exact same issues. Here is what I know: I used to be able to connect just fine. I have noticed for a little while now a failed to connect message regarding keep-alive, but before this i could still connect okay. Nothing has changed, and no software has been installed on my local computer or the server. Other people are able to connect to our server just fine. This did not start until I allowed TS3 to update to the latest version, but it was working fine just after i updated it too.
    As for a hostname, our server doesnt have one, only a numerical ip address.
    occasionally an entirely new ts3 window will come up and be trying to connect to hostname keep-alive.

    Appears to me as if the problem is that somewhere, somehow TS3 keeps trying to connect to another server called keep-alive but since such a server doesnt exist it is dropping me from the current one.

  9. #9
    Join Date
    May 2010
    Posts
    6,310
    It seems this problem can appears when the DirectX Overlay is activated (solution for some users)

    Is it your case ?
    Last edited by florian_fr40; June 24th, 2011 at 08:56 AM.

  10. #10
    Join Date
    June 2011
    Posts
    1

    Trying to resolve hostname "Keep-Alive" Disconnect

    I'll be sitting in my TS when all of a sudden this appears and kicks me out of the server:

    <16:25:26> Trying to resolve hostname keep-alive
    <16:25:29> Failed to resolve hostname ' keep-alive'

    This started happening when I upgraded to windows 7 64bit.

    Can anyone help me?

    Edit by mod
    Threads merged
    Last edited by BlueMoney; June 24th, 2011 at 01:58 AM.

  11. #11
    Join Date
    June 2008
    Posts
    18,508
    Edit
    How do you connect? What IP or address do you enter? Do you click onto a link, to connect to a server?
    I've got toled, that it happens, when the overlay is enabled. I can't reproduce this.

    The overlay got updated, but you have to wait for an Rc3-pre or final client.
    Last edited by dante696; November 24th, 2011 at 09:50 AM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  12. #12
    Join Date
    June 2008
    Posts
    18,508
    Update
    We need a complete log file, when it happend.
    You can find the log under your configuration folder.

    C:\Program Files\TeamSpeak 3 Client\config\logs or
    Press these keys on your keyboard "Win + R" > now type %appdata% and press ok > Go into folder TS3Client/Logs
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  13. #13
    Join Date
    July 2011
    Posts
    1
    This is what he is asking for and since I am having the same problem I will post my log file.

    2011-07-08 12:35:04.|INFO | | | Logging started, clientlib version: 3.0.0-rc2 [Build: 14642]
    2011-07-08 12:35:04.281250|DEBUG |Direct Sound | | setting timer resolution to 1ms
    2011-07-08 12:35:04.375000|INFO |SoundBckndIntf| | Load Library failed with errorno 126
    2011-07-08 12:35:04.468750|INFO | | | Registering plugin command id: {e7ac8483-74bd-461a-b188-061c36328365} appscanner_plugin
    2011-07-08 12:35:04.625000|INFO |Query | | listening on 127.0.0.1:25639
    2011-07-08 12:35:04.625000|INFO | | | Registering plugin command id: {ef9d9d2e-5c6a-45c6-8e1d-3133faac4756} clientquery_plugin
    2011-07-08 12:35:04.828125|INFO | | | Registering plugin command id: {e2be3d12-5e31-4a62-879c-540b1dfb866d} dx_overlay_plugin
    2011-07-08 12:35:11.531250|INFO |GenericPlayback| | STOPWATCH1 closePlaybackDevice: 10 ms -1
    2011-07-08 12:35:13.765625|INFO |Input | | Input device name: Mouse
    2011-07-08 12:35:13.765625|INFO |Input | | Input device name: Keyboard
    2011-07-08 12:35:15.125000|INFO |ClientUI | | TeamSpeak 3 client version: 3.0.0-rc2 [Build: 14642]
    2011-07-08 12:35:15.125000|INFO |ClientUI | | Qt version: 4.7.2
    2011-07-08 12:35:15.125000|INFO |ClientUI | | Using configuration location: C:/Documents and Settings/(my name here)/Application Data/TS3Client/ts3clientui_qt.conf
    2011-07-08 12:35:15.468750|INFO |ClientUI | | Last update check was: Thu Jul 7 13:51:34 2011
    2011-07-08 12:35:15.484375|INFO | | | Checking for updates...
    2011-07-08 12:35:16.375000|INFO | | | Update check, my version: 14642, latest version: 14642
    2011-07-08 12:35:17.750000|INFO |ClientUI | | ts3server: keep-alive/?port=9987&nickname=onnection&password=%20keep%2da live
    2011-07-08 12:35:20.093750|INFO | | | No TSDNS found at " keep-alive"
    2011-07-08 12:40:37.406250|INFO |GenericPlayback| | STOPWATCH1 closePlaybackDevice: 0 ms -1
    2011-07-08 12:40:37.484375|INFO |GenericPlayback| | STOPWATCH1 internalOpenDevice: 85 ms -1
    2011-07-08 12:40:37.500000|INFO |GenericPlayback| | STOPWATCH1 internalStartDevice: 0 ms -1
    2011-07-08 12:40:37.500000|INFO |GenericPlayback| | STOPWATCH1 openPlaybackDevice: 97 ms -1
    2011-07-08 12:40:37.578125|INFO |GenericPlayback| | LIMSTOPWATCH onEditMixedPlaybackVoiceDataEvent (recorder): 27 ms 10
    2011-07-08 12:40:37.578125|INFO |GenericPlayback| | LIMSTOPWATCH GenericPlayback::fillSoundBuffer 2: 28 ms 10
    2011-07-08 12:40:37.578125|INFO |GenericPlayback| | LIMSTOPWATCH GenericPlayback::fillSoundBuffer 1: 28 ms 10
    2011-07-08 12:40:37.578125|INFO |GenericPlayback| | LIMSTOPWATCH PlaybackManager::fillSoundBuffer 2: 54 ms 10
    2011-07-08 12:40:37.578125|INFO |GenericPlayback| | LIMSTOPWATCH onGetPlaybackData: 61 ms 10
    2011-07-08 12:40:37.578125|WARNING |Direct Sound | | RenderDeviceContext::int_processData m_DS->m_Callbacks.getPlaybackData time 61 msecs
    2011-07-08 12:40:37.578125|WARNING |Direct Sound | | RenderDeviceContext::int_processData Loop proc time: 82 msecs
    2011-07-08 12:40:37.609375|WARNING |Direct Sound | | RenderDeviceContext::int_processData outerLoop proc (3) time: 105 msecs
    2011-07-08 12:40:37.609375|INFO |GenericPlayback| | STOPWATCH1 closeCaptureDevice: 13 ms -1
    2011-07-08 12:40:37.687500|INFO |GenericPlayback| | STOPWATCH1 internalOpenDevice: 82 ms -1
    2011-07-08 12:40:37.734375|INFO |PreProSpeex | 1| Speex version: speex-1.2beta3
    2011-07-08 12:40:37.734375|INFO |GenericPlayback| | STOPWATCH1 internalStartDevice: 1 ms -1
    2011-07-08 12:40:37.734375|INFO |GenericPlayback| | STOPWATCH1 openCaptureDevice: 129 ms -1
    2011-07-08 12:40:37.734375|WARNING |Direct Sound | | RenderDeviceContext::int_processData Loop proc time: 101 msecs
    2011-07-08 12:40:37.765625|WARNING |Direct Sound | | RenderDeviceContext::int_processData outerLoop proc (3) time: 141 msecs
    2011-07-08 12:40:37.937500|INFO | | | No TSDNS found at "gameservers.com"
    2011-07-08 12:40:57.015625|INFO |ClientUI | | ts3server: keep-alive/?port=9987&nickname=onnection&password=%20keep%2da live
    2011-07-08 12:40:57.906250|INFO | | | No TSDNS found at "ts25.gameservers.com"
    2011-07-08 12:40:59.296875|INFO | | | No TSDNS found at " keep-alive"

  14. #14
    Join Date
    July 2011
    Posts
    2

    im trying to connect to a server but keep getting disconected?

    when i connect to the server i am conected for about 3/4 seconds then disconected with a error message saying Failed to resolve hostname ' keep-alive'

    can anyone help me?

  15. #15
    Join Date
    July 2011
    Posts
    2
    im getting the same problem and its rather annoying now.. it worked fine last night iv also changed nothing here is my log also-

    10/07/2011 22:40:37 Info Logging started, clientlib version: 3.0.0-rc2 [Build: 14642]
    10/07/2011 22:40:37 Info Registering plugin command id: {b73a958f-b5dd-46bc-8ac3-eb8f078a77d3} appscanner_plugin
    10/07/2011 22:40:37 Query Info listening on 127.0.0.1:25639
    10/07/2011 22:40:37 Info Registering plugin command id: {9b54336a-ee6c-46f4-93a3-1fce98ed0ec4} clientquery_plugin
    10/07/2011 22:40:37 Info Registering plugin command id: {80871f4c-4411-4b70-9833-922596503edc} dx_overlay_plugin
    10/07/2011 22:40:37 GenericPlayback Info STOPWATCH1 closePlaybackDevice: 0 ms -1
    10/07/2011 22:40:37 Input Info Input device name: Mouse
    10/07/2011 22:40:37 Input Info Input device name: Keyboard
    10/07/2011 22:40:37 ClientUI Info TeamSpeak 3 client version: 3.0.0-rc2 [Build: 14642]
    10/07/2011 22:40:37 ClientUI Info Qt version: 4.7.2
    10/07/2011 22:40:37 ClientUI Info Using configuration location: C:/Users/john/AppData/Roaming/TS3Client/ts3clientui_qt.conf
    10/07/2011 22:40:38 ClientUI Info Last update check was: Sun 10. Jul 01:10:08 2011
    10/07/2011 22:40:38 ClientUI Info ts3server: keep-alive/?port=9987&nickname=onnection&password=%20keep%2da live
    10/07/2011 22:40:41 Info No TSDNS found at " keep-alive"
    10/07/2011 22:40:42 GenericPlayback Info STOPWATCH1 closePlaybackDevice: 0 ms -1
    10/07/2011 22:40:42 GenericPlayback Info STOPWATCH1 internalOpenDevice: 55 ms -1
    10/07/2011 22:40:42 GenericPlayback Info STOPWATCH1 internalStartDevice: 0 ms -1
    10/07/2011 22:40:42 GenericPlayback Info STOPWATCH1 openPlaybackDevice: 55 ms -1
    10/07/2011 22:40:42 GenericPlayback Info STOPWATCH1 closeCaptureDevice: 0 ms -1
    10/07/2011 22:40:42 GenericPlayback Info STOPWATCH1 internalOpenDevice: 16 ms -1
    10/07/2011 22:40:42 PreProSpeex Info Speex version: speex-1.2beta3
    10/07/2011 22:40:42 GenericPlayback Info STOPWATCH1 internalStartDevice: 0 ms -1
    10/07/2011 22:40:42 GenericPlayback Info STOPWATCH1 openCaptureDevice: 17 ms -1
    10/07/2011 22:40:42 EncodeCelt Info CELT bitstream version: 0x80000010
    10/07/2011 22:41:01 ClientUI Info ts3server: keep-alive/?port=9987&nickname=onnection&password=%20keep%2da live
    10/07/2011 22:41:04 Info No TSDNS found at " keep-alive"
    10/07/2011 22:41:19 ClientUI Info ts3server: keep-alive/?port=9987&nickname=onnection&password=%20keep%2da live
    10/07/2011 22:41:22 Info No TSDNS found at " keep-alive"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fail to connect to one server "just" one
    By damme in forum Client Support
    Replies: 5
    Last Post: November 8th, 2012, 04:24 PM
  2. [Resolved] ServerQuery - "Open Connection" and "Banned" message issues
    By Imisnew2 in forum Bug Reports [EN/DE]
    Replies: 8
    Last Post: February 24th, 2012, 09:34 AM
  3. [On Todo] ServerQuery - "Open Connection" and "Banned" message issues
    By Imisnew2 in forum Server Support
    Replies: 3
    Last Post: February 18th, 2012, 05:24 PM
  4. Fail to connect message "Keep-Alive"
    By geta07 in forum Windows
    Replies: 19
    Last Post: August 1st, 2011, 09:22 AM
  5. Replies: 0
    Last Post: December 23rd, 2009, 09:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •