Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 9 of 9

Hybrid View

  1. #1
    Join Date
    June 2011
    Posts
    5

    TS3 -> Error on running server on CentOS

    TS3 it give a error everytime i try to run it
    Code:
    [[email protected] ~]# cd ts
    [[email protected] ts]# ls
    a  teamspeak3-server_linux-x86
    [[email protected] ts]# cd teamspeak3-server_linux-x86/
    [[email protected] teamspeak3-server_linux-x86]# ls
    CHANGELOG            logs                    ts3server_linux_x86
    doc                  query_ip_blacklist.txt  ts3server_minimal_runscript.sh
    files                query_ip_whitelist.txt  ts3server.pid
    libts3db_mysql.so    serverkey.dat           ts3server.sqlitedb
    libts3db_sqlite3.so  serverquerydocs         ts3server_startscript.sh
    LICENSE              sql                     tsdns
    licensekey.dat       ts3server.ini
    [[email protected] teamspeak3-server_linux-x86]# ./ts3server_startscript.sh
    Usage: ./ts3server_startscript.sh {start|stop|restart|status}
    [[email protected] teamspeak3-server_linux-x86]# ./ts3server_startscript.sh start
    ts3server.pid found, but no server running. Possibly your previously started server crashed
    Please view the logfile for details.
    WARNING ! For security reasons we advise: DO NOT RUN THE SERVER AS ROOT
    !!!!!!!!!!!
    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file
    [[email protected] teamspeak3-server_linux-x86]# ./ts3server_startscript.sh start
    ts3server.pid found, but no server running. Possibly your previously started server crashed
    Please view the logfile for details.
    WARNING ! For security reasons we advise: DO NOT RUN THE SERVER AS ROOT
    !!!!!!!!!!!
    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file
    [[email protected] teamspeak3-server_linux-x86]# ts3server.pid found, but no server running. Possibly your previously started server crashed
    -bash: ts3server.pid: command not found
    You have new mail in /var/spool/mail/root
    [[email protected] teamspeak3-server_linux-x86]# Please view the logfile for details.
    -bash: Please: command not found
    [[email protected] teamspeak3-server_linux-x86]# WARNING ! For security reasons we advise: DO NOT RUN THE SERVER AS ROOT
    -bash: WARNING: command not found
    [[email protected] teamspeak3-server_linux-x86]# !!!!!!!!!!!
    -bash: !: event not found
    [[email protected] teamspeak3-server_linux-x86]# Starting the TeamSpeak 3 server
    -bash: Starting: command not found
    [[email protected] teamspeak3-server_linux-x86]# TeamSpeak 3 server started, for details please view the log file
    -bash: TeamSpeak: command not found
    [[email protected] teamspeak3-server_linux-x86]#

  2. #2
    Join Date
    May 2006
    Location
    Europe/Czech Rep.
    Posts
    1,616
    Quote Originally Posted by KevinsL View Post
    TS3 it give a error everytime i try to run it
    Code:
    [[email protected] teamspeak3-server_linux-x86]# ./ts3server_startscript.sh start
    ts3server.pid found, but no server running. Possibly your previously started server crashed
    Please view the logfile for details.
    WARNING ! For security reasons we advise: DO NOT RUN THE SERVER AS ROOT
    !!!!!!!!!!!
    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file
    Okey, the errors you are getting are self-explanatory.
    First one is just about how to use start script. You then used it correctly.
    Your server is at /root/ts/teamspeak3-server_linux-x86/

    Read the errors, they tell you what to fix, just not how, since it can be different there and here. Read the log files, if you don't know....

    Anyway I am installing and using my ts3server in a usual fashion for a linux service(okey aside starting described below):
    1. Create user that will be used by the service(for example ts3), they SHOULD not have root rights !
    Code:
    useradd -m ts3
    2. Move your server files to that user home directory.
    Code:
    mv /root/ts/teamspeak3-server_linux-x86/* /home/ts3/
    3. Fix permissions (it was saved using root, which means root is owner, and others might not be able to write to logs dir etc....)
    Code:
    chown -R ts3:ts3 /home/ts3/
    4. manual test
    Code:
     su -l ts3 -c "cd /home/ts3; ts3server_startscript.sh start"
    5. auto start on boot
    There is two options I will show you the easiest one:
    put the same command as in manual test inside /etc/rc.local before the line starting with exit....

    You might be able to create service scripts using that startscript but it needs some changes.
    Last edited by Tomas; June 28th, 2011 at 08:05 PM. Reason: (20110628) missing -R

  3. #3
    Join Date
    June 2011
    Posts
    5
    Code:
    [[email protected] ts3]#  su -l ts3 -c "cd /home/ts3; ./ts3server_startscript.sh start"
    ts3server.pid found, but no server running. Possibly your previously started server crashed
    Please view the logfile for details.
    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file
    [[email protected] ts3]# 2011-06-27 21:43:26.275874|CRITICAL|SQL           |   | unable to remove old log entries error: database error

  4. #4
    Join Date
    May 2010
    Posts
    6,310
    Hello

    ts3server.pid found, but no server running. Possibly your previously started server crashed
    As you can read in this info message, there already is a ts3server.pid file in the server folder.

    - Stop all teamspeak process (check with "top" or "ps -aux | grep ts3server")
    - Delete de "ts3server.pid" file in the server folder
    - Check up if all files and folder has the same linux owner (according your database error)
    - Start your server with the startscript

  5. #5
    Join Date
    June 2011
    Posts
    5
    still giving error
    Code:
    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file
    [[email protected] ts3]# 2011-06-28 12:03:06.002579|CRITICAL|SQL           |   | unable to remove old log entries error: database error

  6. #6
    Join Date
    May 2010
    Posts
    6,310
    Are you 100% positive that the database file is readable ?
    Please post the result from "ls -al"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: February 15th, 2014, 08:46 PM
  2. CentOS: Server running but unable to connect
    By Glotty in forum Server Support
    Replies: 14
    Last Post: October 13th, 2013, 07:11 PM
  3. [Resolved] Issues connecting to a running server. CentOS
    By Morthawt in forum Linux / FreeBSD
    Replies: 9
    Last Post: July 25th, 2012, 11:53 AM
  4. [Resolved] Error starting server on vps running centos 5
    By Samkitz in forum Linux / FreeBSD
    Replies: 1
    Last Post: July 24th, 2012, 11:51 PM
  5. Problem running TS3 on Centos vps
    By some_user in forum Linux / FreeBSD
    Replies: 22
    Last Post: January 26th, 2010, 04:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •