Forum

Results 1 to 15 of 18

Hybrid View

  1. #1
    Join Date
    January 2010
    Location
    New York
    Posts
    11

    Drag/Drop on Channel Names for File Browser Upload

    Cool release Teamspeak people!

    I don't really understand why this 3.0.0 is now higher than release candidate when we still cannot drag and drop files from our computer onto a channel name (to upload into file browser), when we used to be able to do this feature previously. It is an extremely handy feature. Did you decide to remove this feature completely a while ago?
    Anyhow, it would be nice if this could be brought back, because you can only upload now by opening the file browser with right-click/choose option or middle-click and still have to press the upload arrow button.

    (in the Aug 2, 2010 changelog of 3.0.0 beta23, it says "- We now use a slightly different approach to handle file browser drag and drop. If some users still can't drag and drop into file browser, a warning text will be added to clientlog." Not sure if this is what happened, but I don't even get an error. It just has a kind of denied symbol if I try to drag over it.)

    thanks
    Last edited by Father Goose; July 27th, 2011 at 01:45 AM.

  2. #2
    Join Date
    January 2010
    Location
    New York
    Posts
    11
    any teamspeak employee have an answer about this please?

  3. #3
    Join Date
    June 2008
    Posts
    17,923
    My answer is simple. It works fine here on my Windows client.
    I can drag and drop files or folders onto the channel name and the filetransfer starts or the queue dialog asks me to start.

    It does not work, when my i_ft_file_upload_power is not high enough, to uplaod a file.

    1. Please check the server chat for any error like
    <10:09:49> Transfer "testfile" reports: (insufficient client permissions)
    2. Check your client log under Tools > Client Log
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #4
    Join Date
    January 2010
    Location
    New York
    Posts
    11
    thanks for the answer Dante.

    If I look at i_ft_file_upload_power, the "value" is set to 75 by default for server admins. The "grant" permission also is on 75. If i raise the value to 9000 for example, it still won't let me do drag and drop successfully on a channel name to upload. If I try to also raise the grant permission to 9000, it says "insufficient permission modify power". I'm not sure how to fix that problem, and if fixing that would allow upgrading the grant permission. Not really sure of the difference between "value" and "grant" as well lol.

    Under "Group" > "modify", I tried to change "permission modify power" to higher than 75, and it won't let me again because of "insufficient modify power".
    I must be missing something easy here. (and sorry if this is the wrong place to ask further about this)

  5. #5
    Join Date
    May 2014
    Posts
    4
    Quote Originally Posted by Father Goose View Post
    thanks for the answer Dante.

    If I look at i_ft_file_upload_power, the "value" is set to 75 by default for server admins. The "grant" permission also is on 75. If i raise the value to 9000 for example, it still won't let me do drag and drop successfully on a channel name to upload. If I try to also raise the grant permission to 9000, it says "insufficient permission modify power". I'm not sure how to fix that problem, and if fixing that would allow upgrading the grant permission. Not really sure of the difference between "value" and "grant" as well lol.

    Under "Group" > "modify", I tried to change "permission modify power" to higher than 75, and it won't let me again because of "insufficient modify power".
    I must be missing something easy here. (and sorry if this is the wrong place to ask further about this)
    still does not work in 2014 windows client!
    https://www.youtube.com/watch?v=bXF3OmOqKk0

  6. #6
    Join Date
    September 2012
    Posts
    6,076
    It works just fine, however it may not work the first time you launch TS3 after it has been installed.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  7. #7
    Join Date
    October 2003
    Location
    Germany
    Posts
    2,510
    Quote Originally Posted by oglop View Post
    still does not work in 2014 windows client!
    https://www.youtube.com/watch?v=bXF3OmOqKk0
    It is working... but the current implementation is not perfect. The problem shown in your video is caused by Windows' User Account Control (UAC) because the TS3 client is probably running on a different privilege level than your Explorer process.

    Anyway... I think there's room for improvement. What I'd really like to see in future TS3 versions is the ability to drag files out of the filebrowser window to download them. This would require a shell extension to be registered... but it's not an impossible task.


  8. #8
    Join Date
    February 2010
    Location
    Denmark
    Posts
    16

    6 Years has passed and yet drag'n'drop is still not working as DRAG & DROP feature...


  9. #9
    Join Date
    February 2010
    Location
    Denmark
    Posts
    16
    After the new update 3.1.1 (10-02-2017 08:33:58)

    I joined my teamspeak during first launch and it worked, I could drag'N'drop.

    Now I shutdown restarted TS and its the same thing again not working again!

    Log

    Code:
    13-02-2017 11:09:09		Info	TeamSpeak 3 Client 3.1.1 (2017-02-10 07:33:58)	
    13-02-2017 11:09:09		Info	SystemInformation: Windows 10 (14393) x64 (AMD or Intel) Binary: 64bit	
    13-02-2017 11:09:09		Info	Using hardware aes	
    13-02-2017 11:09:09	Direct Sound	Debug	setting timer resolution to 1ms	
    13-02-2017 11:09:09	Addons	Info	Checking for addon updates...	
    13-02-2017 11:09:09	Plugins	Info	Loading plugin: teamspeak_control_plugin.dll	
    13-02-2017 11:09:09	Plugins	Info	Loading plugin: platform_plugin.dll	
    13-02-2017 11:09:09	Plugins	Info	Api version is not compatible for plugin: D:\programmer\VoiceMix\teamspeak\3\config\plugins\platform_plugin.dll	
    13-02-2017 11:09:09	Plugins	Info	Loading plugin: admin_tools.dll	
    13-02-2017 11:09:09	Plugins	Info	Loading plugin: rp_soundboard_win64.dll	
    13-02-2017 11:09:09	Addon	Info	Addon up to date.	
    13-02-2017 11:09:09	Addon	Info	Addon up to date.	
    13-02-2017 11:09:10	Addon	Info	Addon up to date.	
    13-02-2017 11:09:10	Plugins	Info	Loading plugin: clientquery_plugin.dll	
    13-02-2017 11:09:10	Query	Info	listening on 127.0.0.1:25639	
    13-02-2017 11:09:10	Plugins	Info	Loading plugin: lua_plugin_win64.dll	
    13-02-2017 11:09:10	Plugins	Info	Loading plugin: chatlogs_win64.dll	
    13-02-2017 11:09:10	Plugins	Info	Loading plugin: gamepad_joystick_win64.dll	
    13-02-2017 11:09:10	Plugins	Info	Loading plugin: notification_plugin_win64.dll	
    13-02-2017 11:09:10	Notifications	Info	Plugin initialized; version 1.0.2 (API 21) built on Sep 26 2016 21:14:59	
    13-02-2017 11:09:10	Plugins	Info	Loading plugin: soundboard.dll	
    13-02-2017 11:09:10	Plugins	Info	Api version is not compatible for plugin: D:\programmer\VoiceMix\teamspeak\3\config\plugins\soundboard.dll	
    13-02-2017 11:09:10	Plugins	Info	Loading plugin: now_playing_x64.dll	
    13-02-2017 11:09:10	Plugins	Info	Api version is not compatible for plugin: D:\programmer\VoiceMix\teamspeak\3\config\plugins\now_playing_x64.dll	
    13-02-2017 11:09:10	Plugins	Info	Loading plugin: last_channel_win64.dll	
    13-02-2017 11:09:10	Plugins	Info	Api version is not compatible for plugin: D:\programmer\VoiceMix\teamspeak\3\config\plugins\last_channel_win64.dll	
    13-02-2017 11:09:10	Plugins	Info	Loading plugin: TS3MassMover_win64.dll	
    13-02-2017 11:09:10		Info	*** Time [PLUGINS]: 665	
    13-02-2017 11:09:10	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - enter	
    13-02-2017 11:09:10	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - leave	
    13-02-2017 11:09:10	SB	Debug	CurrentServerConnectionChanged: 1	
    13-02-2017 11:09:10		Info	*** Time [SERVERVIEWMANAGER]: 110	
    13-02-2017 11:09:10		Info	*** Time [MAINWINDOW]: 1026	
    13-02-2017 11:09:10		Info	*** Time [INIT]: 1026	
    13-02-2017 11:09:10	ClientUI	Devel	Notifications init: Soundpack path: D:/programmer/VoiceMix/teamspeak/3/sound\default	
    13-02-2017 11:09:10	ClientUI	Info	Qt version: 5.6.1	
    13-02-2017 11:09:10	ClientUI	Info	Using configuration location: D:/programmer/VoiceMix/teamspeak/3/config/settings.db	
    13-02-2017 11:09:11	ClientUI	Info	Last update check was: ma feb 13 12:01:52 2017	
    13-02-2017 11:09:11		Info	Statistics report: Not yet, next report on lÝ mar 11 08:11:59 2017	
    13-02-2017 11:09:11	ClientUI	Info	Connect to server: x	
    13-02-2017 11:09:11	ClientUI	Info	Trying to resolve x	
    13-02-2017 11:09:11	TSDNS	Info	SRV DNS resolve unsuccessful, "_tsdns._tcp.x" DNS server returned answer with no data	
    13-02-2017 11:09:11	TSDNS	Info	SRV DNS resolve unsuccessful, "_ts3._udp.x" Domain name not found	
    13-02-2017 11:09:11	TSDNS	Info	A/AAAA DNS resolve successful, "x" =(h: x p:0)	
    13-02-2017 11:09:11	TSDNS	Info	A/AAAA DNS resolve for possible TSDNS successful, "x" =(h: x p:0)	
    13-02-2017 11:09:11	TSDNS	Info	A/AAAA DNS resolve for possible TSDNS successful, "x" =(h: x p:0)	
    13-02-2017 11:09:11	Newsticker	Info	Newsticker next check: ma feb 13 12:31:53 2017	
    13-02-2017 11:09:12	TSDNS	Info	TSDNS queried unsuccessfully x
    13-02-2017 11:09:12	TSDNS	Info	No TSDNS found	
    13-02-2017 11:09:13	TSDNS	Info	TSDNS queried unsuccessfully x	
    13-02-2017 11:09:13	TSDNS	Info	No TSDNS found	
    13-02-2017 11:09:13	ClientUI	Info	Lookup finished: ip=x port=x query=x error=0	
    13-02-2017 11:09:13	ClientUI	Info	Resolve successful: x	
    13-02-2017 11:09:13	ClientUI	Info	Blacklist check ok	
    13-02-2017 11:09:13	ClientUI	Info	Initiating connection: x	
    13-02-2017 11:09:13	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - enter	
    13-02-2017 11:09:13	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - leave	
    13-02-2017 11:09:13	Windows Audio Session	Debug	WAS::openDevice-enter	
    13-02-2017 11:09:13	TSDNS	Info	A/AAAA DNS resolve successful, "blacklist.teamspeak.com" =(h: x p:0)	
    13-02-2017 11:09:13	Windows Audio Session	Devel	Format detected: Multichannel capable Float	
    13-02-2017 11:09:13	Windows Audio Session	Debug	WAS Buffer size: 1056	
    13-02-2017 11:09:13	Windows Audio Session	Debug	WAS::openDevice-leave	
    13-02-2017 11:09:13	Windows Audio Session	Debug	WAS::startDevice-enter	
    13-02-2017 11:09:13	Windows Audio Session	Debug	WAS::startDevice-leave	
    13-02-2017 11:09:13	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - enter	
    13-02-2017 11:09:13	Windows Audio Session	Devel	DeviceDeleteList::wait_for_deletes - leave	
    13-02-2017 11:09:13	Windows Audio Session	Debug	WAS::openDevice-enter	
    13-02-2017 11:09:13	Windows Audio Session	Devel	Format detected: Multichannel capable Float	
    13-02-2017 11:09:13	Windows Audio Session	Debug	WAS Buffer size: 1058	
    13-02-2017 11:09:13	Windows Audio Session	Debug	WAS::openDevice-leave	
    13-02-2017 11:09:13	PreProSpeex	Info	Speex version: speex-1.2beta3	
    13-02-2017 11:09:13	Windows Audio Session	Debug	WAS::startDevice-enter	
    13-02-2017 11:09:13	Windows Audio Session	Debug	WAS::startDevice-leave	
    13-02-2017 11:09:13	ClientUI	Info	Connect status: Connecting	
    13-02-2017 11:09:13	PktHandler	Devel	Puzzle solve time: 4	
    13-02-2017 11:09:13	ClientUI	Info	Connect status: Connected	
    13-02-2017 11:09:13	ClientUI	Info	Connect status: Establishing connection	
    13-02-2017 11:09:13	UIHelpers	Info	setClientVolumeModifier: 1 -5	
    13-02-2017 11:09:13	UIHelpers	Info	setClientVolumeModifier: 2 -16	
    13-02-2017 11:09:13	ClientUI	Info	Connect status: Connection established	
    13-02-2017 11:09:13	PermManager	Info	Loading permissions from cache	
    13-02-2017 11:09:13	SB	Debug	onUpdateClientEvent: serverId = 1, clientId = 5, invokerID = 0, invokerName = "", invokerUID = ""	
    13-02-2017 11:09:13	SB	Debug	Input state of server 1 enabled	
    13-02-2017 11:09:13	SB	Debug	TSMGR: Setting active server id: 0 -> 1	
    13-02-2017 11:09:13	SB	Info	Server Id: 1ll	
    13-02-2017 11:09:13	SB	Debug	onUpdateClientEvent: serverId = 1, clientId = 5, invokerID = 0, invokerName = "", invokerUID = ""	
    13-02-2017 11:11:19	PermissionsTree	Info	Is new permID server: 1	
    13-02-2017 11:11:19	PermissionsTree	Info	Is new permID server: 1	
    13-02-2017 11:11:19	PermissionsTree	Info	Is new permID server: 1	
    13-02-2017 11:11:19	PermissionsTree	Info	Is new permID server: 1	
    13-02-2017 11:11:19	PermissionsTree	Info	Is new permID server: 1	
    13-02-2017 11:11:39	SB	Debug	onUpdateClientEvent: serverId = 1, clientId = 2, invokerID = 0, invokerName = "", invokerUID = ""	
    13-02-2017 11:11:39	SB	Debug	onUpdateClientEvent: serverId = 1, clientId = 2, invokerID = 0, invokerName = "", invokerUID = ""	
    13-02-2017 11:15:48	SB	Debug	onUpdateClientEvent: serverId = 1, clientId = 2, invokerID = 0, invokerName = "", invokerUID = ""	
    13-02-2017 11:15:48	SB	Debug	onUpdateClientEvent: serverId = 1, clientId = 2, invokerID = 0, invokerName = "", invokerUID = ""	
    13-02-2017 11:16:02	SB	Debug	onUpdateClientEvent: serverId = 1, clientId = 2, invokerID = 0, invokerName = "", invokerUID = ""	
    13-02-2017 11:16:02	SB	Debug	onUpdateClientEvent: serverId = 1, clientId = 2, invokerID = 0, invokerName = "", invokerUID = ""
    ]

    Server log
    Code:
    13-02-2017 11:02:24	VirtualServerBase	Info	client connected 'wazer'(id:2) from x	
    13-02-2017 11:02:29	VirtualServerBase	Info	client disconnected 'wazer'(id:2) reason 'reasonmsg=leaving'	
    13-02-2017 11:02:43	VirtualServerBase	Info	client connected 'wazer'(id:2) from x	
    13-02-2017 11:05:18	VirtualServerBase	Info	file upload to (id:113), '/updater.sp' by client 'wazer'(id:2)	
    13-02-2017 11:09:29	VirtualServerBase	Info	file upload to (id:47), '/updater.sp' by client 'wazer'(id:2)	
    13-02-2017 11:09:35	VirtualServerBase	Info	client disconnected 'wazer'(id:2) reason 'reasonmsg=leaving'	
    13-02-2017 11:09:42	VirtualServerBase	Info	client connected 'wazer'(id:2) from x
    Last edited by wazer; February 13th, 2017 at 11:12 AM.

  10. #10
    Join Date
    September 2012
    Posts
    6,076
    If you run the client as admin, it will not work. That's a windows protection.
    The client will automatically be elevated by Windows if it is installed in %ProgramFiles%. This is required so that hotkeys continue to work properly in other applications.
    So there are two options:
    1) Don't use Drag n' Drop
    2) Install the client in a location other than %ProgramFiles% (or any subdirectory thereof).
    Last edited by Chris; February 14th, 2017 at 03:22 PM.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Drag & Drop in File Browser
    By MrFreeman102 in forum Windows
    Replies: 2
    Last Post: October 20th, 2013, 05:58 PM
  2. Windows 7 64bit file transfer drag and drop
    By Dangerousdave26 in forum Windows
    Replies: 3
    Last Post: March 9th, 2012, 01:06 AM
  3. [Suggestion] File Browser Drag & Drop
    By TSPB | Striker in forum Suggestions and Feedback
    Replies: 22
    Last Post: September 7th, 2010, 09:59 AM
  4. drag&drop in file browser doesnt work
    By Pumpe in forum Windows
    Replies: 6
    Last Post: February 11th, 2010, 04:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •