Forum

Results 1 to 1 of 1
  1. #1
    Join Date
    October 2015
    Posts
    1

    ModMic and Robot Voice

    I got the latest unidirectional ModMic with some Superlux headphones for use in TeamSpeak on my Mac. I'm using a USB 2.0 C-media converter to connect them to my Mac and am having a small problem. I'm only playing Diablo 3 and Heroes of the Storm with it, and my friends say my voice sounds like a robot sometimes. It's usually about an hour of usage, and then they tell me I sound like a robot. It’s only for about a minute or so and then it goes away.

    I'm running the latest version of Yosemite, and everything is up-to-date on my machine. I also have 16GB maxed-out RAM.

    Here’s the converter:
    http://www.amazon.com/Syba-SD-CM-UAU...cm_rdp_product

    Here's the headphones:
    Superlux HD668B Dynamic Semi-Open Headphones

    And the Mic:
    http://www.modmic.com/collections/mo...cts/modmic-4-0

    I was using that cheap Logitech headset for the longest time: Logitech ClearChat Comfort/USB Headset H390 (Black)

    I never ever had an issue with the mic and it also runs through USB. The only reason I upgraded was one of the headphone speakers started to go out when I would slightly move the cord connected to the mute button.

    I thought I would be upgrading with this ModMic, but if people can't even understand me right in the middle of a game, there's not much point in me keeping this thing.

    Do you think this is a problem with the USB converter or is it TeamSpeak, or is it the ModMic? I can't really get a straight answer from the ModMic people either. I tried turning off the automatic gain adjustment and noise-reduction options in TeamSpeak, but that did nothing. And it made me a lot harder to understand with background fans and such. Any ideas?
    Last edited by iOmek; October 1st, 2015 at 11:22 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Android 5.0 robot voice
    By dbownage in forum Android
    Replies: 1
    Last Post: June 14th, 2015, 05:04 PM
  2. [Resolved] Robot/mickey mouse voice problem
    By enginama in forum Windows
    Replies: 4
    Last Post: April 26th, 2012, 01:16 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •