Forum

Results 1 to 3 of 3

Hybrid View

  1. #1
    Join Date
    August 2011
    Posts
    2

    OSX high processor usage bug with workaround

    machine: 2011 macbook pro 15"
    client version: 3.0.0-rc2, 3.0.0
    os: osx snow leopard

    I started using teamspeak on osx recently by installing 3.0.0-rc2. I noticed that the ts3client was was using anywhere from 75-110% of a processor core. I hoped that the 3.0.0 release would solve the issue, and at first it appeared to. But as I got ts3 setup as before, the issue came back just as it was.

    Here's the workaround.

    By default, the ts3 client window has 3 panes that can be resized or hidden:
    left (names and channels)
    right (server and channel info)
    bottom (messages and chat)

    It turns out that it is specifically when the bottom pane is hidden that the processor utilization jumps. Upon dragging it visible again, utilization goes back to normal (~6.5%). It is easy to replicate the issue as many times as you like. Hiding the left or right panes does not affect processor utilization.

    I don't need it, but for now I'm leaving the bottom pane visible and as a result teamspeak 3.0.0 behaves as expected.

  2. #2
    Join Date
    January 2011
    Location
    US
    Posts
    260

    ToDo List High CPU Usage when the message panel is "closed"

    http://forum.teamspeak.com/showthrea...ith-workaround

    I believe this is an important bug, and the bug description is on the link above. (Not many people visit the Mac OSX section, so I think the bug report should get to this section as well.)

    Btw: I can confirm this happening in OSX Lion as well.
    Steps to reproduce:
    1. Open Teamspeak Client 3.0.0 final
    2. Hold down the "==========" border between the channel panel and the message panel. Drag the mouse down to make the message panel invisible.
    xxxxxxxxxxxxxxxxxxx
    CHANNEL || DETAIL
    =============
    Message
    xxxxxxxxxxxxxxxxxxx
    ==>
    xxxxxxxxxxxxxxxxxxx
    CHANNEL || DETAIL
    CHANNEL || DETAIL
    xxxxxxxxxxxxxxxxxxx
    3. Look at the CPU usage. I got 100% on Lion.

  3. #3
    Join Date
    June 2008
    Location
    -
    Posts
    252
    Thank you for the report, a Developer will take a look at it.

    Internal TicketID: TS-628

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: July 8th, 2015, 10:39 AM
  2. [Rejected] new Permission on Virtual Server Host Message "Message Mode" type
    By Kisuke1989 in forum Suggestions and Feedback
    Replies: 5
    Last Post: August 4th, 2014, 08:10 PM
  3. [Resolved] ServerQuery - "Open Connection" and "Banned" message issues
    By Imisnew2 in forum Bug Reports [EN/DE]
    Replies: 8
    Last Post: February 24th, 2012, 08:34 AM
  4. [On Todo] ServerQuery - "Open Connection" and "Banned" message issues
    By Imisnew2 in forum Server Support
    Replies: 3
    Last Post: February 18th, 2012, 04:24 PM
  5. Replies: 0
    Last Post: December 23rd, 2009, 08:49 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •