Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    August 2011

    I have a very strange problem...

    Ok i just recently bought a Logitech headset and i've run into a little problem. before i was using a Jabra usb headset and it worked just fine. But now, when i dont have TS3 on, everything works like it's supposed to. But as soon as i connect to my server everything except TS3 plays through my laptop speakers and TS3 works through my headset. Again, I only have this problem when using teamspeak. I have tried for hours to reconfigure my audio driver settings and TS3 settings.

    I have a HP laptop with Windows 7 Home Edition (x86) 64-bit OS.
    IDT PC Audio Driver
    My Logitech Headset plugs into the only headphone & mic jacks i have on here. I've looked everywhere on the forums and i couldn't really find anything that helped. I would greatly appreciate if anyone could find an answer for my problem. it's not that big of a problem, just very annoying. thank you.

  2. #2
    Join Date
    November 2008
    United States
    Sounds to me like you should go to TS3 > Settings > Options > playback (tab) and change the playback device to your laptop speakers and not the Headset.

    Assuming i read and understood your problem correctly.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Strange problem.
    By Ratyt in forum Windows
    Replies: 1
    Last Post: December 16th, 2014, 04:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts