Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 14 of 14
  1. #1
    Join Date
    August 2011
    Location
    TN
    Posts
    14

    Solved Problem In Creating Teamspeak Server

    I Have A BiG Problem In Creating New TS3 SERVER ON Vps Please Help Me



    The Error:

    ------------------------------------------------------------------
    I M P O R T A N T
    ------------------------------------------------------------------
    Server Query Admin Acccount created
    loginname= "serveradmin", password= ""
    ------------------------------------------------------------------

    2011-10-08 14:00:40.371160|CRITICAL|ServerLibPriv | | Server() error while starting virtualservers, halted! error: unable to bind network port


    Please Help Me

    OS : Debian

  2. #2
    Join Date
    May 2010
    Posts
    6,310
    Hello

    Are you sure that you have only one Teamspeak instance running ?
    ps -aux|grep ts3

  3. #3
    Join Date
    August 2011
    Location
    TN
    Posts
    14
    I Have A Server with The Default Port And I Want To Make Another Server In The Same Vps

  4. #4
    Join Date
    May 2010
    Posts
    6,310
    As it's write in the documentation, you have to change the port using the start parameter.
    Read this documentation : TeamSpeak 3 Server Quick Start.txt

    Part
    --------------------------
    (6) Commandline Parameters
    --------------------------

    In your second Instance folder, create an ts3server.ini file with the IP and port parameter (using other port - already use by your first instance)
    and : ts3server.startscript.sh start inifile=ts3server.ini

    Many other information, using the search function.

  5. #5
    Join Date
    August 2011
    Location
    TN
    Posts
    14
    i have run this command when i create the server and the error still

  6. #6
    Join Date
    May 2010
    Posts
    6,310
    Please post your ts3server.ini

  7. #7
    Join Date
    August 2011
    Location
    TN
    Posts
    14
    machine_id=46.234.119.17
    default_voice_port=9988
    voice_ip=46.234.119.17
    licensepath=
    filetransfer_port=30034
    filetransfer_ip=46.234.119.17
    query_port=10021
    query_ip=46.234.119.17
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    logpath=logs
    logquerycommands=0

  8. #8
    Join Date
    May 2010
    Posts
    6,310
    And you are 100% positive that these ports are not already used ?
    For test stop your both instances, check your process list, and start just the second instance.

  9. #9
    Join Date
    August 2011
    Location
    TN
    Posts
    14
    no ports are already used
    it's new vps i made it yesterday
    --- Merged ---
    If You Want You Can Come To Our TS3 Server To Talk Now

  10. #10
    Join Date
    May 2010
    Posts
    6,310
    And about this
    Quote Originally Posted by Florian
    For test stop your both instances, check your process list, and start just the second instance.

  11. #11
    Join Date
    August 2011
    Location
    TN
    Posts
    14
    i make it and doesn't want to start

  12. #12
    Join Date
    May 2010
    Posts
    6,310
    hum

    So if you have teamviewer, send me a private message with the ID and password.
    We will try to find the problem together.

  13. #13
    Join Date
    August 2011
    Location
    TN
    Posts
    14
    I Send You A Private Message With The Ip Of Our TS

  14. #14
    Join Date
    May 2010
    Posts
    6,310
    Fixed, redoing the server folders and ts3sever.ini files.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Creating a new TS 3 server problem
    By HertogJan in forum Server Support
    Replies: 6
    Last Post: October 22nd, 2014, 11:59 PM
  2. Need help creating a teamspeak server
    By wasif in forum General Questions
    Replies: 3
    Last Post: September 9th, 2014, 04:16 PM
  3. Replies: 1
    Last Post: February 14th, 2012, 09:32 AM
  4. Problem creating a TS3 server
    By Ol'Ski in forum Server Support
    Replies: 4
    Last Post: December 21st, 2009, 05:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •