Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    April 2011

    Unhappy USB headset not working in TS3

    Good afternoon all.

    I am having a issue using a USB headset with my TS client. When I fire up TS I get an error that speakers/Headphones are Disabled but I can still here systems sounds like email notifications and music, and when I run the setup wizard in the TS client the MIC is working but there just is no play back. Now if I unplug the USB headset and use the onboard mic and speakers it works fine. I am trying to use these for a language lab in a high school and this all worked last year but after a few client patches and it all of a sudden has stopped working.

  2. #2
    Join Date
    June 2002
    can you check if the headset has speakers configured for the channels? You can do this in osx preferences, audo midi setup -> audio devices ->configure speakers. If that was already set / did not help, please post a log here from a typical ts3 session startup/close.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My TS3 is not working with my headset
    By Itachi_MS in forum Client Support
    Replies: 2
    Last Post: June 14th, 2014, 02:42 PM
  2. Headset not working
    By bladeroth in forum General Questions
    Replies: 1
    Last Post: January 16th, 2013, 09:44 AM
  3. 3D not working using headset
    By BEER4LEGEND in forum Windows
    Replies: 1
    Last Post: February 16th, 2010, 09:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts