I have the problem that I can't connect to my kin's server in TS3, but I can connect to public ones.

I know this has been asked before, and I've tried many things to solve the problem, but nothing worked.

Also I'm no native english speaker and though my english is pretty good, I'm having trouble with the technical stuff, because I wouldn't even really understand that in german.
So please be lenient

-Windows XP 32bit
-TS3 Version 3.0.2
-Router Siemens ADSL C2-010-I

What the problem is in detail:

As I said, I can't connect to that one server, but I can to (most) public servers.
Deactivating firewall etc didn't help, so a friend who knows something about those things (and also with the help of this forum) tried to fix it, but the problem seems to be that I can't unblock the port on my router, I can't connect to router control panel! We used the ipconfig /all thing and I've got all the information, but when I enter the IP into internet explorer (where it should open the control thing) it just loads google.

Any ideas? I'm desperate
Sorry if anything I wrote wasn't understandable.
If someone here knows german and has a clue, that would be even more perfect, but I'm thankful for any help