Forum

Page 2 of 7 FirstFirst 1234 ... LastLast
Results 16 to 30 of 99
  1. #16
    Join Date
    January 2010
    Location
    El Prat de Llobregat (Barcelona, Spain)
    Posts
    2,699
    Hello,

    Quote Originally Posted by PeterS View Post
    Mac: Seems I forgot the file associations for *.ts3_xxx on Mac. Will fix that.
    Mac: Any alternative for using the *.ts3_xxx meanwhile? How can a Mac user "launch" the file?

    Quote Originally Posted by PeterS View Post
    Linux: Due to various window managers with their own handling of file associations this is difficult. However, Linux users can start the package_installer binary directly and give the *.ts3_xxx file as parameter.
    Well, it seems that Linux users are "bound" to work in manual mode. ;-)

    This has inspired me a suggestion: Why not having a subdirectory for *.ts3_xxx package files and then "select and launch them" from the TS3 client directly, instead of using external file association?.

    Greetings.

  2. #17
    Join Date
    June 2008
    Posts
    17,241
    Mac needs to be fixed and then it will be possible to use it.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #18
    Join Date
    October 2003
    Location
    Germany
    Posts
    2,390
    Quote Originally Posted by PotaBlava View Post
    An issue with the add-on website: not all the suffixes related with the Package files are identified. Some (.ts3_addon, .ts3_style) appear with a button that says "Install Now" and others, case of ".ts3_translation", the button shows "Download".
    Fixed. Thank you for reporting this.


  4. #19
    Join Date
    June 2008
    Location
    Krün, Germany
    Posts
    510
    Quote Originally Posted by PeterS View Post
    Mac: Seems I forgot the file associations for *.ts3_xxx on Mac. Will fix that.
    I admit I violated the "think first, post later" rule here. Those file associations do exist on Mac, they are included in the Info.plist file inside the package_installer app bundle (which is bundled inside the TeamSpeak 3 client app bundle).

    Now file associations on Mac work a bit different than on Windows. You have to start the application once so Mac OS X can add the file associations read from the bundles Info.plist. On Windows one would just add them to the registry and Windows knows without starting package_installer.exe.

    Now, although the file associations already exist, they are never registered because nobody starts package_installer manually, as it's hidden inside the TeamSpeak bundle. One could open the TeamSpeak 3 app bundle manually in Finder, navigate to the package_installer bundle and start this once. Then *.ts3_xxx files are properly clickable on Mac. But that is, well, not a great way. I need to think about something better...

    Sorry for the confusion.

  5. #20
    Join Date
    May 2007
    Location
    Eastern NC
    Posts
    1,724
    I thought would be:

    In the Application area of Options window in TS3 add a "Set installer package file association" button. Have that call the installer and pass a "null action" parameter.

    Could also add a screen for this to the Setup Wizard with a check box to set installer package file association. Wizard runs on first run so that should help.

  6. #21
    Join Date
    January 2010
    Location
    Catalunya
    Posts
    2,350
    Quote Originally Posted by PeterS View Post
    Linux: Due to various window managers with their own handling of file associations this is difficult. However, Linux users can start the package_installer binary directly and give the *.ts3_xxx file as parameter.
    In Linux, it works as you say, but it really is much easier to use .zip

  7. #22
    Join Date
    June 2008
    Location
    Krün, Germany
    Posts
    510
    I found a way to properly register the package installer file associations on Mac OS X for release 3.0.3.

    Until then, there is a workaround: Just move the TeamSpeak 3 Client application to another folder and back to the original place. Actually my original theory, that the registration takes place when starting the package installer, was wrong. It takes place when installing the application or moving it. Now I suppose that the problem occured when someone installed a TeamSpeak client from before the package installer and then updated it, so installation or moving never took place. But that should be solved with 3.0.3.

    Thanks for the feedback, I would not have noticed as the file associations were already in place on my dev box.

  8. #23
    Join Date
    June 2008
    Posts
    17,241

    Feedback for our "TeamSpeak 3 Package Installer"

    I moved all post's from sticky TeamSpeak-3-Package-Installer thread into this section.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  9. #24
    Join Date
    December 2011
    Location
    Surakarta - SOLO
    Posts
    3
    Hi all, nice explanation for this Package Installer.
    I have created 2 skins, and uploaded as .ZIP, since I can't make the installer work. A friend of mine did the package.ini at his place, and zip it, change to .ts3_style send to me. The launcher works (Tho the name doesn't show, so it install nothing). But so far, he was able to launch the installer.

    I tried to unzip his version. Open the package.ini, put underscore for the name, and save it again. once more, can't run the installer, it gives me error again.

    Failed to extract Add-on :
    Failed to extract:<name>/package.ini

    If it is something related to UTF-8, I have tried from Notepad, and Notepad ++, and still the same.

    Any help will be great.
    Thanks

  10. #25
    Join Date
    December 2011
    Posts
    6
    At the end it Alwaya says failed! What can i do?

  11. #26
    Join Date
    January 2010
    Location
    Catalunya
    Posts
    2,350
    Quote Originally Posted by Bouma View Post
    Tho the name doesn't show, so it install nothing
    With Notepad ++ is required to encode: UTF-8 without BOM

  12. #27
    Join Date
    June 2008
    Location
    Krün, Germany
    Posts
    510
    Regarding translations, which was discussed on the first page of this thread, I made the package installer, updater and error reporter dynamically translatable. This will be included in 3.0.6 beta, so once that's out, please contact us (dante or me) to get access to empty translation files.

    The Windows NSIS installer can be translated, but only at build, so adding dynamic translations won't work. If anyone wants to translate the NSIS installer, please contact me (whenever, no 3.0.6 beta client required for this).

  13. #28
    Join Date
    January 2010
    Location
    Catalunya
    Posts
    2,350
    Regarding translations, which was discussed on the first page of this thread, I made the package installer, updater and error reporter dynamically translatable. This will be included in 3.0.6 beta, so once that's out, please contact us (dante or me) to get access to empty translation files.
    Ok, we'll do it

  14. #29
    Join Date
    June 2008
    Posts
    17,241
    You can contact me, when 3.0.6 (beta or stable) has been released.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  15. #30
    Join Date
    January 2010
    Location
    Hinterfeitupfing
    Posts
    36
    Well, looks like a nice feature. But I there is no way to upload an installer for Win32 and another one for Win64. I can only upload one file, so I have to distribute it within a zip file (source for linux included).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: July 8th, 2015, 11:39 AM
  2. "Installer Integrity Error" during install
    By CloudGT4 in forum Windows
    Replies: 1
    Last Post: August 3rd, 2012, 08:51 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •