Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 24
  1. #1
    Join Date
    January 2010
    Location
    UK
    Posts
    12

    newer MySQL support

    Hi All

    With Active development of MySQL 5.0 ceasing back in 2010, I have been having a bit of a look round the forums to see if I can find anything about Teamspeak server intending to support MySQL 5.1, but have not found anything.

    As this is the only thing on my server that still REQUIRES 5.0 to run, I'm really looking to get MySQL updated to the latest stable version, so thought I'd just ask if there's any plans to get this to work with 5.1.

    --- Merged ---

    I'm guessing by the distinct lack of response to this that Teamspeak doesn't intend to support MySQL 5.1 any time soon.

    If someone could confirm this, that would put my mind at ease, and I know I might need to look into alternative solutions to upgrading to >5.0.
    Last edited by florian_fr40; January 26th, 2012 at 09:05 AM.

  2. #2
    Join Date
    May 2010
    Posts
    6,310
    Hello

    Do you got an error message ?
    Please post the server log.

  3. #3
    Join Date
    January 2010
    Location
    UK
    Posts
    12
    The problem is that MySQL 5.1 comes with libmysqlclient.so.16, where teamspeak looks strictly for libmysqlclient.so.15 (the 5.0 version of this).

    there's a few other posts I found on the forums about this, but nothing about how to get it working on 5.1.

    Edit:

    I've just updated MySQL, and the error is:


    2012-01-26 17:15:56.087615|INFO |ServerLibPriv | | Server Version: 3.0.0-rc1 [Build: 14468], Linux
    2012-01-26 17:15:56.098407|INFO |DatabaseQuery | | Please make sure you use the supplied ts3server_minimal_runscript.sh to run the server, or set LD_LIBRARY_PATH yourself
    2012-01-26 17:15:56.098458|CRITICAL|DatabaseQuery | | unable to load database plugin library "libts3db_mysql.so", halting!

    This is using exactly the same init script as before, the only difference, the mysql version.
    Last edited by sdousley; January 26th, 2012 at 05:27 PM. Reason: Extra info

  4. #4
    Join Date
    May 2010
    Posts
    6,310
    There is several thread to know how to download the libmysqlclient15off.
    What is your linux distrib that I merged your Thread in the good one ?

    Edit
    Other way, using the search function :
    http://forum.teamspeak.com/showthrea...linux.../page3
    http://forum.teamspeak.com/showthrea...sql.so-halting
    Last edited by florian_fr40; March 27th, 2012 at 09:50 AM.

  5. #5
    Join Date
    January 2010
    Location
    UK
    Posts
    12
    My Distribution of linux is Gentoo, which compiles all the sources from scratch.

    Personally, instead of having to put some form of workaround in, would it not be better if it could just use the 5.1 libraries?

  6. #6
    Join Date
    January 2010
    Location
    UK
    Posts
    12
    Sorry to bring this back up, but I've been as yet totally unable to get anything working on MySQL 5.1, instead of putting in workarounds like getting a libmysqlclient.so.15, it'd be better for this to work with mysql 5.0 or 5.1? Is this possible at all?

  7. #7
    Join Date
    December 2004
    Location
    RF
    Posts
    3,002
    It is possible.
    Devs just have to learn, how to use libs properly...

  8. #8
    Join Date
    January 2010
    Location
    UK
    Posts
    12
    lol it's just a pain that it's still not even seemingly being worked on by Teamspeak, meaning that they are forcing their server administrators to use versions of 3rd party software that are vulnerable to fairly large issues.

    For the attention of whoever might be interested, here's the bug I'm referring to: http://www.gentoo.org/security/en/gl...-201201-02.xml

    Basically allows users (under the right circumstances) to execute shell commands through mysql - not good at all!

  9. #9
    Join Date
    January 2010
    Location
    Germany
    Posts
    2,029
    not to mention that MySQL 5.1 is fairly old itself, current Version of MySQL beeing 5.5

  10. #10
    Join Date
    January 2010
    Location
    UK
    Posts
    12
    True, but at least 5.1 is stull under active development unlike 5.0

  11. #11
    Join Date
    January 2012
    Posts
    1
    Quote Originally Posted by sdousley View Post
    My Distribution of linux is Gentoo, which compiles all the sources from scratch.

    Personally, instead of having to put some form of workaround in, would it not be better if it could just use the 5.1 libraries?
    There's several thread to understand how to download the libmysqlclient15off.

  12. #12
    Join Date
    January 2010
    Location
    UK
    Posts
    12
    Few people have said this, but searching for "libmysqlclient.so.15" seems to return nothing, so if you could provide some links, I'm more than willing to give it a try, though personally, I'd prefer TS to just work with 5.1 rather than use vulnerable 3rd party software.

  13. #13
    Join Date
    January 2010
    Location
    UK
    Posts
    12
    Quote Originally Posted by florian_fr40 View Post
    There is several thread to know how to download the libmysqlclient15off.
    What is your linux distrib that I merged your Thread in the good one ?
    Do you have any more ideas on this? or any view to changing TS to support mysql 5.1? I can see more and more people moving to other solutions if this isn't updated any time soon.

  14. #14
    Join Date
    February 2010
    Location
    localhost
    Posts
    9
    Wow, anotherone with the same problem like me. I "solved" this for pre 3.0.6 by compiling the "old" mysql client version to another directory and put this directory into the LD_LIBRARY_PATH. Currently 3.0.6 dont want to load this file anyways but it worked good with <= 3.0.5

    It can't be that hard to use the libmysqlclient.so.16, pls fix this!

  15. #15
    Join Date
    January 2010
    Location
    UK
    Posts
    12
    What I'd like to see is an actual member of Teamspeak staff respond to this, with any potential intention of supporting this.

    From what I can see, it only seems to be teamspeak users responding to this, and no actual teamspeak developer/support person.

    Working with libraries properly, shouldn't be too hard to get this working with MySQL 5.1 surely?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Any one been able to start server with mysql support
    By DarKZONE in forum Linux / FreeBSD
    Replies: 3
    Last Post: December 22nd, 2009, 10:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •