Forum

Results 1 to 10 of 10
  1. #1
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,354

    Solved ServerQuery sendtextmessage BBCode color bug if starting with a newline

    The following bug occur with TS3 client 3.0.3 final (Windows version tested). If you send a chat message starting with a newline \n, all color BBCodes in that chat message don't work. Example:

    Working color BBCode:
    Code:
    sendtextmessage targetmode=1 msg=[color=green]Hello[\/color]\s[color=#FF0000][u]Stefan1200[\/u][\/color]\n target=2
    Looks like:
    Hello Stefan1200

    Not working color BBCode:
    Code:
    sendtextmessage targetmode=1 msg=\n[color=green]Hello[\/color]\s[color=#FF0000][u]Stefan1200[\/u][\/color]\n target=2
    Looks like:

    Hello Stefan1200

  2. #2
    Join Date
    June 2008
    Posts
    18,224
    I can reproduce this, but i get some new interesting errors.

    I cant send any message after i have tried your second text. Please note, that the target needs to be in front of the message

    Code:
    sendtextmessage targetmode=3 target=4 msg=Hello
    error id=256 msg=command\snot\sfound
    sendtextmessage targetmode=3 target=4 msg=Hello
    error id=0 msg=ok

    I send it to one of our testers this needs further testing.

    ----note----
    - I used putty for testing
    - I have tested following commands
    Code:
    sendtextmessage targetmode=3 target=4 msg=[color=green]Hello[\/color]\s[color=#FF0000][u]Stefan1200[\/u][\/color]
    message was ok
    
    sendtextmessage targetmode=3 target=4 msg=\n[color=green]Hello[\/color]\s[color=#FF0000][u]Stefan1200[\/u][\/color]
    message was like reported, but i could not send any message after this one
    Last edited by dante696; February 14th, 2012 at 09:27 AM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    June 2008
    Location
    -
    Posts
    252
    Same if you just use "set font color" clientside.
    Thank you.

    InternalTicketID: TS-861

  4. #4
    Join Date
    June 2008
    Location
    -
    Posts
    252
    I marked this as "No Bug" because it's working as intended.
    Only the first line accepts the [color] code to prevent chat-nickname abuse.
    This is since we fixed some "right-to-left - arabic character" problems.

  5. #5
    Join Date
    May 2007
    Location
    Eastern NC
    Posts
    1,799
    What is the point of preventing colors when [url=client......] still works on lines after the first. I know some of us use that in plugins for valid reasons, but I can type that in by hand just the same.

  6. #6
    Join Date
    January 2011
    Location
    Missouri
    Posts
    26

    Question Colored chat and newlines

    I've noticed that since the update where they added in the LUA menu thing, that for LUA scripts if there is a newline "\n" inside of a color it will nullify all the colors and make the text just pure black. I use a lot of colors in my LUA addon and it kind of looks uglier in just pure black.

    Screenshot 1

    Screenshot 2

    *** Thread Merged ***
    Similar question.
    Last edited by florian_fr40; February 24th, 2012 at 08:50 AM.

  7. #7
    Join Date
    June 2008
    Location
    -
    Posts
    252
    You got it.
    We re-opened the ticket to discuss about it and maybe [color] comes back again.
    Last edited by MuhChy; February 24th, 2012 at 03:19 PM.

  8. #8
    Join Date
    January 2011
    Location
    Missouri
    Posts
    26
    Thank you that would be great.

  9. #9
    Join Date
    June 2008
    Posts
    18,224
    The colors for new lines are back and an arrow in front of every new message was added.

    Please wait for release 3.0.6
    Last edited by MuhChy; March 1st, 2012 at 01:27 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  10. #10
    Join Date
    January 2011
    Location
    Missouri
    Posts
    26
    Thank you! That's great news.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: January 14th, 2011, 09:54 PM
  2. [No bug] sendtextmessage bug
    By Trekkan in forum Bug Reports [EN/DE]
    Replies: 2
    Last Post: August 13th, 2010, 10:22 PM
  3. serverquery and bbcode: which codes are supported and where?
    By MindcrimeNL in forum General Questions
    Replies: 3
    Last Post: March 29th, 2010, 04:50 PM
  4. [Rejected] BBcode or Color in channel name plz
    By Baphomet in forum Suggestions and Feedback
    Replies: 1
    Last Post: March 15th, 2010, 02:09 PM
  5. ServerQuery sendtextmessage
    By benv666 in forum General Questions
    Replies: 4
    Last Post: January 27th, 2010, 06:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •